mint won't start after changing desktop effects settings [SOLVED]

Forum rules
Before you post please read how to get help
Post Reply
dolfijn
Level 1
Level 1
Posts: 7
Joined: Thu May 22, 2014 3:32 pm

mint won't start after changing desktop effects settings [SOLVED]

Post by dolfijn » Mon Feb 26, 2018 7:32 pm

hello,

I'm using Mint KDE 17.1 LTS but it won't start any more. I get the KDE logo but then I have to wait forever or the PC reboots itself. Shortly before this happened, I changed the desktop effects settings: the Qt graphics system or the Compositing type. I hope to fix this by changing these settings back to default using a live USB stick. I did some research and learned that the config files should be here: home/username/.kde/share/config
But I can't find a file that looks like it contains the desktop effects settings. Where can I find the right file and how should I change it?
Thanks!
Last edited by dolfijn on Thu Mar 08, 2018 8:29 pm, edited 1 time in total.

thunder422
Level 2
Level 2
Posts: 53
Joined: Wed May 16, 2012 7:26 am

Re: mint won't start after changing desktop effects settings

Post by thunder422 » Wed Feb 28, 2018 8:20 am

The specific configuration file you are looking for is /home/username/.kde/share/config/.kwinrc. The section for the desktop effects are in the [Plugins] section - they all start with "kwin4_effect_...". Looks like the compositing settings are in the [Compositing] section.

What you could do is simply copy this file from the Live session on top of the one in your installation to bring it back to its default configuration. You could make a backup of the current file first (say rename it to ".kwinrc-bad") and then compare the two to see what setting or settings that is preventing it from starting.
Mint 17.3 KDE: AMD FX-6300, 16GB RAM, GTX 660Ti (2GB), Gigabyte 990FXA-UD5
(with Windows XP, Windows 10, and Mint 18.3 KDE VMs on VirtualBox)

daret
Level 2
Level 2
Posts: 79
Joined: Sun Sep 30, 2012 8:42 am

Re: mint won't start after changing desktop effects settings

Post by daret » Wed Feb 28, 2018 9:38 am

Easy way is to remove the whole .kde directory. You will loose your settings and revert to default, but kde should start.
  • Boot to console (recovery)
  • login
  • Remove ".kde" directory

    Code: Select all

    rm -r ~/.kde

dolfijn
Level 1
Level 1
Posts: 7
Joined: Thu May 22, 2014 3:32 pm

Re: mint won't start after changing desktop effects settings

Post by dolfijn » Thu Mar 01, 2018 6:32 pm

Thanks, thunder422, that is the right file! I changed back the "graphics system" setting to "raster". That helped, but only a little. Mint starts but the desktop is a mess. The wallpaper is cluttered with big white blocks, and if I click on anything with the mouse, nothing happens. So I tried setting the Compositing type back to the default value. But I had to guess how, the only line in the file that seems the right one is "backend=Xrender". When changed Xrender into "OpenGL 2.0" it only made things worse: my PC resets itself. So I changed that back again.
Here is the present content of the [compositing] section of my kwinrc file:
animationspeed=3
Backend=Xrender
Enabled=true
GL colorcorrection=false
GL legacy=false
GL preferbufferSwap=4
GL texture filter=2
Graphics system=raster
hiddenpreviews=5
Open GL is unsafe=false
unredirectFullscreen=false
XrenderSmoothscale=false

What can I change here to fix my problem?

"What you could do is simply copy this file from the Live session on top of the one in your installation to bring it back to its default configuration." That's a great idea, but I can't find the kwinrc file on the USB stick. Where is it?
Thanks for your help,

thunder422
Level 2
Level 2
Posts: 53
Joined: Wed May 16, 2012 7:26 am

Re: mint won't start after changing desktop effects settings

Post by thunder422 » Sat Mar 03, 2018 9:46 am

You have to start a Live session, and then navigate to that directory to get the default kwinrc file. If you don't have access to you actual system (you will have to mount it), then copy kwinrc to another USB drive. End the Live session and boot up your actual system.

I created a temporary VM and started a Live session. The default kwinrc Compositing section is:

Backend=XRender
GraphicsSystem=native
OpenGLIsUnsafe=false

If I just go into the Desktop Effects setting and look at each tab without changing anything, the Compositing section changes to (AnimationSpeed and Enabled are added):

AnimationSpeed=3
Backend=XRender
Enabled=true
GraphicsSystem=native
OpenGLIsUnsafe=false

By the way, not sure this is useful, but my current Compositing section looks like this:

AnimationSpeed=3
Backend=OpenGL
Enabled=true
GLColorCorrection=false
GLCore=true
GLLegacy=false
GLPreferBufferSwap=a
GLTextureFilter=2
GraphicsSystem=native
HiddenPreviews=5
OpenGLIsUnsafe=false
UnredirectFullscreen=false
XRenderSmoothScale=false

But this may not work for you (this is with a NVidia graphics card). However, curious differences are the spaces in the settings (e.g. "GL colorcorrection" vs. "GLColorCorrection"). I'm not sure spaces in the names are valid. Also the case of some of the settings is different - I'm not sure these settings are case-insensitive. If you typed these into the message instead of copying and pasting directly from kwinrc, that could explain the differences. Other differences are GLCore is missing from your settings, GLPreferBufferSwap is "a" vs. "4" (may be a hexadecimal number), and GraphicsSystem is "native" vs. "raster" (which may be due to "OpenGL" vs. "Xrender" for Backend). I checked a second system I have (also with a NVidia card) and it is identical to above except "Backend=Xrender".
Mint 17.3 KDE: AMD FX-6300, 16GB RAM, GTX 660Ti (2GB), Gigabyte 990FXA-UD5
(with Windows XP, Windows 10, and Mint 18.3 KDE VMs on VirtualBox)

dolfijn
Level 1
Level 1
Posts: 7
Joined: Thu May 22, 2014 3:32 pm

Re: mint won't start after changing desktop effects settings

Post by dolfijn » Thu Mar 08, 2018 8:28 pm

I have tried a lot of things the past few days, but none helped. I tried all 4 combinations of Backend=XRender/raster
GraphicsSystem=native/openGL. Then I deleted the whole Compositing section. Next I deleted the entire kwinrc file.
So eventually, I deleted the .KDE folder and that solved the problem.
Daret, I didn't try this earlier because it seemed very risky. I didn't know that the system automatically rereates the .KDE folder. If I had known that, I would have tried it earlier.
I now lost my desktop settings which gave me some new problems, but I will start new topics on that to keep things tidy.
BTW, I read on this site that Linux Mint is going to stop with KDE! That's really frustrating. What are you going to do? Switch to Gnome or MATE or to a different Linux distro with KDE?

thanks for your help,

Post Reply

Return to “KDE”