[CLOSED] Mint 15 KDE language setting

Forum rules
Before you post please read how to get help
User avatar
nomko
Level 9
Level 9
Posts: 2986
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

[CLOSED] Mint 15 KDE language setting

Post by nomko »

Hi,

Just installed Mint 15 KDE for testing. But when i go to: Menu > Computer > System settings > Language/Region. There i want to change the language to Dutch (Nederlands) but all i get is a black screen and nothing i can do there. I can clearly see that Dutch and English are installed. How can i solve this?

See screenshot:
http://imageshack.com/scaled/large/24/2ir.png
Last edited by nomko on Sat Aug 17, 2013 3:42 am, edited 1 time in total.

User avatar
nomko
Level 9
Level 9
Posts: 2986
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: Mint 15 KDE language setting

Post by nomko »

Nobody wanna help me?????

User avatar
Snapcase
Level 3
Level 3
Posts: 135
Joined: Wed Jul 03, 2013 5:27 pm

Re: Mint 15 KDE language setting

Post by Snapcase »

It's summer. Folks are in the beach. Normaly the forums run slow in summertime. Only morons like me prefer to sip some beer in front of a computer by a big fan... :mrgreen:

Did you deleted locales (language packages) with BleachBit or Terminal or something like that?

User avatar
Snapcase
Level 3
Level 3
Posts: 135
Joined: Wed Jul 03, 2013 5:27 pm

Re: Mint 15 KDE language setting

Post by Snapcase »

Huh, wait. The same is happening here. It didn't showed like this a few days ago. Surely we disabled some startup services. Do you have BootUpManager or a similar app installed?

User avatar
nomko
Level 9
Level 9
Posts: 2986
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: Mint 15 KDE language setting

Post by nomko »

Snapcase wrote:Did you deleted locales (language packages) with BleachBit or Terminal or something like that?
Snapcase wrote:Huh, wait. The same is happening here. It didn't showed like this a few days ago. Surely we disabled some startup services. Do you have BootUpManager or a similar app installed?
Nope, it happens after a fresh/new/clean installation.
Didn't do anything.

Just did a new/fresh/clean installation and now just half of everything is in Dutch and the other half in English... But this: http://imageshack.com/scaled/large/24/2ir.png is still there.

User avatar
Snapcase
Level 3
Level 3
Posts: 135
Joined: Wed Jul 03, 2013 5:27 pm

Re: Mint 15 KDE language setting

Post by Snapcase »

The same happens here, but I disabled a whole lot of unwanted services and deleted all the language packs ecepting Spanish and English. Anyway, My OSs are always in english and never use any other language packages myself, only for other accounts, for my relatives. Gonna check that in a fresh new account and see what happens there.
Last edited by Snapcase on Wed Jul 24, 2013 10:58 am, edited 1 time in total.

User avatar
Snapcase
Level 3
Level 3
Posts: 135
Joined: Wed Jul 03, 2013 5:27 pm

Re: Mint 15 KDE language setting

Post by Snapcase »

Same issue in a fresh new created accout selected to be in Spanish. It remains in English language and the shaded screen is there.... A bug? :roll:

Zalbor
Level 4
Level 4
Posts: 321
Joined: Tue Apr 19, 2011 11:53 am

Re: Mint 15 KDE language setting

Post by Zalbor »

I've reported the same problem, and so have others in other threads and on launchpad.

For now, there's packages that you can install from synapic. I'm not at home so I don't remember the names, but I think there's "lang" and "kde" in their names.

User avatar
nomko
Level 9
Level 9
Posts: 2986
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: Mint 15 KDE language setting

Post by nomko »

Just updated my system and guess what.... Most issues has been solved. Still checking the complete installation for errors in language settings. But this: http://imageshack.com/scaled/large/24/2ir.png still remains grey...

phill1978
Level 3
Level 3
Posts: 176
Joined: Fri Apr 22, 2011 5:19 am

Re: Mint 15 KDE language setting

Post by phill1978 »

i swear to god :evil:

i reported this in mint 14 KDE on the official bug tracker and on here ! i made many posts. i had to do a fresh install, because i ((was)) using an @ key in my password and that meant on login i had to type shift+2 to get an @ as the keyboard language is messed, i think its because they integrated the keyboard language thing in Mint (badly)

ohh well im starting to think i should give Suse or Fedora a go mint seems to be sliding a bit because it maintains too many versions and updates before fixing important stuff

Zalbor
Level 4
Level 4
Posts: 321
Joined: Tue Apr 19, 2011 11:53 am

Re: Mint 15 KDE language setting

Post by Zalbor »

Look in synaptic for packages whose name contains "language-pack-kde-". The last bit of the name corresponds to a language. If you find the right package and install it, I'm pretty sure that it will install everything that window would.
phill1978 wrote:i had to do a fresh install, because i ((was)) using an @ key in my password and that meant on login i had to type shift+2 to get an @ as the keyboard language is messed, i think its because they integrated the keyboard language thing in Mint (badly)
You don't have to do a reinstall because you were using the wrong keyboard layout. It's not even related to this bug. The settings for that are in System Settings > Input Devices > Keyboard > Layouts.

User avatar
Snapcase
Level 3
Level 3
Posts: 135
Joined: Wed Jul 03, 2013 5:27 pm

Re: Mint 15 KDE language setting

Post by Snapcase »

Just updated my system and guess what.... Most issues has been solved.
Yes, the issues I was finding in the RC version I intsalled went away after updating to the final release, but didn't noticed if this one was already there before updating. I don't need it at this moment, but at some point I'll have to make new user accounts for any of my relatives and they must be in Spanish.

Anyway. Maybe this is related with this issue. When I check the updates available in the Update manager (refresh showing individual files) there are plenty of packages reported as failed. They all are Translation_en or Translation_en-US packages. It's the same for you, Nomko?

elianus
Level 1
Level 1
Posts: 1
Joined: Sat Jul 27, 2013 4:11 am

Re: Mint 15 KDE language setting

Post by elianus »

nomko wrote:Hi,

Just installed Mint 15 KDE for testing. But when i go to: Menu > Computer > System settings > Language/Region. There i want to change the language to Dutch (Nederlands) but all i get is a black screen and nothing i can do there. I can clearly see that Dutch and English are installed. How can i solve this?

See screenshot:
http://imageshack.com/scaled/large/24/2ir.png
Yesterday I made a fresh installation. No any problem; whole system in Dutch.

User avatar
Shimapan
Level 1
Level 1
Posts: 16
Joined: Sun Aug 04, 2013 4:16 pm

Re: Mint 15 KDE language setting

Post by Shimapan »

nomko wrote:Just did a new/fresh/clean installation and now just half of everything is in Dutch and the other half in English... But this: http://imageshack.com/scaled/large/24/2ir.png is still there.
It tries to download the language files from the internet, but it can't do that, because you're not connected to the internet, and thus it's stuck at 0%.
Close the dialog, connect to the internet, and open it up again, and it will download the language files.

User avatar
nomko
Level 9
Level 9
Posts: 2986
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: Mint 15 KDE language setting

Post by nomko »

Shimapan wrote:
nomko wrote:Just did a new/fresh/clean installation and now just half of everything is in Dutch and the other half in English... But this: http://imageshack.com/scaled/large/24/2ir.png is still there.
It tries to download the language files from the internet, but it can't do that, because you're not connected to the internet, and thus it's stuck at 0%.
Close the dialog, connect to the internet, and open it up again, and it will download the language files.
I'm always connected to the internet by Powerlan connection. So that's not the issue or problem here.

Arny006
Level 1
Level 1
Posts: 30
Joined: Tue Apr 02, 2013 5:49 am
Location: Munich, Germany

Re: Mint 15 KDE language setting

Post by Arny006 »

I had the same problem with Kubuntu 12.10-13.04 Mint 14 KDE. Mint 15 is present only in Cinnamon I want to transform/replace with KDE.

Since more than one year I noticed no possibility to choice a language in the systemsettings (Alt F2 + kdesudo systemsettings) and install those directly from there as in the past, so as the other mates suggest the solution is to install (over "synaptic") languages and choice default/preferred language in the systemsettings.
The installation through the systemsettings was perfect cause of also language packs for Firefox and Thunderbird was installed.

Due the fact that I'm a language freak I made a list of languages and store it to easy install those each time I want. Here the list that you can use also in the terminal-command-line. For those want implement also vocabularies and syntax-correction are here also proposal.

Sorry for late answer & Enjoy:

Code: Select all

sudo apt-get -y -m -f install language-pack-kde-de language-pack-kde-en language-pack-kde-es language-pack-kde-fr language-pack-kde-ia language-pack-kde-it language-pack-kde-ja language-pack-kde-pt language-pack-kde-ru language-pack-kde-zh-hant language-pack-gnome-de-base language-pack-gnome-en-base language-pack-gnome-es-base language-pack-gnome-fr-base language-pack-gnome-ia-base language-pack-gnome-it-base language-pack-gnome-ja-base language-pack-gnome-pt-base language-pack-gnome-ru-base language-pack-gnome-zh-hans-base language-pack-gnome-zh-hant-base hunspell hunspell-tools goldendict libtext-hunspell-perl hunspell-de-de-frami hunspell-de-ch-frami hunspell-de-at-frami hunspell-en-ca hunspell-en-us hunspell-fr hunspell-ru acheck aspell aspell-doc aspell-de aspell-en aspell-es aspell-fr aspell-it aspell-pt-br aspell-pt-pt aspell-ru inkscape libpadre-plugin-spellcheck-perl libraspell-ruby libtest-spelling-perl libtext-aspell-perl firefox firefox-locale-de firefox-locale-en firefox-locale-es firefox-locale-fr firefox-locale-it firefox-locale-ja firefox-locale-pt firefox-locale-ru firefox-locale-zh-hans firefox-locale-zh-hant thunderbird thunderbird-locale-de thunderbird-locale-en thunderbird-locale-en-gb thunderbird-locale-en-us thunderbird-locale-es thunderbird-locale-es-ar thunderbird-locale-es-es thunderbird-locale-fr thunderbird-locale-it thunderbird-locale-ja thunderbird-locale-pt thunderbird-locale-pt-br thunderbird-locale-pt-pt thunderbird-locale-ru thunderbird-locale-zh-cn thunderbird-locale-zh-hans thunderbird-locale-zh-hant thunderbird-locale-zh-tw

language-pack-kde-zh-hans 

Languages and corrections:

- Hunspell
- GNU Aspell
To solve update issue use following command in the terminal

Code: Select all

sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade && sudo update-grub

sudo apt-get -y update && sudo apt-get -y upgrade && sudo apt-get -y dist-upgrade && sudo update-grub

sudo apt-get -y -m -f update && sudo apt-get -y -m -f upgrade && sudo apt-get -y -m -f dist-upgrade && sudo update-grub
Vista Ultimate 64 bit on BIOS-RAID 0+1
W7 Ultimate 64 bit on BIOS-RAID 0+1
Kubuntu 12.10 64 bit on sde6
Kubuntu 13.04 64 bit on sde7
Mint 14 Kde 64 bit on sde8
Mint 15 Kde 64 bit on sde9
Ultimate Edition 3.5 64 bit on sde10

User avatar
Snapcase
Level 3
Level 3
Posts: 135
Joined: Wed Jul 03, 2013 5:27 pm

Re: Mint 15 KDE language setting

Post by Snapcase »

Great tip, Thank you!

In my case it's not a bug. I noticed I disabled the languages so only English is currently installed. I'll install extra packages following your advice when needed in september. :wink:

Arny006
Level 1
Level 1
Posts: 30
Joined: Tue Apr 02, 2013 5:49 am
Location: Munich, Germany

Re: Mint 15 KDE language setting

Post by Arny006 »

Snapcase wrote:Great tip, Thank you!

In my case it's not a bug. I noticed I disabled the languages so only English is currently installed. I'll install extra packages following your advice when needed in september. :wink:
My is just an example for how to and not a list for you. You can build your list e.g. "en" + "nl" by change for each type the last part. E.g.:

Code: Select all

language-pack-kde-nl
.
Don't forget to set the preferred language in "systemsettings" as User and with "Alt + F2" and insert "kdesudo systemsettings" as Root/Admin.
If you omit one of last part (Settings), can happen that User or Admin different preferred language have, hence, e.g. the admin CLI is in english.

The same happen e.g. Mint KDE if you set/change the standatd color to obsidian-coast (dark) but omit to do also in Admin-Systemsettings. The result here is an Dolphin (File-Manager) with one dark and one bright row.

In this way p.e. you can set a blue mouse-pointer for User and a red-one for Admin. Each time you start an application with Admin-rights you mouse-pointer will change color.

enjoy
Vista Ultimate 64 bit on BIOS-RAID 0+1
W7 Ultimate 64 bit on BIOS-RAID 0+1
Kubuntu 12.10 64 bit on sde6
Kubuntu 13.04 64 bit on sde7
Mint 14 Kde 64 bit on sde8
Mint 15 Kde 64 bit on sde9
Ultimate Edition 3.5 64 bit on sde10

Zalbor
Level 4
Level 4
Posts: 321
Joined: Tue Apr 19, 2011 11:53 am

Re: [CLOSED] Mint 15 KDE language setting

Post by Zalbor »

Why is this thread marked "CLOSED"? There's neither a solution to the problem (only workarounds) nor is it offensive to anyone.

User avatar
nomko
Level 9
Level 9
Posts: 2986
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: [CLOSED] Mint 15 KDE language setting

Post by nomko »

Zalbor wrote:Why is this thread marked "CLOSED"? There's neither a solution to the problem (only workarounds) nor is it offensive to anyone.
For the reason i ditched KDE for the reason of being to buggy.

Post Reply

Return to “KDE”