<SOLVED> Mint 15 KDE will not shut down or restart

Forum rules
Before you post please read how to get help
Jules6490
Level 1
Level 1
Posts: 12
Joined: Fri Jul 26, 2013 5:04 pm

Re: <SOLVED> Mint 15 KDE will not shut down or restart

Post by Jules6490 »

Update: I wanted to update since I think I have finally figured out why my system was hanging while shutting down/rebooting in KDE in hopes this might help others.

After I uninstalled Mint KDE and installed Mint XFCE over it, even though it worked, it was too much of a change from KDE, and I missed many of the customization options. So, I decided to
uninstalled Mint XFCE and try Mint 15 Cinnamon instead. I like the additional options, and at first it worked fine, but today my computer froze again while trying to shut down to reboot. I had to
push the reset button manually. After thinking about it, the only things I could think of that changed since all these shutdown problems started, was the updated Mint 15 OS's themselves and the
updated proprietary nvidia card drivers. I had updated from nvidia 304 to 310 drivers. So, I tried rolling back to the default nouveau driver to see if it was the new nvidia driver. After over a dozen
restarts and shut downs since then, I have not had any more problems so far. I guess the 310 nvidia drivers are conflicting somehow with my older Geforce 9800 GT video card and the updated
Mint 15 OS's.

poloshiao
Level 1
Level 1
Posts: 41
Joined: Thu Jul 25, 2013 8:11 pm

Re: <SOLVED> Mint 15 KDE will not shut down or restart

Post by poloshiao »

Thank you for your sharing !
I had updated from nvidia 304 to 310 drivers.
Check whether you have done the whole process :
1. install / update to 310
2. activate 310
3. setting 310
Otherwise it will be not the normal case (for other users to refer to).
Refer to :
https://help.ubuntu.com/community/Binar ... wto/Nvidia

Jules6490
Level 1
Level 1
Posts: 12
Joined: Fri Jul 26, 2013 5:04 pm

Re: <SOLVED> Mint 15 KDE will not shut down or restart

Post by Jules6490 »

I guess I should clarify I didn't update the driver through Terminal. I went to the Driver Manager, where the list of proprietary drivers are, and clicked on
Nvidia 310 (the recommended driver) to change from the default Nouveau. Then clicked Install. I was led to believe there was no longer any additional
steps required to change drivers, like restarting X config, etc.

But, after reading your last post, I took your advice and went back, and this time after clicking Install for the 310 driver, I ran:

Code: Select all

sudo nvidia-xconfig
I got an error message in Terminal that said:
Warning: Unable to locate/open X configuration file. New X configuration file written to '/etc/X11/xorg.conf'

I didn't know what that meant, but went ahead and restarted my computer. Now after two days of testing shutdown and restarting many times, I have
not seen any more problems with hanging blank screens while shutting down/restarting. And my video card is working great, so I can once again run
programs or games like Second Life in Linux without having to reboot into Windows. I guess both problems are now fixed? Thank you, Poloshiao! :D

Post Reply

Return to “KDE”