KDE fonts are messed up

Forum rules
Before you post please read how to get help
Post Reply
Oedner
Level 1
Level 1
Posts: 14
Joined: Sun Jul 28, 2013 11:39 am

KDE fonts are messed up

Post by Oedner »

hi there, I'm new to this forum but actually an intermediate linux user.

There still are linux mysteries out there that I just don't understand. I'm using linux mint 15 kde x64 for quite some time now (I really love it) on my netbook and after today as a 2nd os on my desktop pc. I installed the same programs as on my netbook, but after two hours one of the fonts started trolling me. I checked the system settings and the font sizes and styles etc. are all the same, nothing changed, but the font looks ugly now, see for yourself:

just after successful mint installation: http://abload.de/img/snapshot1hguw0.png
about two hours later: http://abload.de/img/snapshot2k0uxw.png

(sorry for the high resolution, you have to zoom in to see what i mean)

You can notice the difference at urls, tab names, firefox button (upper left browser corner), but its affecting almost everything, like the fonts in the kickoff app launcher, the fonts in system settings etc. etc. i like the standard fonts, they are easy to read for my eyes, the others are just hurt my eyes.

In the past I used manjaro linux and didn't have this problem even after weeks, is this mint (or kde) related? on my netbook linux mint this also didnt happen.

If someone knows how to revert these font settings please help me :)

PS: I already posted this in the main edition forum but didn't get an answer for 3 days, i thinks its better to put this topic in the KDE subforum.

User avatar
xenopeek
Level 24
Level 24
Posts: 24536
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: KDE fonts are messed up

Post by xenopeek »

I've deleted your other topic, as cross-posting isn't permitted. You can report a post with the exclamation icon in its top right, to ask the moderators to move the post to another forum if you so desire. See the forum rules about cross-posting (and bumping, if you get no reply again): http://forums.linuxmint.com/viewtopic.php?f=17&t=83444.

Looks like font smoothing settings got messed up. Firefox is known to not adhere to system-wide font settings on KDE. You'll probably have to edit your fonts configuration file manually to correct this for Firefox. See: http://community.linuxmint.com/tutorial/view/1107. That's all I know :| It is a known KDE + Firefox issue (and to be clear, Firefox is at fault--it has many such known issues where it doesn't adhere to Linux' configuration).
Image

Oedner
Level 1
Level 1
Posts: 14
Joined: Sun Jul 28, 2013 11:39 am

Re: KDE fonts are messed up

Post by Oedner »

thanks for your reply, but its not firefox thats bugging me. this is affecting almost all fonts systemwide.

ajgreeny
Level 5
Level 5
Posts: 554
Joined: Mon Nov 19, 2007 3:27 pm

Re: KDE fonts are messed up

Post by ajgreeny »

Just to try out my theory, see if you have a hidden .fonts.conf in your home and if so rename it as a backup file, then logout and in again.

Does that make any difference?

The background to this suggestion is that on my Xubuntu 12.04 (xfce desktop) I also run a few kde applications and to make them look better in gtk I installed the system-settings package. Using that I adjusted the fonts setup for my kde apps, and immediately all fonts in all applications looked dreadful; thin, spindly and very unattractive. I read that removing the .fonts.conf file would make everything OK again, and magic!! It worked.

Oedner
Level 1
Level 1
Posts: 14
Joined: Sun Jul 28, 2013 11:39 am

Re: KDE fonts are messed up

Post by Oedner »

nope, no hidden .fonts.conf in my home folder :(

i thinks it has something to do with the liberation sans standard font, i changed all liberation sans font entries to OxygenSans and it looks way better now, but still not as nice as liberations sans after system installation. still dont know whats causing this issue. its on my netbook too now -.-

User avatar
Snapcase
Level 3
Level 3
Posts: 135
Joined: Wed Jul 03, 2013 5:27 pm

Re: KDE fonts are messed up

Post by Snapcase »

Just an idea. I don't have a .fonts.config file either but there's a .fontconfig folder. What about moving it anywhere else or provisionally renaming it? I'm rather new to Linux and I don't know if a new one will be generated on reboot set to defaults, but sometimes these things work.

Lag
Level 1
Level 1
Posts: 2
Joined: Thu Aug 01, 2013 8:18 am

Re: KDE fonts are messed up

Post by Lag »

Maybe this way can solve your problem.
Open Konsole. Type:

Code: Select all

nano ~/.config/fontconfig/fonts.conf
Copy the following lines:

Code: Select all

<?xml version='1.0'?>
<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
<fontconfig>
 <match target="font">
  <edit mode="assign" name="rgba">
   <const>rgb</const>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="hinting">
   <bool>true</bool>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="hintstyle">
   <const>hintslight</const>
  </edit>
 </match>
 <dir>~/.fonts</dir>
 <match target="font">
  <edit mode="assign" name="lcdfilter">
   <const>lcddefault</const>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="antialias">
   <bool>true</bool>
  </edit>
 </match>
</fontconfig>
Paste to Konsole (CTRL + SHIFT + V), save (CTRL + O), enter and exit nano (CTRL + X)

Oedner
Level 1
Level 1
Posts: 14
Joined: Sun Jul 28, 2013 11:39 am

Re: KDE fonts are messed up

Post by Oedner »

Lag wrote:Maybe this way can solve your problem.
Open Konsole. Type: ......
Wow, that actually did it, fonts are back to normal again. Thank you very very much :)

User avatar
Shimapan
Level 1
Level 1
Posts: 16
Joined: Sun Aug 04, 2013 4:16 pm

Re: KDE fonts are messed up

Post by Shimapan »

Instead of editing the configuration file manually, you can also set this in Kde's control panel.

Open System Settings > Appearance of Applications > Fonts. At the bottom, set the anti-aliasing to "Activated" and click on "Setup".
Check "Sub-Pixel Hinting" and select "Rgb", then select "Slight" for "Hinting style". Click on "OK" and then on "Apply" in the Fonts dialog.
Note that you'll need to log out and log back in again (or reboot) so that all applications will use the new settings.

nizmo64
Level 1
Level 1
Posts: 2
Joined: Tue Jan 28, 2014 3:59 am

Re: KDE fonts are messed up

Post by nizmo64 »

Lag wrote:Maybe this way can solve your problem.
Open Konsole. Type:

Code: Select all

nano ~/.config/fontconfig/fonts.conf
Copy the following lines:

Code: Select all

<?xml version='1.0'?>
<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
<fontconfig>
 <match target="font">
  <edit mode="assign" name="rgba">
   <const>rgb</const>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="hinting">
   <bool>true</bool>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="hintstyle">
   <const>hintslight</const>
  </edit>
 </match>
 <dir>~/.fonts</dir>
 <match target="font">
  <edit mode="assign" name="lcdfilter">
   <const>lcddefault</const>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="antialias">
   <bool>true</bool>
  </edit>
 </match>
</fontconfig>
Paste to Konsole (CTRL + SHIFT + V), save (CTRL + O), enter and exit nano (CTRL + X)

thanks this worked for me i had tried everything before but without luck, now all works fine was very helpful for someone new to linux

rootkowski
Level 3
Level 3
Posts: 110
Joined: Tue Jun 26, 2007 5:06 am
Location: Wirral, UK
Contact:

Re: KDE fonts are messed up

Post by rootkowski »

I had a .fonts.conf file already but things were still messed up. This solution worked solved the problems for me so I just wanted to add my thanks for posting this solution. :)

blucap
Level 1
Level 1
Posts: 6
Joined: Sat Jun 14, 2014 11:37 pm

Re: KDE fonts are messed up

Post by blucap »

Many thanks for this solution, it works!

Post Reply

Return to “KDE”