No KDE option in the login screen

Forum rules
Before you post please read how to get help
Post Reply
AndrewAmmerlaan
Level 1
Level 1
Posts: 29
Joined: Thu Jan 09, 2014 12:55 pm
Location: The Netherlands

No KDE option in the login screen

Post by AndrewAmmerlaan »

I was running linux mint cinnamon, when i got curious about the mate, kde versions, i used the following command: sudo apt-get install mint-meta-mate. Mate installed perfectly, however when i tried doing the same for kde, i found no option in the login screen to use kde for the session. Did i do something wrong, or did i do something that i shouldn't have done.

Tz2001
Level 1
Level 1
Posts: 40
Joined: Fri Mar 08, 2013 8:11 pm

Re: No KDE option in the login screen

Post by Tz2001 »

exactly which package did you install with apt-get?

AndrewAmmerlaan
Level 1
Level 1
Posts: 29
Joined: Thu Jan 09, 2014 12:55 pm
Location: The Netherlands

Re: No KDE option in the login screen

Post by AndrewAmmerlaan »

mint-meta-kde
just like i did with mate, but replacing mate with kde

hiroaki
Level 2
Level 2
Posts: 58
Joined: Tue Jan 14, 2014 7:24 am

Re: No KDE option in the login screen

Post by hiroaki »

I don't know why, but I don't recommend you to install MATE and KDE together.

I tried it before, (I forget which version I tried with), but KDE destroyed MATE.

I could login KDE normaly, but when I loged-in MATE, more than twenty caja launched.

I tried it on VMware, so it was no harm for me, but you had better avoid to do it on your main machine.
Please mark the topic as [SOLVED] when the problem is solved.
Hiroaki Ban
Linux Mint 16 Petra KDE 64bit
Three simple techniques to make terminal input easier
http://forums.linuxmint.com/viewtopic.php?f=42&t=157171

AndrewAmmerlaan
Level 1
Level 1
Posts: 29
Joined: Thu Jan 09, 2014 12:55 pm
Location: The Netherlands

Re: No KDE option in the login screen

Post by AndrewAmmerlaan »

Thanks for your reply, I think I will stick with mate or cinnamon anyway

User avatar
anandrkris
Level 5
Level 5
Posts: 944
Joined: Fri Nov 16, 2012 1:13 am
Location: Chennai

Re: No KDE option in the login screen

Post by anandrkris »

I am not an expert on the subject. But I believe MDM looks for sessions available in /usr/share/xsessions/
Maybe you can check if KDE session is present or not.

https://wiki.archlinux.org/index.php/Display_Manager says
To add/remove entries to your display manager's session list; create/remove the .desktop files in /usr/share/xsessions/ as desired. A typical .desktop file will look something like:

Code: Select all

[Desktop Entry]
Encoding=UTF-8
Name=Openbox
Comment=Log in using the Openbox window manager (without a session manager)
Exec=/usr/bin/openbox-session
TryExec=/usr/bin/openbox-session
Icon=openbox.png
Type=XSession
Cheers,
If there is a drive, there will be a path

AndrewAmmerlaan
Level 1
Level 1
Posts: 29
Joined: Thu Jan 09, 2014 12:55 pm
Location: The Netherlands

Re: No KDE option in the login screen

Post by AndrewAmmerlaan »

There is no KDE in that folder, but since KDE breaks mate, I don't think i want to try installing KDE. Thanks for your reply anyway

Mercury048
Level 1
Level 1
Posts: 5
Joined: Sun Jan 19, 2014 11:57 am

Re: No KDE option in the login screen

Post by Mercury048 »

I am having a very similar issue.

I initially installed Mint Cinnamon 17, which has worked fine for a few weeks.
I then installed the mint-meta-kde package in Synaptic. However, I'm not seeing any option to log into a KDE session.

Code: Select all

____@____:~ > ls /usr/share/xsessions
cinnamon2d.desktop  cinnamon.desktop
Should there be something else here?

Post Reply

Return to “KDE”