[solved] Dolphin cannot search "invalid protocol"

Forum rules
Before you post please read how to get help
Locked
braingateway
Level 3
Level 3
Posts: 105
Joined: Thu Sep 29, 2011 4:21 pm

[solved] Dolphin cannot search "invalid protocol"

Post by braingateway » Wed May 07, 2014 9:57 pm

Hi All,

I suddenly get an error "invalid protocol" when I try to "find" with Dolphin.

Can anyone confirm this? Or it just on my system?

How can I make it work again?

Update:
after I installed kfind, I can use kfind directly, but still the dolphin cannot search. This is very annoying.

Thanks!
#############
DESCRIPTION="Linux Mint 13 Maya"
$ kded4 --version
Qt: 4.8.2
KDE Development Platform: 4.13.0
KDE Daemon: 4.13.0
+++-===================-===================-======================================================
ii dolphin 4:4.13.0-0ubuntu1~u file manager
+++-===================-===================-======================================================
ii kde-baseapps-bin 4:4.13.0-0ubuntu1~u core binaries for the KDE base applications
Last edited by braingateway on Sat Oct 25, 2014 10:10 pm, edited 1 time in total.

User avatar
yoramdavid
Level 3
Level 3
Posts: 118
Joined: Fri Jan 25, 2013 2:41 pm
Location: Almodôvar, Baixo Alentejo, Portugal
Contact:

Re: Dolphin cannot search "invalid protocol"

Post by yoramdavid » Sat Oct 18, 2014 1:46 pm

Hi braingateway,

I confirm this, I actually found this threat searching for a solution myself.
The search tool worked fine under Mint 16, not in Mint 17, both Cinnamon desktops.

Things I tried:

Install kfind (it was already installed)
Install kde-baseapps, kdebase-apps
check that "filenamesearch.protocol" is there under /usr/share/kde4/services/ - it is.

Have you in the meantime found a solution?

Thanks,

David.
You laugh because I am different and I laugh because you are all the same.

User avatar
yoramdavid
Level 3
Level 3
Posts: 118
Joined: Fri Jan 25, 2013 2:41 pm
Location: Almodôvar, Baixo Alentejo, Portugal
Contact:

Re: Dolphin cannot search "invalid protocol"

Post by yoramdavid » Fri Oct 24, 2014 5:28 pm

When launched form the terminal and trying to search, there is an error about baloosearch:

Code: Select all

dolphin(3478): couldn't create slave: "Não foi possível criar um 'ioslave':
O klauncher disse: Protocolo desconhecido 'baloosearch'.
" 
Which means: the protocol is unkown for 'baloosearch'

Installing the file ´baloo´ gets rid of this error as well as the ´invalid protocol´ on dolphin, but does not search.
You laugh because I am different and I laugh because you are all the same.

oldgranola
Level 3
Level 3
Posts: 120
Joined: Fri Sep 05, 2014 1:39 am

Re: [solved] Dolphin cannot search "invalid protocol"

Post by oldgranola » Wed Jan 21, 2015 3:13 pm

Yup. Installing the full baloo app does get rid of the 'protocol' error but still doesn't add real search functionality to Dolphin. No error but no search. I wouldn't exactly call that "Solved". Kfind works fine though.
comadore, pcDOS, hpux, solaris, vms-vax ....blah blah blah..
Yet I'm still a fn nooob

braingateway
Level 3
Level 3
Posts: 105
Joined: Thu Sep 29, 2011 4:21 pm

Re: [solved] Dolphin cannot search "invalid protocol"

Post by braingateway » Sat Jul 11, 2015 5:39 pm

oldgranola wrote:Yup. Installing the full baloo app does get rid of the 'protocol' error but still doesn't add real search functionality to Dolphin. No error but no search. I wouldn't exactly call that "Solved". Kfind works fine though.
baloo indexing process is very slow. It will take hours to days. Trying `ps aux|grep baloo` will show the baloo_indexer. Before it is finished, You cannot search.

You should also go to the system setting/desktop searching. It may list the certain folder as non-searchable.

If it still does not work, you can try to turn off the desktop search option:

system settings > desktop search
disable desktop search

Then the dolphin find should work.

Iron Tongue
Level 1
Level 1
Posts: 2
Joined: Wed Sep 06, 2017 7:02 pm

Re: [solved] Dolphin cannot search "invalid protocol"

Post by Iron Tongue » Wed Sep 06, 2017 7:05 pm


Locked

Return to “KDE”