[SOLVED]Screen tearing

Forum rules
Before you post please read how to get help
DeMus
Level 6
Level 6
Posts: 1029
Joined: Sat Aug 15, 2009 5:11 pm

Re: [SOLVED]Screen tearing

Post by DeMus » Sat Feb 14, 2015 12:19 am

Answer from Nvidia:

Code: Select all

Discussion Thread
Response Via Email (Afshar)	02/13/2015 04:24 PM
Hello,

Thank you for contacting NVIDIA Customer Care.

This is Afshar, assisting you in regards to your query.

From the problem description, I understand that you wanted to suggest a driver modification mentioned the on our page which actually helped.

Your case is been forward to the concerned team.

Best regards,
Afshar
NVIDIA Customer Care
I find it a bit cryptic but at least something is happening, as far as I understand it. Will be continued.

mintyjock
Level 1
Level 1
Posts: 2
Joined: Sun Jun 30, 2013 12:48 pm

Re: [SOLVED]Screen tearing

Post by mintyjock » Tue Feb 24, 2015 10:57 am

I have chased this bug on multiple distros, in the end I dont use Video players like VLC and just use KODI and view everything via that.

Pain in the backside.

DeMus
Level 6
Level 6
Posts: 1029
Joined: Sat Aug 15, 2009 5:11 pm

Re: [SOLVED]Screen tearing

Post by DeMus » Fri Mar 13, 2015 11:09 am

I received an answer from the Nvidia helpdesk. This is what they wrote me:

Hi Jan,

Your issue was just referred to me.

I discussed your idea with our developers.

They don't want to set it as default because it incurs one frame of latency which may be undesirable for certain applications like first-person shooter in a game.

Let me know if any more questions.

Best regards,

Mike
NVIDIA Customer Care

In other words we have to keep changing the xorg.conf file if we want to watch tearing free movies.
Sorry guys, I tried. Didn't help.

ack0329
Level 1
Level 1
Posts: 41
Joined: Tue Feb 25, 2014 11:42 pm

Re: [SOLVED]Screen tearing

Post by ack0329 » Wed May 06, 2015 9:38 am

I was so optimistic but no joy.

Any ideas?

My system Is mint 17.1 Cinnamon gnome vs kde
and my HP Envy laptop is muxless with an "optimus" Intel/Nvidia hybrid (Intel always handles the monitor and the Nvidia 740m kicks in when asked).

I should point out that this is a very common laptop video card arrangement these days. Would be nice to fix it in Linux Mint 17.1.

As well my /etx/X11/xorrg,conf never had the line you said was standard but I added it anyway, here is my video part of it,

Section "Device"
Identifier "intel"
Driver "modesetting"
BusID "PCI:0@0:2:0"
EndSection

Section "Screen"
Identifier "intel"
Device "intel"
EndSection

Section "Device"
Identifier "nvidia"
Driver "nvidia"
BusID "PCI:1@0:0:0"
Option "ConstrainCursor" "off"
EndSection

Section "Screen"
Identifier "nvidia"
Device "nvidia"
Option "AllowEmptyInitialConfiguration" "on"
Option "IgnoreDisplayDevices" "CRT"
EndSection

User avatar
Quexos
Level 2
Level 2
Posts: 69
Joined: Wed Jul 29, 2015 9:49 pm

Re: [SOLVED]Screen tearing

Post by Quexos » Wed Sep 09, 2015 8:20 pm

Made the change in mine like so:

Code: Select all

    Option         "metamodes" "1920x1080_60 +0+0 { ForceFullCompositionPipeline = On }"
#   Option         "metamodes" "1920x1080_60 +0+0"
...and it is much improved. I had really bad tearing in everything from videos to scrolling in Firefox, menus, pretty much everywhere. Thanks.

klp84
Level 1
Level 1
Posts: 2
Joined: Sat Mar 19, 2016 2:51 pm

Re: [SOLVED]Screen tearing

Post by klp84 » Sun Apr 03, 2016 2:21 pm

Hello,

I also had screen tearing problem and this trick perfectly fix it !

I'm on Nvidia GTX 960 with driver 352.63.

Many thanks !

grungy_me
Level 3
Level 3
Posts: 131
Joined: Mon Sep 30, 2013 3:54 pm

Re: [SOLVED]Screen tearing

Post by grungy_me » Thu Apr 28, 2016 2:30 pm

Hey Folks,

If you are getting screen tearing, even if you fixed it previously, before you do anything else issue the following terminal command to see what is going on with the graphics driver.

Code: Select all

inxi -G
In my case, something has messed with the graphics driver in the last few months. It likely was an update. I spent a bunch of wasted time messing with the xorg.conf file until I did the prior command and saw that the Nvidia driver was listed as unloaded. So I downloaded and installed the latest stable Nvidia proprietary graphics driver.

Please make note that what user SimpleTechGuy mentioned applies, if you have more than one monitor, the command needs to be applied for each monitor. I have never done this before so I was likely getting tear free playback on my main computer monitor, and screen tearing on my HDTV when I watched videos on it. After much tinkering with the xorg.conf file, here is what worked for me:

Code: Select all

    Option         "metamodes" "DVI-I-1: nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }, HDMI-1: nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }; DVI-I-1: nvidia-auto-select +0+0 {viewportout=1920x1080+0+60, ForceFullCompositionPipeline = On}, HDMI-1: nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }; DVI-I-1: nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On };"
I'm not sure how much of this is necessary. There maybe redundant entries here, as I'm not knowledgeable enough to know better than just through the trial and error testing I did. What I found is that the order is important. Entries are separated by a semi-colon, monitors by a comma. If I put the last entry first, then when I boot up LinuxMint with the HDTV connected, it would automatically have the HDTV disabled. Thusly the last entry which is only the main computer powered on is listed last. This corrects that issue. The first entry shows both the main computer monitor and the HDTV connected via HDMI powered on and connected at full native resolution. The main computer monitor native resolution is too large for the HDTV, so the main monitor has to be reduced to 1920x1080 for the HDTV to show the full screen. This is what the second entry is for. Notice that each entry for each monitor gets the "ForceFullCompositionPipeline = On" command issued to it. Otherwise there will be screen tearing in one or more scenarios.

You may have to play around some with your entries, but this should give you the general idea of what to do if you have more than one monitor.

Krusher
Level 1
Level 1
Posts: 7
Joined: Sun Jan 04, 2015 6:09 pm

Re: [SOLVED]Screen tearing

Post by Krusher » Tue Jun 14, 2016 7:48 pm

klp84 wrote:Hello,

I also had screen tearing problem and this trick perfectly fix it !

I'm on Nvidia GTX 960 with driver 352.63.

Many thanks !
Yes, same here with GTX 960, 352.63 custom driver, and LM 17.3 KDE.

NVIDIA, if they're reading this, should make the option standard and have a checkbox to disable it rather than the other way around. Maybe we here are just screen-tear sensitive.

So many thanks as well; now this weekend I can focus on my last problem...getting the GTX 960 to output 5.1 sound to my TV, which then connects to my stereo...(5.1 passthru works on other devices; so I know it's not the TV's problem per-se although it might not be identifying correctly as 5.1 capable).

jackcq
Level 1
Level 1
Posts: 35
Joined: Tue Oct 11, 2016 12:35 pm

Re: [SOLVED]Screen tearing

Post by jackcq » Tue Dec 13, 2016 2:00 pm

Same here.
Nvidia GTX 1060, driver version 367.57 on Mint 17.3
with XFCE (openbox + Compton).

Before adding that line to Xorg.conf, screen tearing depended
pretty much on which applications I used, e.g. chromium works
better for websites with videos than firefox, smplayer (through vdpau)
always worked great, while other players had tearing issues with the
same videos. Now the tearing's completely gone, thanks so much.

Now, I just need a way to configure it accordingly on windows, hehe.

User avatar
roiikkata
Level 1
Level 1
Posts: 4
Joined: Wed Apr 09, 2014 1:56 am
Location: united states
Contact:

Re: [SOLVED]Screen tearing

Post by roiikkata » Mon Apr 24, 2017 5:52 pm

doctorx wrote:I thought i would post my solution for kde to see if it helps anyone:

i did not alter my xorg.conf except to turn off power mizer.

what i did though was add these lines to /etc/environment

CLUTTER_PAINT=disable-clipped-redraws:disable-culling
CLUTTER_VBLANK=True
KWIN_TRIPLE_BUFFER=1

The last line is key. The top 2 are needed for nvidia and make a large difference.

This desktop flies now. Gaming is such a treat and watching mythtv is tearfree and fast.
STILL WORKS IN 2017!! AND MY GOODNESS DOES IT FLY!! WOW!! THANK YOU!!

I'm bookmarking this to add to my "what to do after installing each and every darn Linux distro ever"! This should be there by default!

nashville_bill
Level 1
Level 1
Posts: 11
Joined: Sat Dec 31, 2016 12:24 pm

Re: Screen tearing - Newbie Question

Post by nashville_bill » Tue Jan 30, 2018 11:36 pm

Hello,

I'm experiencing screen tearing on Mint 18.3 Mate, using an Nvidia GeForce 610 card. I found what looks like the fix (see below), but I can't even get the settings file to save.

I open Nvidia X Server Settings, click on nvidia-settings Configuration, click on Save Current Configuration, set the path to be /etc/X11 and click Save; it doesn't save any file to that folder. I tried leaving the file name as .nvidia-settings-rc and changing it to xorg.conf. I get no error when I click save.

I would appreciate any help you could give me.

Thanks in advance,

nashville_bill

DeMus wrote:Hi,

I also have an Nvida card (GTX760) and had the tearing problem. I got in touch with somebody from the Nvidia helpdesk and he advised me to do the following:
After installation of the latest driver suitable for your card you open the Nvidia settings program. In here you make sure you save the current settings to the /etc/X11/xorg.conf file.
I had no such file to begin with but saving the settings makes it.

You can now open a terminal and type:
kdesudo kate /etc/X11/xorg.conf.

Type your password and kate will open the file.

Almost at the end of the file you see 2 lines with options:
Option "nvidiaXineramaInfoOrder" "DFP-0"
Option "metamodes" "nvidia-auto-select +0+0"
First copy the second options line to a new line below it and put a # sign in front of it to change it in to a remark. This so you have a copy of the original line should you ever have to use it.

The first line is standard, the second one needs to be be changed by the line coming from the helpdesk, who gave me the part printed in bold below.
Change the second line to this and save it:
Option "metamodes" "nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"

To make sure the file in its new configuration is used you have to reboot.

Since then my tearing problems are over. I don't say it is over for you as well but it won't hurt to try.
When it doesn't work change the line back to the original one by deleting the changed line and the #-symbol in front of the original line.

Good luck.

Wonder
Level 5
Level 5
Posts: 637
Joined: Wed Jul 11, 2012 8:09 pm

Re: Screen tearing - Newbie Question

Post by Wonder » Wed Jan 31, 2018 7:26 am

nashville_bill wrote:Hello,

I'm experiencing screen tearing on Mint 18.3 Mate, using an Nvidia GeForce 610 card. I found what looks like the fix (see below), but I can't even get the settings file to save.

I open Nvidia X Server Settings, click on nvidia-settings Configuration, click on Save Current Configuration, set the path to be /etc/X11 and click Save; it doesn't save any file to that folder. I tried leaving the file name as .nvidia-settings-rc and changing it to xorg.conf. I get no error when I click save.

I would appreciate any help you could give me.

Thanks in advance,

nashville_bill
Open nvidia-settings with sudo, in terminal:
sudo nvidia-settings

Regards.
Image

nashville_bill
Level 1
Level 1
Posts: 11
Joined: Sat Dec 31, 2016 12:24 pm

Re: [SOLVED]Screen tearing

Post by nashville_bill » Thu Feb 01, 2018 12:03 pm

Wonder,

Thank you for your reply. However, I appear to get the same results; I'm probably missing something.

I did notice that the Nvidia window opened as superuser after the sudo nvidia-settings command.
I attempted to save the settings as xorg.conf from the Nvidia window.
The file didn't appear to save and didn't open when I typed kdesudo kate /etc/X11/xorg.conf

nashville_bill@AY030AA-ABA-CQ5320F ~ $ sudo nvidia-settings
[sudo] password for nashville_bill:
Sorry, try again.
[sudo] password for nashville_bill:
** Message: PRIME: No offloading required. Abort
** Message: PRIME: is it supported? no
nashville_bill@AY030AA-ABA-CQ5320F ~ $ kdesudo kate /etc/X11/xorg.conf
nashville_bill@AY030AA-ABA-CQ5320F ~ $

Thanks again for your help,

Bill

nashville_bill
Level 1
Level 1
Posts: 11
Joined: Sat Dec 31, 2016 12:24 pm

Re: [SOLVED]Screen tearing

Post by nashville_bill » Thu Feb 01, 2018 9:17 pm

Well, it appears I was able to create the file /etc/X11/xorg.conf. I just tried to boot into Mint on the computer I was working on and found:

Failed to start the X server

Fatal server error: no screens found(EE)

Using system config directory "usr/share/X11/xorg.conf.d "Parse error on line 10 of section Module in file /etc/X11/xorg.conf"

My guess is that the file was created, but there is nothing in it.

Thank you for any help you might be able to give me, as I can't boot into Mint at this time.

Bill

nashville_bill
Level 1
Level 1
Posts: 11
Joined: Sat Dec 31, 2016 12:24 pm

Re: [SOLVED]Screen tearing

Post by nashville_bill » Thu Feb 01, 2018 10:23 pm

I found this fix for the loss of my video, and my tearing is gone now even with a 4K video test stream; I didn't load the Nvidia driver back in my system.

Alt+F2

gnome-terminal
run these commands

sudo apt-get purge nvidia*
sudo apt-get --purge autoremove

Thanks,
nashville_bill

Post Reply

Return to “KDE”