[SOLVED]Screen tearing

Forum rules
Before you post please read how to get help
paul
Level 1
Level 1
Posts: 24
Joined: Wed Mar 18, 2009 6:16 pm

[SOLVED]Screen tearing

Postby paul » Sat Jul 26, 2014 7:59 pm

I am getting terrible screen tearing on KDE 17 on both VLC and Dragon Player. Although this is only one of many issues for me with this release, it is definately one of the most annoying. I am using Nvidia-updates driver on a GTX 660ti. After trying every possible setting, I decided to install Ubuntu 14.04 to see if this issue was inherited from upstream. It appears not; everything plays pretty sweet on Ubuntu.
Help me Obi Wan Kanobi you're my only hope!
Last edited by paul on Wed Aug 13, 2014 2:53 pm, edited 1 time in total.

User avatar
PatH57
Level 13
Level 13
Posts: 4595
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: Screen tearing

Postby PatH57 » Sun Jul 27, 2014 5:52 am

Hi,

problem is likely due to the DE you use in Mint17 (cinnamon, mate...)
check this link, a lot of testing was done.
https://forum.manjaro.org/index.php?topic=7511.0
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.

paul
Level 1
Level 1
Posts: 24
Joined: Wed Mar 18, 2009 6:16 pm

Re: Screen tearing

Postby paul » Tue Jul 29, 2014 7:04 pm

PatH57 wrote:Hi,

problem is likely due to the DE you use in Mint17 (cinnamon, mate...)
check this link, a lot of testing was done.
https://forum.manjaro.org/index.php?topic=7511.0


Thank you very much PatH57 for your response; I have been toiling with this for far too long; I will leave it now.
Seems a little too quiet on these forums recently; I guess KDE fans are in the wrong place here. :(
I must say how totally disappointed I am with this release, and how gutted I am to have blindly trashed my LM 13 KDE install (which took some serious tweaking) in favour of this crap.
I realise now, after some investigation, that this is mostly due to KDE (as opposed to the Mint team), however, how the hell would this **** get through QA if anyone on the "team" was actually using it?
I will try the MATE edition now and hope for better results.
Thanks again Pat.

Wonder
Level 5
Level 5
Posts: 588
Joined: Wed Jul 11, 2012 8:09 pm

Re: Screen tearing

Postby Wonder » Tue Jul 29, 2014 7:28 pm

I was have a similar problem, but in Mate and I change to KDE for view if resolved this issue.
Same results.

I think that, the problem is in Mint (and I love Mint), not in the DE.
Image

paul
Level 1
Level 1
Posts: 24
Joined: Wed Mar 18, 2009 6:16 pm

Re: Screen tearing

Postby paul » Wed Jul 30, 2014 6:48 pm

Thanks for the info Wonder.
I was planning on using Compiz as the WM on MATE. Everything looks great on Ubuntu (which uses Compiz as default) so I assumed I would get similar results.
Have you tried Compiz? I will give it a go when I get a chance 'cos I'm not ready to turn my back on Mint just yet... we'll see.
I will post my results on this thread when I get a chance.

Wonder
Level 5
Level 5
Posts: 588
Joined: Wed Jul 11, 2012 8:09 pm

Re: Screen tearing

Postby Wonder » Mon Aug 04, 2014 7:53 am

paul wrote:Thanks for the info Wonder.
I was planning on using Compiz as the WM on MATE. Everything looks great on Ubuntu (which uses Compiz as default) so I assumed I would get similar results.

I think the same...
Have you tried Compiz?..

In the past yes, but now, no, I don't try Compiz but I think that, not resolved this.

Regards.
Image

paul
Level 1
Level 1
Posts: 24
Joined: Wed Mar 18, 2009 6:16 pm

Re: Screen tearing

Postby paul » Mon Aug 04, 2014 6:02 pm

Just tried Nvidia 340 driver on KDE. Still tearing badly. :(

zcmint
Level 1
Level 1
Posts: 37
Joined: Thu Jan 24, 2013 1:07 am

Re: Screen tearing

Postby zcmint » Tue Aug 05, 2014 3:10 pm

This was a problem in Mint (KDE) 16 when it first came out but a fix was made and all screen graphics were as smooth as glass. Same thing is happening in 17 but there is a fix for it if only temporary (this applies to nVidia only). Go to System Settings->Desktop Effects and click on the Advanced tab. In Compositing type change the OpenGL version to a different one (doesn't matter which one) and click apply. This should smooth out the on screen graphics and no tearing. Make sure the QT Graphics System is set to "native" and VSync is set to "automatic". The reason I call this temporary is because when you reboot/cold start your machine or log out/in you have to do this again to stop the tearing.

As I said, the Mint guys/gals had a fix for this in version 16 to where there was no tearing at all regardless of rebooting. Hopefully they'll come up with another one for version 17 as well.

paul
Level 1
Level 1
Posts: 24
Joined: Wed Mar 18, 2009 6:16 pm

Re: Screen tearing

Postby paul » Tue Aug 05, 2014 4:54 pm

Thanks for the help zcmint, unfortunalely your settings don't seem to work for me.

zcmint
Level 1
Level 1
Posts: 37
Joined: Thu Jan 24, 2013 1:07 am

Re: Screen tearing

Postby zcmint » Tue Aug 05, 2014 5:36 pm

Sorry it didn't workout Paul. It took me forever to come up with the right combination of settings in version 16 and applied them to 17 and they worked. In my original post on this subject I assumed you are using the nVidia configuration tool. Do you have "Sync to VBlank" checked? If not, check it and see if that helps.

Zach

paul
Level 1
Level 1
Posts: 24
Joined: Wed Mar 18, 2009 6:16 pm

Re: Screen tearing

Postby paul » Wed Aug 06, 2014 2:27 pm

Yes, v-sync is set to auto in Desktop Effects and also checked in Nvidia Settings. Powermizer is set to Prefer Maximum Performance. OpenGL settings have been switched. Still no joy. :(

paul
Level 1
Level 1
Posts: 24
Joined: Wed Mar 18, 2009 6:16 pm

Re: Screen tearing

Postby paul » Fri Aug 08, 2014 8:26 pm

OK, so i just installed "LM 17 MATE" on on a spare partition. Wow, what a difference! I am running Compiz and Nvidia 331 driver and everything is peachy! The system is extremely responsive and I have ZERO screen tearing. There are some issues with the current version of Compiz in the repo's (3D windows don't work properly and some animations fail) but most of the good stuff works great. I forgot just how good Compiz was... please God don't let it die...
So I guess I'm leaving the KDE camp for now. Gonna check out LM 17 XFCE next and see how well that behaves with Compiz. I will report back with my feeble opinion sometime soon, if only to bring some sort of closure to my recent grumblings!

User avatar
DeMus
Level 5
Level 5
Posts: 706
Joined: Sat Aug 15, 2009 5:11 pm

Re: Screen tearing

Postby DeMus » Tue Aug 12, 2014 2:45 pm

Hi,

I also have an Nvida card (GTX760) and had the tearing problem. I got in touch with somebody from the Nvidia helpdesk and he advised me to do the following:
After installation of the latest driver suitable for your card you open the Nvidia settings program. In here you make sure you save the current settings to the /etc/X11/xorg.conf file.
I had no such file to begin with but saving the settings makes it.

You can now open a terminal and type:
kdesudo kate /etc/X11/xorg.conf.

Type your password and kate will open the file.

Almost at the end of the file you see 2 lines with options:
Option "nvidiaXineramaInfoOrder" "DFP-0"
Option "metamodes" "nvidia-auto-select +0+0"
First copy the second options line to a new line below it and put a # sign in front of it to change it in to a remark. This so you have a copy of the original line should you ever have to use it.

The first line is standard, the second one needs to be be changed by the line coming from the helpdesk, who gave me the part printed in bold below.
Change the second line to this and save it:
Option "metamodes" "nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"

To make sure the file in its new configuration is used you have to reboot.

Since then my tearing problems are over. I don't say it is over for you as well but it won't hurt to try.
When it doesn't work change the line back to the original one by deleting the changed line and the #-symbol in front of the original line.

Good luck.
Attachments
nvidia settings.jpg
Nvidia Settings
Last edited by DeMus on Fri Feb 13, 2015 4:31 pm, edited 2 times in total.

paul
Level 1
Level 1
Posts: 24
Joined: Wed Mar 18, 2009 6:16 pm

Re: Screen tearing

Postby paul » Wed Aug 13, 2014 2:52 pm

Wow, thanks DeMus that's it!! A perfect tear-free KDE desktop and beautifully smooth video playback.
Thank-you so much for sharing that. :D

Wonder
Level 5
Level 5
Posts: 588
Joined: Wed Jul 11, 2012 8:09 pm

Re: [SOLVED]Screen tearing

Postby Wonder » Wed Aug 13, 2014 6:39 pm

Ohh, great post.

I view my xorg.conf, and this 2 lines appears with any changes:

Code: Select all

Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "nvidia-auto-select +0+0"

The difference its DFP-1, in my file, the value its 1, and in your post appears with 0.

I need change this?

In other question, my english is not very good, and I don't know if I understand well.

Copy the second line, add a # in this second line? This is all?

You can post your xorg.conf with this 2 lines for I understand well?

Again, thank you very much!!!
Image

Wonder
Level 5
Level 5
Posts: 588
Joined: Wed Jul 11, 2012 8:09 pm

Re: [SOLVED]Screen tearing

Postby Wonder » Wed Aug 13, 2014 6:48 pm

Hello.
Y try with this lines:

Code: Select all

    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "nvidia-auto-select +0+0{ ForceFullCompositionPipeline = On }"
    #Option         "metamodes" "nvidia-auto-select +0+0"

And....fantastic!!!!
Like paul, beautifully smooth video playback, my problems with tearing dissapears.
Fantastic post and help!!
Thank you very much!!!
Image

paul
Level 1
Level 1
Posts: 24
Joined: Wed Mar 18, 2009 6:16 pm

Re: [SOLVED]Screen tearing

Postby paul » Wed Aug 13, 2014 8:15 pm

Wonder; great to hear it worked for you too. :D
I'm happy to keep LM17 KDE on my main drive now.
DeMus.... you're a STAR!! Thank you again; it was driving me mad! If ever we should meet, I owe you a beer! :wink:

User avatar
DeMus
Level 5
Level 5
Posts: 706
Joined: Sat Aug 15, 2009 5:11 pm

Re: [SOLVED]Screen tearing

Postby DeMus » Tue Aug 19, 2014 1:51 pm

paul wrote:DeMus.... you're a STAR!! Thank you again; it was driving me mad! If ever we should meet, I owe you a beer! :wink:


Where and when? :lol:

zcmint
Level 1
Level 1
Posts: 37
Joined: Thu Jan 24, 2013 1:07 am

Re: [SOLVED]Screen tearing

Postby zcmint » Tue Aug 19, 2014 3:27 pm

My hat is off to you as well DeMus...worked on my machine too!

Zach

Joshual1177
Level 1
Level 1
Posts: 23
Joined: Mon Sep 08, 2014 2:55 pm

[SOLVED]Screen tearing

Postby Joshual1177 » Thu Sep 11, 2014 7:42 am

Can anyone post pictures of examples of screen tearing?


Sent from my iPhone using Tapatalk


Return to “KDE”

Who is online

Users browsing this forum: No registered users and 2 guests