KDE recently opened files... [Solved]

Forum rules
Before you post please read how to get help
Post Reply
thom_A
Level 4
Level 4
Posts: 314
Joined: Tue Jun 09, 2015 1:26 pm

KDE recently opened files... [Solved]

Post by thom_A »

I was about to add KDE Mint in my sister's family computer when I noticed at the last minute that the Recent files tab in KDE's start menu cannot be cleared. Or there's no way of stopping them from being generated. KDE also doesn't have a global privacy settings. Am I missing something? When I say family computer it meant that it's used by everybody in the household, ie, browse, check email, shop, etc... I started liking KDE, but this lacking privacy feature is a complete no no.
Last edited by thom_A on Wed Sep 16, 2015 6:37 pm, edited 1 time in total.

User avatar
phd21
Level 19
Level 19
Posts: 9533
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: KDE recently opened files...

Post by phd21 »

Hi thom_A,

You should know that with the wonderful and incredible Linux Mint KDE, you can practically configure anything the way you would like it.

1. If you right click the "menu" button (key), select "Application Launcher Menu Settings", under the first option "View" on the left side, there are numerous check box options available on the right side, like "recently used applications", "recently used documents", "recently used", etc... Just un-check the ones you do not want to see, or do not want others to see, like "recently used documents" and or "recently used". Then if you click on "options" on the left there are some other "options" for applications as well. I personally like having my recent applications shown to me, but not the documents because most document applications, ex: LibreOffice Writer, have their own history options built-in. Of course, many other applications like "Firefox" also have their own internal settings (in "preferences") and options to control your "history" of your actions, like websites visited, bookmarks, downloads, etc...

2. If you are allowing more than one person to use one computer, I would highly recommend creating user accounts for each person with their own passwords. This way, no one has access to any other user's files, history, settings, etc...


Hope this helps ...
Phd21: Mint 19.2 Cinnamon & xKDE (Xfce) & KDE Neon 64-bit Awesome OS's, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram, 256gb SDD, only Intel 4 Graphics. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

thom_A
Level 4
Level 4
Posts: 314
Joined: Tue Jun 09, 2015 1:26 pm

Re: KDE recently opened files...

Post by thom_A »

@phd21

Seems yours is different from mine (Mint 17.2 KDE). There's no "View" on the left side, no "recently used applications", "recently used documents," etc.

(Cinnamon got this Privacy button where it gives the global option of not remembering recently opened documents. Image is a KDE attatchment, not Cinnamon.)
Attachments
snapshot1.png

User avatar
phd21
Level 19
Level 19
Posts: 9533
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: KDE recently opened files...

Post by phd21 »

Hi thom_A,

Do you have the full version of KDE 17.2 installed, or are you running KDE in demo "test drive" mode from the live installation DVD or live USB flash drive?

I use KDE 17.1 on my main computer, and KDE 17.2 (upgraded from 17.1) on my other computer, and both have the options I was referring to, see screen shot below. But, when I booted to a "live" installation version of Linux Mint KDE 17.2, it did not show all of those options, but not all options are available until you do a full installation.
Linux Mint KDE<br />Application Launcher Settings
Linux Mint KDE
Application Launcher Settings
Last edited by phd21 on Wed Sep 16, 2015 4:32 pm, edited 1 time in total.
Phd21: Mint 19.2 Cinnamon & xKDE (Xfce) & KDE Neon 64-bit Awesome OS's, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram, 256gb SDD, only Intel 4 Graphics. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

pacho37
Level 3
Level 3
Posts: 133
Joined: Fri Feb 07, 2014 3:18 am

Re: KDE recently opened files...

Post by pacho37 »

Right click a file or program from your 'recent list' then choose 'clear recent applications/documents'.
Linux Mint 18.1 Cinnamon 64 Bit

thom_A
Level 4
Level 4
Posts: 314
Joined: Tue Jun 09, 2015 1:26 pm

Re: KDE recently opened files...

Post by thom_A »

phd21 wrote:Hi thom_A,

Do you have the full version of KDE 17.2 installed, or are you running KDE in demo "test drive" mode from the live installation DVD or live USB flash drive?

I use KDE 17.1 on my main computer, and KDE 17.2 (upgraded from 17.1) on my other computer, and both have the options I was referring to, see screen shot below. But, when I booted to a "live" installation version of Linux Mint KDE 17.2, it did not show all of those options, but not all options are available until you do a full installation.
This is strange. Yes, it's fully installed in a hard drive, and not on a live CD/USB. For a while I thought I've installed the older version or the wrong ISO, but then I downloaded the ISO again and the sizes are exactly similar.

I'm not getting the list similar to yours. I don't know why.

(Can't find the System Info button to check what Mint version I have.)
Last edited by thom_A on Wed Sep 16, 2015 5:18 pm, edited 1 time in total.

thom_A
Level 4
Level 4
Posts: 314
Joined: Tue Jun 09, 2015 1:26 pm

Re: KDE recently opened files...

Post by thom_A »

pacho37 wrote:Right click a file or program from your 'recent list' then choose 'clear recent applications/documents'.
Yeah, this worked for the time being. I still prefer a permanent setting as shown and described by phd21 above.

pacho37
Level 3
Level 3
Posts: 133
Joined: Fri Feb 07, 2014 3:18 am

Re: KDE recently opened files...

Post by pacho37 »

Those settings appear on my system when I switch to 'classic menu style' (after righ-clicking the 'menu/start' button). There you can indeed remove both recently used applications and documents.
With the 'application launcher style' the setting for recently used documents is not available.
In case you want to remove the setting completely maybe this could help: http://www.addictivetips.com/ubuntu-lin ... buntu-tip/
It's for ubuntu but should probably work on mint, use at your own risk ;-)
Linux Mint 18.1 Cinnamon 64 Bit

User avatar
phd21
Level 19
Level 19
Posts: 9533
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: KDE recently opened files...

Post by phd21 »

Hi Everyone,

I would try user Pacho37's idea, right click your menu key, select classic menu style, then see what happens and let us know. You can always go back to the regular application menu the same way after making your changes. I prefer the classic menu.

You can see what version and edition of Linux Mint you have by typing in "inxi -S" from your command prompt; "inxi -Fxz" is another good command people here usually ask for you to run and copy & paste the results back here. Your Welcome Screen (at the top) in your System Menu will also show you what edition and version of Linux Mint you are running.
Phd21: Mint 19.2 Cinnamon & xKDE (Xfce) & KDE Neon 64-bit Awesome OS's, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram, 256gb SDD, only Intel 4 Graphics. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

thom_A
Level 4
Level 4
Posts: 314
Joined: Tue Jun 09, 2015 1:26 pm

Re: KDE recently opened files...

Post by thom_A »

Now I see the problem. I didn't know most of you prefer the Classic Menu Style. :)

Thanks guys for your assistance.

DeMus
Level 6
Level 6
Posts: 1029
Joined: Sat Aug 15, 2009 5:11 pm

Re: KDE recently opened files...

Post by DeMus »

phd21 wrote:Hi Everyone,

I would try user Pacho37's idea, right click your menu key, select classic menu style, then see what happens and let us know. You can always go back to the regular application menu the same way after making your changes. I prefer the classic menu.
Problem is, the recently used applications and documents stay the way they were before turning into the classic menu style. The setting only work in classic style menu.

User avatar
phd21
Level 19
Level 19
Posts: 9533
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: KDE recently opened files...

Post by phd21 »

Hi DeMus, thom_A, and everyone else,

I personally do not consider that a "problem" having to use the "classic menu" style. What difference does the menu style(s) really make, especially if those settings are important to you (I think they are very important)? I have not checked my systems to see if the changes to those settings made while in "classic menu style" would revert to a previous state (not be remembered), if you go back to the regular "application launcher style" menus, but I will check on that.

If anyone has a direct line of communication to the developers of the Linux Mint KDE desktop, or any of the Mint desktops, I would contact them and strongly suggest that these options should be available to any menu style chosen by the user; I do find it a little odd that these options are somehow not available in in the regular "application launcher style" menu, yet they are available in the "classic menu"; they should be.
Phd21: Mint 19.2 Cinnamon & xKDE (Xfce) & KDE Neon 64-bit Awesome OS's, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram, 256gb SDD, only Intel 4 Graphics. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

User avatar
phd21
Level 19
Level 19
Posts: 9533
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: KDE recently opened files... [Solved]

Post by phd21 »

Hi DeMus, thom_A, and everyone else,

Okay, I just verified that the "recent" category of recently used applications and or documents does indeed continue to show up in the KDE desktop when using the "application launcher style" menus even after changing settings to not show them in the "classic menu style". But, it is obviously something that can currently be dealt with by using the "classic menu style". I'm hoping that this just an oversight from the developers which will be updated in a near future update. It would also be nice to have simple check box option(s) for "keep cleared" in the "recently used" sections for either "applications" and "documents", or preferably both. I will check to see if there is some other method(s) to keep the "recent" category from showing up in the "application launcher style" menus. User "pacho37" posted a link to a possibility that might work, but I am reluctant to try it, since using the "classic menu" now is such an easy method to accomplish this.

If anyone else knows any methods for doing this, please share those.
Phd21: Mint 19.2 Cinnamon & xKDE (Xfce) & KDE Neon 64-bit Awesome OS's, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram, 256gb SDD, only Intel 4 Graphics. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

pacho37
Level 3
Level 3
Posts: 133
Joined: Fri Feb 07, 2014 3:18 am

Re: KDE recently opened files... [Solved]

Post by pacho37 »

Agreeing with all of the above, I think there should be an easy way to change the 'recent documents/applications' setting regardless of the launcher style.
Digging a little into the issue I found the following Load-on-Demand service' in KDE autostart: 'Recent Document Watcher' - and according to KDE help center, services from this list cannot be manipulated, they can only be viewed.
Now the question is whether linux mint developers could/should do something about this or should it be taken directly to KDE guys.
Linux Mint 18.1 Cinnamon 64 Bit

User avatar
phd21
Level 19
Level 19
Posts: 9533
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: KDE recently opened files... [Solved]

Post by phd21 »

Hi DeMus, thom_A, pacho37, and everyone else,

Okay, I think I found a permanent way to do keep anything from showing up in the "recent" history lists, even in the regular "application launcher style" menu. Although, I still think just using the "classic style menu" is a better way to go; That, and the developers updating the system to add (or add back) these options I spoke of before to the regular "application launcher style" menu.
From: http://www.sqtl.co.uk/blog-article/item ... -menu.html

First empty the list by right clicking on it and choosing "Clear Recent Documents". Then try a quick:

chmod u-w ~/.kde4/share/apps/RecentDocuments

This disables write access to the directory where the data is stored. Next time you log in you'll find the Recent Documents menu is no longer there.

Note: if you're not using OpenSuse 11.4 you might find it uses .kde instead of .kde4 as the config directory, so change your command accordingly.
1. Clear your recent list by right clicking and clearing them.
2. Run this command below from your console terminal prompt:
On my Linux Mint KDE system the command would look like that below:
*Note you may need "sudo " in front of the command
chmod u-w ~/.kde/share/apps/RecentDocuments/
or
chmod u-w /home/phil/.kde/share/apps/RecentDocuments/
** If you use the command above replace "phil" with your "username".

3. Logout and log back in...


Hope this helps ...
Phd21: Mint 19.2 Cinnamon & xKDE (Xfce) & KDE Neon 64-bit Awesome OS's, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram, 256gb SDD, only Intel 4 Graphics. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

pacho37
Level 3
Level 3
Posts: 133
Joined: Fri Feb 07, 2014 3:18 am

Re: KDE recently opened files... [Solved]

Post by pacho37 »

Thx phd21, this looks like the most elegant and simplest solution.
As you said it's not a big deal and we can always use the classic menu but it's good to have the option to disable it with a simple command.
cheers
Linux Mint 18.1 Cinnamon 64 Bit

User avatar
phd21
Level 19
Level 19
Posts: 9533
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: KDE recently opened files... [Solved]

Post by phd21 »

Hi pacho37, & everyone else regarding this,

You are welcome. Let me know if any of you try this, so we know for sure if it works as described.

I like this command because it is easily reversible too if you want, by just changing the command to allow access to the "RecentDocuments" folder again.
To reverse the command and allow the normal functions of the "RecentDocuments" folder,
change the "-w" to "+w", see below:


Run this command below from your console terminal prompt:
On my Linux Mint KDE system the command would look like that below:
*Note you may need "sudo " in front of the command
chmod u+w ~/.kde/share/apps/RecentDocuments/
or
chmod u+w /home/phil/.kde/share/apps/RecentDocuments/
** If you use the command above replace "phil" with your "username".
Logout and log back in...

Have a great day!
Phd21: Mint 19.2 Cinnamon & xKDE (Xfce) & KDE Neon 64-bit Awesome OS's, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram, 256gb SDD, only Intel 4 Graphics. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

DeMus
Level 6
Level 6
Posts: 1029
Joined: Sat Aug 15, 2009 5:11 pm

Re: KDE recently opened files... [Solved]

Post by DeMus »

In KDE you can hit alt-F2 after which you get a small drop-down menu on top of the screen. Click the wrench (left most icon should you have a different icon set) and a list appears. In this list you also find Recent Documents with a tick box in front of it.
Unfortunately checking or un-checking this box makes no difference, at least not in my computer, not even after a restart.
I suddenly remembered I saw it somewhere but never used it.

lmuserx4849

Re: KDE recently opened files...

Post by lmuserx4849 »

"Remember opened documents" can be set and cleared from:
System Settings -> Workspace Behavior -> Privacy

KDE Version 4.14.2:
Help -> About KDE

Linux Mint 17.2 Rafaela:
lsb_release -d

I was just trying to find some documentation on "Blacklist all applications not on this list" and "Opened Documents" when I found your entry.

Post Reply

Return to “KDE”