Mint 18 KDE problems

Forum rules
Before you post please read how to get help
Post Reply
xox101
Level 2
Level 2
Posts: 93
Joined: Sat Jan 29, 2011 7:34 pm

Mint 18 KDE problems

Post by xox101 » Thu Aug 25, 2016 1:35 pm

Posted these questions on the KDE beta page. And yes I know it is a beta but a couple of these are ongoing. I normally use Cinnamon and have to say I am overall very impressed with KDE. Interested in thoughts or solutions to numbers 4 and 5. Thanks.

"Installed alongside 18 Cinnamon. Very stylish indeed but there are a few problems.

1 Could not connect to my Synology NAS through Dolphin or Gigolo. Copied over Samba config file from Cinnamon partition and then was able to use Gigolo to connect to my NAS. Dolphin still would not connect.

2 As has been already reported Update Manger icon does not react to left click, only right.

3 No wallpapers available to download. The wallpaper manager in Settings does nothing.

4 Extremely low volume on KDE as opposed to same volume level setting as Cinnamon. Having to keep the volume level at 100% on my laptop all the time. This has been an ongoing problem within KDE for many years. Why can’t there be a way to increase the volume above 100% as in Cinnamon? This alone makes Mint KDE unusable.

5 KDE wallet. This has to be the most useless piece of software out there. If I set Gigolo to auto start and connect to five drives on my NAS, it starts before Wallet. I then have to enter my user name and password five times in Gigolo and once in Wallet. Disabling Wallet in settings then has the result of me needing to enter my wireless password every…..single….time. Why is Wallet needed?"

thom_A
Level 4
Level 4
Posts: 314
Joined: Tue Jun 09, 2015 1:26 pm

Re: Mint 18 KDE problems

Post by thom_A » Fri Aug 26, 2016 12:55 pm

xox101 wrote:5 KDE wallet. This has to be the most useless piece of software out there. If I set Gigolo to auto start and connect to five drives on my NAS, it starts before Wallet. I then have to enter my user name and password five times in Gigolo and once in Wallet. Disabling Wallet in settings then has the result of me needing to enter my wireless password every…..single….time. Why is Wallet needed?"
I'm having the same problem. I have to type the wifi password every time I boot, which is not the case in other distros and OSes. And it appears it's conflicting with KDE Wallet, which is on by default. I disabled it and it still asks for a wifi password.

I don't know what this KDE wallet is used for and I don't even want to know. The name itself is odious. It sounds like it wants you to spend money you don't have.

Menak Vishap
Level 1
Level 1
Posts: 14
Joined: Sat Apr 28, 2012 4:52 pm

Re: Mint 18 KDE problems

Post by Menak Vishap » Sun Aug 28, 2016 6:00 am

xox101 wrote:4 Extremely low volume on KDE as opposed to same volume level setting as Cinnamon. Having to keep the volume level at 100% on my laptop all the time. This has been an ongoing problem within KDE for many years. Why can’t there be a way to increase the volume above 100% as in Cinnamon? This alone makes Mint KDE unusable.
It seems this problem is solved in Plasma 5.7. You can wait for official backport or update it by adding unofficial 'deb http://ppa.launchpad.net/kubuntu-ppa/st ... sma/ubuntu xenial main' (and may be 'deb http://ppa.launchpad.net/kubuntu-ppa/st ... ons/ubuntu xenial main'). But in this case you will partially loose national language in the interface.

thom_A
Level 4
Level 4
Posts: 314
Joined: Tue Jun 09, 2015 1:26 pm

Re: Mint 18 KDE problems

Post by thom_A » Thu Sep 01, 2016 3:49 pm

thom_A wrote:
xox101 wrote:5 KDE wallet. This has to be the most useless piece of software out there. If I set Gigolo to auto start and connect to five drives on my NAS, it starts before Wallet. I then have to enter my user name and password five times in Gigolo and once in Wallet. Disabling Wallet in settings then has the result of me needing to enter my wireless password every…..single….time. Why is Wallet needed?"
I'm having the same problem. I have to type the wifi password every time I boot, which is not the case in other distros and OSes. And it appears it's conflicting with KDE Wallet, which is on by default. I disabled it and it still asks for a wifi password.

I don't know what this KDE wallet is used for and I don't even want to know. The name itself is odious. It sounds like it wants you to spend money you don't have.
I think I managed to solve this problem, albeit by accident. I reinstalled the Mint 18 KDE Beta for no other purpose than to start fresh and clean up the system. Here's what you should do when installing the ISO.

Immediately after the USB/CD live boots up, go to System settings > Account details, uncheck the Enable the KDE Wallet subsystem, then apply. While you're at it, go back to System settings > Desktop behavior > Screen locking, uncheck Lock screen automatically after.. and Lock screen on resume (may not be relevant to the main problem, but it will keep the installation from locking the screen up while installing)..... You can now connect to your Wifi and enter your password, then start the installation. Repeat the same steps you did after the installation process and as soon as it boots up.

Post Reply

Return to “KDE”