chrome default browser

Forum rules
Before you post please read how to get help
Post Reply
mr_raider
Level 7
Level 7
Posts: 1889
Joined: Sun Jun 20, 2010 9:50 am
Location: Montreal, QC

chrome default browser

Post by mr_raider »

Using KDE 18 final. Anyone notice that chrome keeps on giving a message that it's not the default browser every time it starts? I set it as default and the problem comes back,
Image
User avatar
xenopeek
Level 24
Level 24
Posts: 24987
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: chrome default browser

Post by xenopeek »

Google Chrome or Chromium? Asking because too many people refer to both with the shorthand "chrome". Which version of it do you have installed?
Image
mr_raider
Level 7
Level 7
Posts: 1889
Joined: Sun Jun 20, 2010 9:50 am
Location: Montreal, QC

Re: chrome default browser

Post by mr_raider »

chrome. The evil closed source version that spies on you.
Image
User avatar
xenopeek
Level 24
Level 24
Posts: 24987
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: chrome default browser

Post by xenopeek »

I can't reproduce that here. Linux Mint 18 KDE fresh install with Google Chrome added.

First time I run Google Chrome it shows a dialog window asking whether it should be the default:
Image
Next time I run Google Chrome it indeed asks this again, in a bar underneath the address bar:
Image
But if I click "Set as default" on that it doesn't ask again when I next run Google Chrome.
Image
mr_raider
Level 7
Level 7
Posts: 1889
Joined: Sun Jun 20, 2010 9:50 am
Location: Montreal, QC

Re: chrome default browser

Post by mr_raider »

That's it. I keep getting the bar every time I start chrome.
Image
User avatar
Sundowner
Level 1
Level 1
Posts: 14
Joined: Sun Mar 13, 2016 11:58 pm

Re: chrome default browser

Post by Sundowner »

I unticked the box on the popup. The next time I opened Chrome it asked again near the top under the address bar. I clicked on Don't Ask Again. That's the last time I was nagged.
User avatar
Pierre
Level 20
Level 20
Posts: 10953
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: chrome default browser

Post by Pierre »

and that's how chrome should work
- and not ask, ever again.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.
User avatar
xenopeek
Level 24
Level 24
Posts: 24987
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: chrome default browser

Post by xenopeek »

Somebody else has the exact same problem with Opera Web Browser: viewtopic.php?f=90&t=229865. This might be related somehow.
Image
Wonder
Level 5
Level 5
Posts: 646
Joined: Wed Jul 11, 2012 8:09 pm

Re: chrome default browser

Post by Wonder »

Hi,
I have the same issue.
In the last days, I installed a fresh install of Linux Mint 18 KDE.
Have the same problem for set chromium browser set as default.
I go to preferences-Aplications and set chromium-browser as default.
This not work.
Also I try with this commands:

Code: Select all

sudo update-alternatives --config gnome-www-browser

sudo update-alternatives --config x-www-browser
But also, not works.

Always that I start chromium, indicate that, isn't the default browser and if I want set, click yes, but continue the issue.

If some application launch a url, its open with firefox.

Regards.
Last edited by Wonder on Fri Sep 16, 2016 3:38 pm, edited 1 time in total.
Grahf
Level 1
Level 1
Posts: 11
Joined: Wed Sep 14, 2016 10:30 pm

Re: chrome default browser

Post by Grahf »

Someone fix it.
User avatar
xenopeek
Level 24
Level 24
Posts: 24987
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: chrome default browser

Post by xenopeek »

If you create a new user account, log in to that, and try opening and closing Google Chrome a number of times there (without logging in to your Google account or otherwise importing Google Chrome settings from your other account), can you reproduce the issue?

In other words, can you confirm this is an issue affect the entire OS or is it an issue only affecting your own user account? Would be very useful to rule the one or the other out.
Image
Wonder
Level 5
Level 5
Posts: 646
Joined: Wed Jul 11, 2012 8:09 pm

Re: chrome default browser

Post by Wonder »

I use Chromium (not Chrome) and affect the entire OS.

I was made a fresh installation of LM 18 KDE, and I have this issue (and I think other with default program mail) but if I have this other issue, is for other thread :)

Regards.
mr_raider
Level 7
Level 7
Posts: 1889
Joined: Sun Jun 20, 2010 9:50 am
Location: Montreal, QC

Re: chrome default browser

Post by mr_raider »

I have two installs of Mint KDE now with this issue.

Of note, I have one instal of Kubuntu 16.04.1 which does NOT have this issue.

This problem seems to have been present in Ubuntu for some time in 15.10

http://askubuntu.com/questions/688779/g ... to-default
Image
Wonder
Level 5
Level 5
Posts: 646
Joined: Wed Jul 11, 2012 8:09 pm

Re: chrome default browser

Post by Wonder »

Hi,
I view the bug in the link, I apply the 2 solutions, but not works in LM, like I read, works in ubuntu, but not in LM.

Regards.
Post Reply

Return to “KDE”