Here we go again!!!

Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 2
Joined: Sat Dec 17, 2016 10:57 am

Here we go again!!!

Post by pmb »


My desktop icons activating a bash script with gui interaction fail to activate. I tried bug reports and forum questions but no replies.

Will try again here.

I am using LM KDE 18 and since the last major batch of upgrades from 5.6.5 to 5.8.4 my desktop is screwed up again.

A few months ago I was using KDE Neon up to date. I had the same problem with the desktop. I moved from Neon to LM KDE and the problem did not appear so I continued using LM KDE. Now with these last updates the problem is back.

Specifically, any icon that launches a bash script that causes some interaction with the plasma gui dies.

When I launch a script from a desktop icon that tests all my sound sources, it functions as expected - no gui interaction.

All permissions are set along with executable. This issue did not exist until yesterday's massive upgrade.

When I launch a script from Konsole with gui interaction (Konsole), I get something like,
$ cd Desktop
$ ls -l
-rwxr-xr-x 1 . . . 428 Dec 17 10:23 CleanUp
$ CleanUp
CleanUp: command not found

if I try, ./CleanUp, I get,
$ ./CleanUp
./CleanUp: line 1: [Desktop: command not found
./CleanUp: line 5: Up: command not found
./CleanUp: line 6: Up: command not found
./CleanUp: line 9: Up: command not found
./CleanUp: line 10: Up: command not found
./CleanUp: line 16: X-DBUS-ServiceName=: command not found
./CleanUp: line 17: X-DBUS-StartupType=: command not found
./CleanUp: line 18: X-KDE-SubstituteUID=false: command not found
./CleanUp: line 19: X-KDE-Username=: command not found

I even tried,
$ dbus-launch CleanUp
Couldn't exec CleanUp: No such file or directory

$ dbus-launch ./"CleanUp"
./CleanUp: 1: ./CleanUp: [Desktop: not found
./CleanUp: 2: ./CleanUp: Comment[en_GB]=: not found
./CleanUp: 5: ./CleanUp: GenericName[en_GB]=Clean: not found
./CleanUp: 6: ./CleanUp: Up: not found
./CleanUp: 9: ./CleanUp: Name[en_GB]=Clean: not found
./CleanUp: 10: ./CleanUp: Up: not found
./CleanUp: 16: ./CleanUp: X-DBUS-ServiceName=: not found
./CleanUp: 17: ./CleanUp: X-DBUS-StartupType=none: not found
./CleanUp: 18: ./CleanUp: X-KDE-SubstituteUID=false: not found
./CleanUp: 19: ./CleanUp: X-KDE-Username=: not found

The issue is possibly/probably something to do with Konsole because if I remove the 'run in terminal' option the script works. Unfortunately I lose all interaction. That being stated, the same issue is present with xterm.

This script has worked perfectly for at least 5 to 10 years. Linux and KDE are changing too fast for me to keep up with all the improvements.

Any ideas?


Level 2
Level 2
Posts: 78
Joined: Wed May 11, 2011 8:45 pm
Location: NW Montana

Re: Here we go again!!!

Post by blue_bullet »

My idea was to move back to LM 17.3 KDE as it works just fine. If that is where you came from I would suggest a return. Wait for things to get sorted on LM 18. You have a year or so. On LM 18 KDE I found someone had changed the colors so The Hessling Editor (THE) was unreadable. Autokey does not work. That was enough for me and I stopped. I agree it is difficult to keep up with all the improvements to Linux Mint and KDE. That's why Clem says to stay where you are if things work for you.

Level 1
Level 1
Posts: 2
Joined: Sat Dec 17, 2016 10:57 am

Re: Here we go again!!!

Post by pmb »

blue_bullet thanks for the reply

I already did the switch from Neon which was mostly mature. I really don't want to keep moving because of this issue.

Somewhere, someone must have an idea what is causing this issue.

In the meantime I will keep trying different substitutions for apps.

I do daily and weekly backups so I will pull my last plasma 5.6.5 backup and add one upgrade at a time till the issue surfaces. Then at least I will know what app is causing it.

Again, anyone with any ideas?


Level 2
Level 2
Posts: 53
Joined: Sun Mar 11, 2012 8:42 pm
Location: Palm Springs, California, USA

Re: Here we go again!!!

Post by xmanmonk »

Just noticed that the errors seem to be indicating something like [Desktop] on line 1 of the script. If this is a shell script, specifically a bash script, does it help to put #!/bin/bash as the first line in the script? And can you post at least part of the script file?
-The X-Man

Post Reply

Return to “KDE”