Script doesn't start

Forum rules
Before you post please read how to get help
Post Reply
User avatar
Alex_L
Level 2
Level 2
Posts: 96
Joined: Mon Aug 11, 2014 6:59 am

Script doesn't start

Post by Alex_L » Mon Dec 19, 2016 10:16 am

Hi

I wrote some scripts in Bash and launched them using the Desktop (Mint 18). All works fine.
Today was an update of KDE automatically as suggested. So done, these Bash scripts wont start anymore (as Link to application). When I click on the icons, I saw a little response, but the script doesn't start anymore.

When i switch the D-Bus registration in the icon to single or multiple instances, I got an error message:

Code: Select all

KDEInit could not launch 'konsole' 
.

What can I do?

Thanks

Al

User avatar
bartszu
Level 4
Level 4
Posts: 332
Joined: Thu Aug 28, 2014 7:39 pm
Location: Eire

Re: Script doesn't start

Post by bartszu » Mon Dec 19, 2016 3:34 pm

So scripts are in external folder ?
For example /user/myscripts

And Desktop contains only short-cuts to them with commands like ?

/user/myscripts/myscript.sh

This is a situation ???

User avatar
Alex_L
Level 2
Level 2
Posts: 96
Joined: Mon Aug 11, 2014 6:59 am

Re: Script doesn't start

Post by Alex_L » Mon Dec 19, 2016 3:36 pm

Yes, that's the situation.

User avatar
trytip
Level 10
Level 10
Posts: 3405
Joined: Tue Jul 05, 2016 1:20 pm

Re: Script doesn't start

Post by trytip » Mon Dec 19, 2016 4:55 pm

did you reboot your compuler after these updates?
Image

User avatar
Alex_L
Level 2
Level 2
Posts: 96
Joined: Mon Aug 11, 2014 6:59 am

Re: Script doesn't start

Post by Alex_L » Mon Dec 19, 2016 5:02 pm

Of course. But always the same error message.

User avatar
trytip
Level 10
Level 10
Posts: 3405
Joined: Tue Jul 05, 2016 1:20 pm

Re: Script doesn't start

Post by trytip » Mon Dec 19, 2016 5:23 pm

are you able to post a small script in here for testing?
Image

User avatar
bartszu
Level 4
Level 4
Posts: 332
Joined: Thu Aug 28, 2014 7:39 pm
Location: Eire

Re: Script doesn't start

Post by bartszu » Mon Dec 19, 2016 6:44 pm

yes give us script, coz it sounds like your bash is not working, which is impossible as your system runs.

User avatar
Alex_L
Level 2
Level 2
Posts: 96
Joined: Mon Aug 11, 2014 6:59 am

Re: Script doesn't start

Post by Alex_L » Tue Dec 20, 2016 3:10 am

A simple:
#!/bin/bash
echo "Hello world"

Save it in your favorite directory, create a Link to application in the desktop (Folder view), Advanced options->Run in terminal->Do not close when command exits.

That doesn't work anymore since KDE 5.8.4.

inxi -Sz:
System: Host: MC38222 Kernel: 4.4.0-53-generic x86_64 (64 bit)
Desktop: KDE Plasma 5.8.4 Distro: Linux Mint 18 Sarah

Al

User avatar
bartszu
Level 4
Level 4
Posts: 332
Joined: Thu Aug 28, 2014 7:39 pm
Location: Eire

Re: Script doesn't start

Post by bartszu » Tue Dec 20, 2016 4:12 am

Hmm looks then like KDE screwed up, there was no need to update again.
Is your desktop I mean desktop application working at all,
Can you do all normal manipulations on your desktop.
To me it looks like your graphics desktop shell simply do not pass commands,

User avatar
Alex_L
Level 2
Level 2
Posts: 96
Joined: Mon Aug 11, 2014 6:59 am

Re: Script doesn't start

Post by Alex_L » Tue Dec 20, 2016 4:53 am

It's ok. I can start whatever prog I want to, but when it demands to open a konsole, that doesn't work. Even when I switch in system settings to xterm, this doesn't work either.
I think the problem is somehow, how KDEInit wants to start konsole. (A type in the KDEInternals)

Al

User avatar
Alex_L
Level 2
Level 2
Posts: 96
Joined: Mon Aug 11, 2014 6:59 am

Re: Script doesn't start

Post by Alex_L » Tue Dec 20, 2016 6:05 am

I have found a solution for it:

In systemsettings->Applications->default applications->Terminal Emulator click on Use a different terminal program and enter here: /usr/bin/konsole.
After that, your scripts will start from your desktop by clicking on its icon. But a no-go still remains: Once you edit a script icon, the new icon losses his name and when you enter the same name as before to overwrite that icon, it complains overwriting the name, but it isn't writing. Moreover, the icon has gone. Still work to go.

Al

User avatar
acheronuk
Level 2
Level 2
Posts: 60
Joined: Wed Nov 16, 2016 3:21 pm
Location: UK
Contact:

Re: Script doesn't start

Post by acheronuk » Tue Dec 20, 2016 7:07 am

Kubuntu Developer

Post Reply

Return to “KDE”