Page 1 of 1

[Solved] Plasma-calendar holidays

Posted: Sun Jan 08, 2017 12:41 pm
by Alex_L
Hello

I've choosen US-english as system language and Luxemburgish as time format (in System Settings->Regional Settings->Format. The holidays shown in the calendar are the one's for US, but I want them for Luxembourg. Therefore, I have changed the Time Format to Luxembourgish. This doesn't affect the holidays shown in the calendar.
But when I choose Digital Clock settings->Holidays, I got an error message: Could not load file:///usr/lib/x86_64-linux-gnu/qt5/plugins/plasmacalendarplugins/holidays/HolidaysConfig.qml:29 module "org.kde.kholidays" is not installed.

The package libkholidays4 is installed. When I go to /usr/lib/x86_64-linux-gnu/qt5/plugins/plasmacalendarplugins/holidays, I can see a file HolidaysConfig.qml.
How can I choose the Luxembourgish holidays shown by digital-clocks calendar?

I already reported this on bugs.kde.org https://bugs.kde.org/show_bug.cgi?id=374752) and Kai Uwe answered to post it on my distri.
From bugs.kde.org:
You need the packge qml-module-org-kde-kholidays (might be named differently on your distribution).

Please raise this issue to your distribution as this package is mandatory for Plasma and the plasma-workspace package should have a dependency on it so it is automatically installed.
So what's the right name of this package used?

Thanks for your help.

Re: Plasma-calendar holidays

Posted: Tue Jan 10, 2017 3:50 pm
by Alex_L
You need the packge qml-module-org-kde-kholidays (might be named differently on your distribution).

Please raise this issue to your distribution as this package is mandatory for Plasma and the plasma-workspace package should have a dependency on it so it is automatically installed.
I haven't found this package on the repositories, so I installed the one from http://packages.ubuntu.com/yakkety/amd6 ... s/download(ubuntu16.04.3).
This solution works. But why isn't this package available on the repos?

Thanx

Re: [Solved] Plasma-calendar holidays

Posted: Wed Jun 07, 2017 6:39 pm
by Ghermain
Gracias , quedó solucionado en Serena KDE 18.1 x64 con:
sudo apt install qml-module-org-kde-kholidays
:D