[SOLVED] latte-dock

Forum rules
Before you post please read how to get help
Post Reply
desperados
Level 3
Level 3
Posts: 160
Joined: Wed Apr 13, 2016 1:57 am

[SOLVED] latte-dock

Post by desperados » Sun Apr 16, 2017 2:37 pm

Hi to all
I'd like to install latte-dock, I've installed it but it doesn't start: "latte-dock: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.7' not found (required by latte-dock)"
I've Mint 18.1, qt5 is (I suppose, looking the result of "dpkg -l | grep libqt5") 5.6.1
can I upgrade it?
thanks
Last edited by desperados on Mon Apr 17, 2017 2:57 am, edited 1 time in total.

User avatar
acheronuk
Level 2
Level 2
Posts: 60
Joined: Wed Nov 16, 2016 3:21 pm
Location: UK
Contact:

Re: latte-dock

Post by acheronuk » Sun Apr 16, 2017 5:02 pm

Presumably you are using the version (.deb) that someone else built using Qt 5.7 - likely running kubuntu Zesty 17.04 or similar.

Building on mint would require a small variation on the build instructions on the Latte-Dock github pages.

Code: Select all

sudo apt install cmake extra-cmake-modules qtdeclarative5-dev libqt5x11extras5-dev libkf5iconthemes-dev libkf5plasma-dev libkf5windowsystem-dev libkf5declarative-dev libkf5xmlgui-dev libkf5activities-dev build-essential libxcb-util-dev libkf5wayland-dev git gettext libkf5archive-dev libkf5notifications-dev libxcb-util0-dev
Then in a location like ~/ or a folder of your choice to build it in:

Code: Select all

wget https://github.com/psifidotos/Latte-Dock/archive/v0.6.0.tar.gz
tar xvf v0.6.0.tar.gz
cd Latte-Dock-0.6.0
sh install.sh
Kubuntu Developer

desperados
Level 3
Level 3
Posts: 160
Joined: Wed Apr 13, 2016 1:57 am

Re: [SOLVED] latte-dock

Post by desperados » Mon Apr 17, 2017 2:57 am

yes. thanks, with source it works

Cybrnitro
Level 1
Level 1
Posts: 35
Joined: Mon Jun 12, 2017 5:22 am

Re: [SOLVED] latte-dock

Post by Cybrnitro » Wed Jun 14, 2017 2:55 am

Hi
im a kinda green on linux.
i think i ran this correctly. Im trying it on a live boot thumb drive first. just so i dont wind up messing up my host.

this is the results of the first code. im thinking maybe its because the live boot is a non updated version of 18.1

Code: Select all

Reading package lists... Done
Building dependency tree       
Reading state information... Done
gettext is already the newest version (0.19.7-2ubuntu3).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 build-essential : Depends: g++ (>= 4:5.2) but it is not going to be installed
 libkf5activities-dev : Depends: qtbase5-dev (>= 5.6.1~)
 libkf5archive-dev : Depends: qtbase5-dev (>= 5.6.1~)
 libkf5declarative-dev : Depends: libkf5kio-dev (>= 5.28.0~) but it is not going to be installed
                         Depends: libkf5package-dev (>= 5.28.1~) but it is not going to be installed
                         Depends: qtbase5-dev (>= 5.6.1~)
 libkf5iconthemes-dev : Depends: libkf5configwidgets-dev (>= 5.28.0~) but it is not going to be installed
                        Depends: libkf5i18n-dev (>= 5.28.0~) but it is not going to be installed
                        Depends: libkf5itemviews-dev (>= 5.28.0~) but it is not going to be installed
                        Depends: libkf5widgetsaddons-dev (>= 5.28.0~) but it is not going to be installed
                        Depends: qtbase5-dev (>= 5.6.1~)
 libkf5notifications-dev : Depends: libkf5config-dev (>= 5.28.0~) but it is not going to be installed
                           Depends: libkf5coreaddons-dev (>= 5.28.0~) but it is not going to be installed
                           Depends: qtbase5-dev (>= 5.6.1~)
 libkf5plasma-dev : Depends: libkf5package-dev (>= 5.28.1~) but it is not going to be installed
                    Depends: libkf5service-dev (>= 5.28.0~) but it is not going to be installed
 libkf5wayland-dev : Depends: qtbase5-dev (>= 5.5.0~)
 libkf5windowsystem-dev : Depends: qtbase5-dev (>= 5.6.1~)
 libkf5xmlgui-dev : Depends: libkf5attica-dev (>= 5.28.0~) but it is not going to be installed
                    Depends: libkf5config-dev (>= 5.28.0~) but it is not going to be installed
                    Depends: libkf5configwidgets-dev (>= 5.28.0~) but it is not going to be installed
                    Depends: libkf5globalaccel-dev (>= 5.28.0~) but it is not going to be installed
                    Depends: libkf5itemviews-dev (>= 5.28.0~) but it is not going to be installed
                    Depends: libkf5textwidgets-dev (>= 5.28.0~) but it is not going to be installed
                    Depends: qtbase5-dev (>= 5.6.1~)
 libqt5x11extras5-dev : Depends: qtbase5-dev
 qtdeclarative5-dev : Depends: qtbase5-dev
E: Unable to correct problems, you have held broken packages.
i then created a file on the desktop. and then right clicked in it. "open terminal here" and ran the second command.
seems like all went well. but no latte to be found

desperados wrote:yes. thanks, with source it works
Last edited by Cybrnitro on Wed Jun 14, 2017 3:13 am, edited 2 times in total.

User avatar
acheronuk
Level 2
Level 2
Posts: 60
Joined: Wed Nov 16, 2016 3:21 pm
Location: UK
Contact:

Re: [SOLVED] latte-dock

Post by acheronuk » Wed Jun 14, 2017 3:10 am

Kubuntu Developer

Cybrnitro
Level 1
Level 1
Posts: 35
Joined: Mon Jun 12, 2017 5:22 am

Re: [SOLVED] latte-dock

Post by Cybrnitro » Wed Jun 14, 2017 3:18 am

ok. this ran with no issues. but still cant seem to find latte dock

Im also just restarted the live kde and ran this for set of commands again and am having an entire different result so we will see
thanks for the help

User avatar
acheronuk
Level 2
Level 2
Posts: 60
Joined: Wed Nov 16, 2016 3:21 pm
Location: UK
Contact:

Re: [SOLVED] latte-dock

Post by acheronuk » Wed Jun 14, 2017 3:32 am

Cybrnitro wrote:ok. this ran with no issues. but still cant seem to find latte dock
Once installed, click the kickoff menu (or launch krunner with Alt+F2) and start typing 'latte'.

Should then bring up the latte-dock shortcut to launch it with (and r-click to add as a favourite or to panel if you like).

Image
Kubuntu Developer

Cybrnitro
Level 1
Level 1
Posts: 35
Joined: Mon Jun 12, 2017 5:22 am

Re: [SOLVED] latte-dock

Post by Cybrnitro » Wed Jun 14, 2017 3:34 am

I guess i asked for help to soon. I got it to work useing your first post. Been 13 years since i messed with linux. I really missed it!!!!!
Thanks

User avatar
acheronuk
Level 2
Level 2
Posts: 60
Joined: Wed Nov 16, 2016 3:21 pm
Location: UK
Contact:

Re: [SOLVED] latte-dock

Post by acheronuk » Wed Jun 14, 2017 3:37 am

Cybrnitro wrote:I guess i asked for help to soon. I got it to work useing your first post. Been 13 years since i messed with linux. I really missed it!!!!!
Thanks

My 1st post gave how to install v 0.6.0 from source.

If you used that source, then you may want to repeat with the newer bugfix version 0.6.2 from here:

https://github.com/psifidotos/Latte-Dock/releases
Kubuntu Developer

Cybrnitro
Level 1
Level 1
Posts: 35
Joined: Mon Jun 12, 2017 5:22 am

Re: [SOLVED] latte-dock

Post by Cybrnitro » Wed Jun 14, 2017 3:41 am

Will do thanks.

OP
Sorry if this got you a bunch of notifications you dont care about.
acheronuk wrote:
Cybrnitro wrote:I guess i asked for help to soon. I got it to work useing your first post. Been 13 years since i messed with linux. I really missed it!!!!!
Thanks

My 1st post gave how to install v 0.6.0 from source.

If you used that source, then you may want to repeat with the newer bugfix version 0.6.2 from here:

https://github.com/psifidotos/Latte-Dock/releases

User avatar
acheronuk
Level 2
Level 2
Posts: 60
Joined: Wed Nov 16, 2016 3:21 pm
Location: UK
Contact:

Re: [SOLVED] latte-dock

Post by acheronuk » Thu Jul 20, 2017 4:34 pm

Latte Dock 0.6.2 is now available in the Kubuntu backports ppa, so available to all Linux Mint 18.x users.
Kubuntu Developer

User avatar
MrGrimm
Level 5
Level 5
Posts: 609
Joined: Sun Nov 11, 2018 9:13 am
Location: Portland, Oregon Canada
Contact:

Re: [SOLVED] latte-dock

Post by MrGrimm » Wed Nov 14, 2018 10:09 am

acheronuk wrote:
Wed Jun 14, 2017 3:10 am
Might be easier: http://www.omgubuntu.co.uk/2017/05/unof ... pears-wild
not working any suggestions and or help? thanks
acheronuk wrote:
Wed Jun 14, 2017 3:32 am
Cybrnitro wrote:ok. this ran with no issues. but still cant seem to find latte dock
Once installed, click the kickoff menu (or launch krunner with Alt+F2) and start typing 'latte'.

Should then bring up the latte-dock shortcut to launch it with (and r-click to add as a favourite or to panel if you like).

Image
that didn't find latte. had to enter / to get out of it.
KDE Neon 64 Bit: Kernel 5.1.0

AMD FX 6300, Asus 970 Gaming/Aura, Samsung 120 Gig 850 EVO, 16Gig DDR3,
USB 3 Card, AOC 29" Ultra Wide 2560x1080. nVidia 750Ti(430 Driver),
SATA 1TB, 750 & 500Gig Drives, USB 3 2TB & 1.5TB Drives

User avatar
MrGrimm
Level 5
Level 5
Posts: 609
Joined: Sun Nov 11, 2018 9:13 am
Location: Portland, Oregon Canada
Contact:

Re: [SOLVED] latte-dock

Post by MrGrimm » Wed Nov 14, 2018 10:24 am

o.k. this is what i currently get.

https://i.imgur.com/SfJKMMQ.png

The following packages have unmet dependencies:

latte-dock:

Depends: libkf5plasma5 (>= 5.47.0) but 5.44.0-0ubuntu3 is to be installed
Depends: plasma-workspace (>= 4:5.9.0~) but 4:5.12.6-0ubuntu0.1 is to be installed
Depends: libc6 (>= 2.14) but 2.27-3ubuntu1 is to be installed
Depends: libgcc1 (>= 1:3.0) but 1:8.2.0-1ubuntu2~18.04 is to be installed
Depends: libkf5activities5 (>= 5.23.0) but 5.44.0-0ubuntu1 is to be installed
Depends: libkf5archive5 (>= 5.2.0+git20141006) but 5.44.0-0ubuntu1 is to be installed
Depends: libkf5configcore5 (>= 5.24.0) but 5.44.0-0ubuntu1 is to be installed
Depends: libkf5coreaddons5 (>= 5.16.0) but 5.44.0a-0ubuntu1 is to be installed
Depends: libkf5crash5 (>= 4.96.0) but 5.44.0-0ubuntu1 is to be installed
Depends: libkf5dbusaddons5 (>= 4.97.0) but 5.44.0-0ubuntu1 is to be installed
Depends: libkf5declarative5 (>= 5.12.0) but 5.44.0-0ubuntu3 is to be installed
Depends: libkf5globalaccel5 (>= 5.0.0) but 5.44.0-0ubuntu1 is to be installed
Depends: libkf5i18n5 (>= 4.97.0) but 5.44.0-0ubuntu1 is to be installed
Depends: libkf5iconthemes5 (>= 4.96.0) but 5.44.0-0ubuntu1 is to be installed
Depends: libkf5newstuff5 (>= 5.27.0) but 5.44.0-0ubuntu1 is to be installed
Depends: libkf5notifications5 (>= 4.96.0) but 5.44.0-0ubuntu1 is to be installed
Depends: libkf5package5 (>= 5.17.0) but 5.44.0-0ubuntu1 is to be installed
Depends: libkf5plasmaquick5 (>= 5.28.0) but 5.44.0-0ubuntu3 is to be installed
Depends: libkf5quickaddons5 (>= 5.26.0) but 5.44.0-0ubuntu3 is to be installed
Depends: libkf5waylandclient5 (>= 4:5.27.0+p16.10+git20161029.2052) but 4:5.44.0-0ubuntu1 is to be installed
Depends: libkf5windowsystem5 (>= 5.25.0) but 5.44.0-0ubuntu1 is to be installed
Depends: libkf5xmlgui5 (>= 4.96.0) but 5.44.0-0ubuntu2 is to be installed
Depends: libqt5core5a (>= 5.9.0~beta) but 5.9.5+dfsg-0ubuntu1 is to be installed
Depends: libqt5dbus5 (>= 5.9.0~) but 5.9.5+dfsg-0ubuntu1 is to be installed
Depends: libqt5gui5 (>= 5.9.0~beta3) but 5.9.5+dfsg-0ubuntu1 is to be installed
Depends: libqt5qml5 (>= 5.0.2) but 5.9.5-0ubuntu1.1 is to be installed
Depends: libqt5quick5 (>= 5.2.0) but 5.9.5-0ubuntu1.1 is to be installed
Depends: libqt5widgets5 (>= 5.9.0~) but 5.9.5+dfsg-0ubuntu1 is to be installed
Depends: libqt5x11extras5 (>= 5.6.0) but 5.9.5-0ubuntu1 is to be installed
Depends: libstdc++6 (>= 5) but 8.2.0-1ubuntu2~18.04 is to be installed
KDE Neon 64 Bit: Kernel 5.1.0

AMD FX 6300, Asus 970 Gaming/Aura, Samsung 120 Gig 850 EVO, 16Gig DDR3,
USB 3 Card, AOC 29" Ultra Wide 2560x1080. nVidia 750Ti(430 Driver),
SATA 1TB, 750 & 500Gig Drives, USB 3 2TB & 1.5TB Drives

User avatar
MrGrimm
Level 5
Level 5
Posts: 609
Joined: Sun Nov 11, 2018 9:13 am
Location: Portland, Oregon Canada
Contact:

Re: [SOLVED] latte-dock

Post by MrGrimm » Thu Nov 15, 2018 8:23 am

o.k. for those who couldn't figure out i was asking for help in getting latte installed and working, HELP.
KDE Neon 64 Bit: Kernel 5.1.0

AMD FX 6300, Asus 970 Gaming/Aura, Samsung 120 Gig 850 EVO, 16Gig DDR3,
USB 3 Card, AOC 29" Ultra Wide 2560x1080. nVidia 750Ti(430 Driver),
SATA 1TB, 750 & 500Gig Drives, USB 3 2TB & 1.5TB Drives

User avatar
acheronuk
Level 2
Level 2
Posts: 60
Joined: Wed Nov 16, 2016 3:21 pm
Location: UK
Contact:

Re: [SOLVED] latte-dock

Post by acheronuk » Thu Nov 15, 2018 9:10 am

latte in my PPA builds against and depends on the version of frameworks in the kubuntu backports PPA (as the latte PPA description says).

So it can't be installed without that.
Kubuntu Developer

User avatar
MrGrimm
Level 5
Level 5
Posts: 609
Joined: Sun Nov 11, 2018 9:13 am
Location: Portland, Oregon Canada
Contact:

Re: [SOLVED] latte-dock

Post by MrGrimm » Thu Nov 15, 2018 9:16 am

acheronuk wrote:
Thu Nov 15, 2018 9:10 am
latte in my PPA builds against and depends on the version of frameworks in the kubuntu backports PPA (as the latte PPA description says).

So it can't be installed without that.

o.k. thanks can you post how and what i need to add? thanks
KDE Neon 64 Bit: Kernel 5.1.0

AMD FX 6300, Asus 970 Gaming/Aura, Samsung 120 Gig 850 EVO, 16Gig DDR3,
USB 3 Card, AOC 29" Ultra Wide 2560x1080. nVidia 750Ti(430 Driver),
SATA 1TB, 750 & 500Gig Drives, USB 3 2TB & 1.5TB Drives

User avatar
MrGrimm
Level 5
Level 5
Posts: 609
Joined: Sun Nov 11, 2018 9:13 am
Location: Portland, Oregon Canada
Contact:

Re: [SOLVED] latte-dock

Post by MrGrimm » Sat Nov 17, 2018 7:50 am

MrGrimm wrote:
Thu Nov 15, 2018 9:16 am
acheronuk wrote:
Thu Nov 15, 2018 9:10 am
latte in my PPA builds against and depends on the version of frameworks in the kubuntu backports PPA (as the latte PPA description says).

So it can't be installed without that.

o.k. thanks can you post how and what i need to add? thanks
BUMP
KDE Neon 64 Bit: Kernel 5.1.0

AMD FX 6300, Asus 970 Gaming/Aura, Samsung 120 Gig 850 EVO, 16Gig DDR3,
USB 3 Card, AOC 29" Ultra Wide 2560x1080. nVidia 750Ti(430 Driver),
SATA 1TB, 750 & 500Gig Drives, USB 3 2TB & 1.5TB Drives

Post Reply

Return to “KDE”