[18.2KDE64Bit] - Force "Performance" CPU Mode?

Forum rules
Before you post please read how to get help
JeZ-l-Lee
Level 3
Level 3
Posts: 149
Joined: Wed Aug 19, 2009 12:59 pm

[18.2KDE64Bit] - Force "Performance" CPU Mode?

Postby JeZ-l-Lee » Thu Jul 13, 2017 9:50 am

Hi,

Running Linux Mint 18.2 KDE 64Bit fully updated.
How can I permanently force "Performance" CPU mode?
My CPU GHz current bounces around and want it to stay locked in maximum GHz...
Thanks!

Jesse

User avatar
phd21
Level 14
Level 14
Posts: 5245
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: [18.2KDE64Bit] - Force "Performance" CPU Mode?

Postby phd21 » Thu Jul 13, 2017 10:36 am

Hi "JeZ-l-Lee",

It would help to know more about your system setup. If you run "inxi -Fxzd" from the console terminal prompt, highlight the results, copy and paste them back here, that should provide enough information.

That might be a setting in your computer's Bios. Look for something like allow operating system to control CPU speed and disable or uncheck that, reboot...

Hope this helps ...
Phd21: Mint KDE 17.3 & 18.2, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,3gb Ram,160gb hdd, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

JeZ-l-Lee
Level 3
Level 3
Posts: 149
Joined: Wed Aug 19, 2009 12:59 pm

Re: [18.2KDE64Bit] - Force "Performance" CPU Mode?

Postby JeZ-l-Lee » Thu Jul 13, 2017 11:04 am

Hi.

I figured it out below:

sudo apt-get install cpufrequtils
(already installed on LM18.2)

sudo nano /etc/default/cpufrequtils
(ADD: GOVERNOR="performance")

sudo update-rc.d ondemand disable

Thanks!

Jesse

User avatar
phd21
Level 14
Level 14
Posts: 5245
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: [18.2KDE64Bit] - Force "Performance" CPU Mode?

Postby phd21 » Thu Jul 13, 2017 12:13 pm

Hi "JeZ-l-Lee",

That's great that you figured out how to get your CPU's working at top speeds. Good for you. I did not realize the "cpufrequtils" was installed already either ... I often see Mint users "inxi -Fxzd" results where their CPU's are running at much lower speeds then they are rated at, sometimes a 1/3 of that...

I just changed my Bios to disable the Intel SpeedStep (too not "let OS handle CPU speed"), and my CPU's work at full speed. Obviously, if you have an option to enable multiple cores and threads, that should be enabled.

Bios_Setup_Performance_Disable_Intel_SpeedStep.jpg


i would recommend that you install some temperature sensors (Psensor, applet, desklet widget, etc...) to monitor your CPU's and any other hardware you can or want to monitor, just to be on the safe side, and to alert you of possible overheating issues.

As you already know from your other post, but for other KDE users, In KDE there is this really nice desktop / system tray panel widget called "Thermal Monitor" works better on Desktop (Get New Widgets, Download Widgets, search for Thermal Monitor, install, then right click Desktop Add new widgets, double click Thermal Monitor, move it to where you want, resize, change settings to add CPU cores, etc...)
https://forums.linuxmint.com/viewtopic.php?f=56&t=249248&hilit=thermal+monitor


Have a great day or night or both...
FYI:

cpufreq in Ubuntu 16.04 (Linux Mint 18.x)
https://ubuntuforums.org/showthread.php?t=2330427

CPU frequency scaling
https://wiki.debian.org/HowTo/CpuFrequencyScaling

CPU frequency scaling
https://wiki.archlinux.org/index.php/CPU_frequency_scaling

Hope this helps ...
Phd21: Mint KDE 17.3 & 18.2, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,3gb Ram,160gb hdd, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

James_Smith
Level 4
Level 4
Posts: 317
Joined: Wed Feb 18, 2015 6:41 pm

Re: [18.2KDE64Bit] - Force "Performance" CPU Mode?

Postby James_Smith » Thu Jul 20, 2017 2:16 pm



I used the information on one of these links and I think I solved it. Maybe. I'm a little closer, anyway. This is from my post yesterday:

Code: Select all

clock speeds: max: 3100 MHz 1: 457 MHz 2: 479 MHz 3: 497 MHz
4: 494 MHz


Here's the post from later that you said still showed underperformance of my CPU:

Code: Select all

clock speeds: max: 3100 MHz 1: 499 MHz 2: 499 MHz 3: 499 MHz
           4: 499 MHz


Now, here's what I'm looking at:

Code: Select all

clock speeds: max: 2400 MHz 1: 599 MHz 2: 2471 MHz 3: 599 MHz
           4: 599 MHz


I wonder why my max dropped from 3100 MHz to 2400 MHz. I paid a lot of money for a computer with a 3100 MHz processor. I cannot tolerate having it drop to 2400 MHz.

User avatar
phd21
Level 14
Level 14
Posts: 5245
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: [18.2KDE64Bit] - Force "Performance" CPU Mode?

Postby phd21 » Thu Jul 20, 2017 2:57 pm

Hi "James_Smith",

I see some improvements, but we would need to know exactly what you did, and what link(s) did you refer too. As I also mentioned, some computer bios' have an option for using Multi Core Support / Multiple CPU threads, see my picture, which unbelievably may be disabled, if it is, then enable it, save changes, and reboot.

Why did you not reply in the other post's thread, or create a new one?

...
Phd21: Mint KDE 17.3 & 18.2, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,3gb Ram,160gb hdd, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

James_Smith
Level 4
Level 4
Posts: 317
Joined: Wed Feb 18, 2015 6:41 pm

Re: [18.2KDE64Bit] - Force "Performance" CPU Mode?

Postby James_Smith » Thu Jul 20, 2017 7:09 pm

phd21 wrote:some computer bios' have an option for using Multi Core Support / Multiple CPU threads, see my picture, which unbelievably may be disabled, if it is, then enable it, save changes, and reboot.


Yes, that is the first thing I did yesterday and it turns out that's why I went from 2400 MHz to 3100 MHz. I just changed it back, and reversed everything that I did to try to "fix" this "problem" and now here are my results:

Code: Select all

CPU:       Dual core Intel Core i5-7200U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10848
           clock speeds: max: 3100 MHz 1: 3099 MHz 2: 3099 MHz 3: 3099 MHz
           4: 3099 MHz


So, problem solved?

User avatar
phd21
Level 14
Level 14
Posts: 5245
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: [18.2KDE64Bit] - Force "Performance" CPU Mode?

Postby phd21 » Thu Jul 20, 2017 7:15 pm

Hi "James_Smith"

Alright, now that is more like it. Yes solved now, it looks really good now... :)
Phd21: Mint KDE 17.3 & 18.2, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,3gb Ram,160gb hdd, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

GoKingsGo
Level 1
Level 1
Posts: 10
Joined: Thu Sep 21, 2017 9:41 pm

Re: [18.2KDE64Bit] - Force "Performance" CPU Mode?

Postby GoKingsGo » Tue Oct 03, 2017 9:03 pm

James Smith -

What did you do to get your max back up to 3100? I went into my BIOS and disabled the Intel Speedtrap and my max dropped to 2400 like yours did:

CPU: Dual core Intel Core i7-6500U (-HT-MCP-) cache: 4096 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10368
clock speeds: max: 2400 MHz 1: 2500 MHz 2: 2500 MHz 3: 2500 MHz
4: 2500 MHz


Thanks!

James_Smith
Level 4
Level 4
Posts: 317
Joined: Wed Feb 18, 2015 6:41 pm

Re: [18.2KDE64Bit] - Force "Performance" CPU Mode?

Postby James_Smith » Sun Dec 03, 2017 12:18 am

GoKingsGo wrote:James Smith -

What did you do to get your max back up to 3100? I went into my BIOS and disabled the Intel Speedtrap and my max dropped to 2400 like yours did


I reversed everything. This "force performance CPU" thing is poppycock. The CPU is designed to perform economically and efficiently. Forcing it to perform at max is a waste of time and has unintended consequences.
Last edited by James_Smith on Tue Dec 05, 2017 10:52 pm, edited 1 time in total.


Return to “KDE”