Setting desktop icons to open with a double-click in KDE

Forum rules
Before you post please read how to get help
User avatar
Schultz
Level 5
Level 5
Posts: 875
Joined: Thu Feb 25, 2016 8:57 pm

Re: Setting desktop icons to open with a double-click in KDE

Postby Schultz » Tue Sep 05, 2017 10:34 pm

mr_raider wrote:
Before starting your game (in KDE) press alt-shift-f12 and then run the game. See if it helps.

Tried it, didn't work. But thanks for the suggestion.

User avatar
Schultz
Level 5
Level 5
Posts: 875
Joined: Thu Feb 25, 2016 8:57 pm

Re: Setting desktop icons to open with a double-click in KDE

Postby Schultz » Tue Sep 05, 2017 10:44 pm

@ phd21 : I'm a little confused about the link for force Performance CPU. Do I need to edit something in the bios? What terminal commands do I run? And will this effect my Mate partition, or would I have to do it a second time if I want it done for Mate also? Thanks.

User avatar
phd21
Level 13
Level 13
Posts: 4908
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Setting desktop icons to open with a double-click in KDE

Postby phd21 » Wed Sep 06, 2017 12:53 pm

Hi "Schultz",

Every computer has its own bios with various settings that can be changed. If you read the link from the "Performance Mode" post, you can see that on my system I only had to change one setting in my computer's bios (disable the Intel SpeedStep) for my CPU processor to work at full speed (performance mode), then save that and restart. The "poster" (JeZ-l-Lee) edited (or created) one file "cpufrequtils" to achieve the same result, should restart afterwards too. "cpufrequtils" should already be installed in Linux Mint 18.x.

Obviously, you would have to do this in both systems. You can run the "inxi -Fxzd" to see the clock speeds have changed whether doing a bios change and or editing the "cpufrequtils "file.

Hope this helps ...
Phd21: Mint KDE 17.3 & 18.2, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,3gb Ram,160gb hdd, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

User avatar
Schultz
Level 5
Level 5
Posts: 875
Joined: Thu Feb 25, 2016 8:57 pm

Re: Setting desktop icons to open with a double-click in KDE

Postby Schultz » Wed Sep 06, 2017 7:32 pm

I disabled Intel SpeedStep, here's the new reading. Is this what it should be? Looks like it. Any idea why the small difference between the two?

MATE

Code: Select all

CPU:       Dual core Intel Pentium G3220 (-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 11972
           clock speeds: max: 3000 MHz 1: 3000 MHz 2: 3000 MHz

KDE

Code: Select all

CPU:       Dual core Intel Pentium G3220 (-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 11972
           clock speeds: max: 3000 MHz 1: 2993 MHz 2: 2993 MHz

EDIT:
After trying the game again, there is no difference. I'm at a loss. I think I'm about ready to throw in the towel. But, at least I learned how to get full performance out of my CPU. Thanks phd21.

ANOTHER EDIT:
Since there was only one more thing to try, updating ffmpeg, I went ahead and did it. No change in how the game movement looks.
Thanks for trying to help, phd21. :)

User avatar
phd21
Level 13
Level 13
Posts: 4908
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Setting desktop icons to open with a double-click in KDE

Postby phd21 » Wed Sep 06, 2017 8:04 pm

Hi "Schultz",

You are welcome.

That is exactly what the CPU clock speeds should like, nicely done. No idea why there is a small difference between the two distros with the clock speed (except for perhaps a different calculation algorithm).


Honestly, I do not know why the game works well on my system but not yours when my computer has older less powerful hardware.

Did you ever install the new version of the SuperTux2 game, or are you still using the one from the Software Manager or Synaptic Package Manager (SPM)?

Have you tried different video resolutions in the game settings? When I first installed and ran it, it was on 16:10 ratio, but my monitor is only a 19" widescreen (16:9).


FYI: I could not get the Intel video driver update application to run on my system for the most current Intel video drivers because in Linux Mint they override the Ubuntu system "release name" to show the Linux Mint version name like "Serena" instead of the Ubuntu name like "Xenial". I know there is some "work around" for that, but as of yet I have not figured that out.

Updated and Optimized Open Graphics Drivers PPA - restart afterwards
https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers

Code: Select all

sudo add-apt-repository ppa:oibaf/graphics-drivers

Code: Select all

sudo apt-get update



Hope this helps ...

SuperTux2sm.jpg
Phd21: Mint KDE 17.3 & 18.2, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,3gb Ram,160gb hdd, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

User avatar
Schultz
Level 5
Level 5
Posts: 875
Joined: Thu Feb 25, 2016 8:57 pm

Re: Setting desktop icons to open with a double-click in KDE

Postby Schultz » Thu Sep 07, 2017 7:54 pm

Concerning the force performance CPU thing: today my CPU speeds are back down low as they were before I disabled Intel SpeedStep. I went back into the bios and Intel SpeedStep is still disabled. Any idea why it's low again? (It's around 800 ~ 900.)

User avatar
phd21
Level 13
Level 13
Posts: 4908
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Setting desktop icons to open with a double-click in KDE

Postby phd21 » Thu Sep 07, 2017 8:32 pm

HI "Schultz",

That seems unusual too me. Are you using a laptop or a desktop? My desktop never changes; after making that bios change to "disable Intel SpeedStep" I am always in performance mode. Did you make any other changes in Bios, if so what were they?

Is that in both Mate and KDE or one or the other?

Try these instructions for creating / editing the cpufreq file from that link or these links below, and restarting.

Read previous post on this - Force "Performance" CPU Mode?
https://forums.linuxmint.com/viewtopic.php?f=56&t=249555&hilit=performance+mode


- How to set “Performance” instead of “Powersave” as default?
https://askubuntu.com/questions/929884/how-to-set-performance-instead-of-powersave-as-default

- How I can disable CPU frequency scaling and set the system to performance?
https://askubuntu.com/questions/523640/how-i-can-disable-cpu-frequency-scaling-and-set-the-system-to-performance

- How to Permanently Set CPU Governor to Performance in Linux
http://www.preprogrammer.com/how-to-permanently-set-cpu-governor-to-performance-in-linux/

Install cpufrequtils, probably already installed in Linux Mint 18.x:

Code: Select all

sudo apt-get install cpufrequtils


Then edit the following file (if it doesn't exist, this will create it):
I like the "Gedit" graphical text editor, so if that is not installed install it first.

Code: Select all

sudo apt install gedit

Code: Select all

sudo gedit /etc/default/cpufrequtils


And add the following line to it exactly as it is, copy and paste it from here if you want:

Code: Select all

GOVERNOR="performance"


Save the text file and exit the text editor. You may have to logout or restart your system.

Now you might also need to disable "ondemand daemon", otherwise after you reboot the settings might be overwritten.

Code: Select all

sudo update-rc.d ondemand disable


And you are done!
You can check your settings with:

Code: Select all

inxi -Fxzd

or

Code: Select all

cpufreq-info


You can turn off your computer and restart it to see if the changes stick.

Hope this helps ...
Phd21: Mint KDE 17.3 & 18.2, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,3gb Ram,160gb hdd, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

User avatar
phd21
Level 13
Level 13
Posts: 4908
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Setting desktop icons to open with a double-click in KDE

Postby phd21 » Tue Oct 31, 2017 6:44 pm

Hi "Schultz",

FYI:
SuperTuxKart Update Adds New Tracks, Characters, Oct. 30 2017
http://www.omgubuntu.co.uk/2017/10/supertuxkart-halloween-update


SuperTuxKart 0.9.3 is available to install on Ubuntu 14.04 LTS and above (Linux Mint 17.x or 18.x) from the SuperTuxKart Dev PPA (despite the name this PPA is used to distribute new stable releases).

To add the SuperTuxKart PPA to your software sources just run the following commands in a new Terminal window:

Code: Select all

sudo add-apt-repository ppa:stk/dev

Code: Select all

sudo apt update && sudo apt install supertuxkart



Have fun ...
Phd21: Mint KDE 17.3 & 18.2, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,3gb Ram,160gb hdd, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde


Return to “KDE”