[SOLVED] Dolphin error opening folder as root

Forum rules
Before you post please read how to get help
Post Reply
User avatar
Taffman
Level 3
Level 3
Posts: 133
Joined: Fri May 06, 2011 10:51 am
Location: United Kingdom
Contact:

[SOLVED] Dolphin error opening folder as root

Post by Taffman » Fri Oct 06, 2017 2:48 pm

Whenever I try and open a folder as 'Root' in dolphin, after entering the root password, I get this error:
The process for the file protocol died unexpectedly.
Is this a Linux Mint KDE 18.1 Plasma 64-bit bug?
Last edited by Taffman on Mon Oct 09, 2017 4:10 am, edited 1 time in total.
Linux Mint KDE 18.1 Plasma 64-bit, Dell Dimension 9200, 4GB, 2.4GHz Core2, Radeon X1300

minitux
Level 5
Level 5
Posts: 860
Joined: Tue Sep 12, 2017 10:05 am

Re: Dolphin error opening folder as root

Post by minitux » Fri Oct 06, 2017 3:28 pm

That service menu on mint kde 18.2 work properly, I used only 18.2 , never had install 18.1.

However, try to edit the sevice menu .desktop for Dolphin Root

Code: Select all

kdesudo kate /usr/share/kservices5/ServiceMenus/mint_root_dolphin.desktop
and in the file , change the line Exec= in

Code: Select all

Exec=kdesudo -c "KDE_SESSION_VERSION=5 KDE_FULL_SESSION=true dbus-launch dolphin %U"
after editing, save the file and close it and try dolphin open folder as root

dth2
Level 1
Level 1
Posts: 8
Joined: Wed Sep 13, 2017 7:35 am

Re: Dolphin error opening folder as root

Post by dth2 » Sun Oct 08, 2017 4:45 pm

I usually open a terminal window and use the command:

sudo dolphin

minitux
Level 5
Level 5
Posts: 860
Joined: Tue Sep 12, 2017 10:05 am

Re: Dolphin error opening folder as root

Post by minitux » Sun Oct 08, 2017 4:59 pm

it's best not to use sudo with graphics applications, furthermore, if you open dolphin with that command, then you have to explore the path where you want to go, while with the services menu (default on Mint KDE), you open the folder directly which you are positioned

EDIT: however, if he has the problem with the dolphin root service menu, he most likely also has him launching dolphin from terminal with sudo or kdesudo

User avatar
Taffman
Level 3
Level 3
Posts: 133
Joined: Fri May 06, 2011 10:51 am
Location: United Kingdom
Contact:

Re: Dolphin error opening folder as root

Post by Taffman » Mon Oct 09, 2017 4:09 am

Many thanks, your edits to mint_root_dolphin.desktop seems to have worked for me :D
Linux Mint KDE 18.1 Plasma 64-bit, Dell Dimension 9200, 4GB, 2.4GHz Core2, Radeon X1300

User avatar
catweazel
Level 17
Level 17
Posts: 7770
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Dolphin error opening folder as root

Post by catweazel » Mon Oct 09, 2017 4:16 am

minitux wrote:it's best not to use sudo with graphics applications
kdesudo works fine.

http://ksudo.sourceforge.net/kdesudo/
KdeSudo is a graphical frontend to the sudo command.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

minitux
Level 5
Level 5
Posts: 860
Joined: Tue Sep 12, 2017 10:05 am

Re: Dolphin error opening folder as root

Post by minitux » Mon Oct 09, 2017 5:14 am

catweazel wrote:
minitux wrote:it's best not to use sudo with graphics applications
kdesudo works fine.

http://ksudo.sourceforge.net/kdesudo/
KdeSudo is a graphical frontend to the sudo command.
yes, but most likely it does not work even kdesudo, it's a problem that had the first releases of kubuntu 16.04 and he has mint kde 18.1

User avatar
catweazel
Level 17
Level 17
Posts: 7770
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Dolphin error opening folder as root

Post by catweazel » Mon Oct 09, 2017 5:38 am

minitux wrote: yes, but most likely it does not work even kdesudo, it's a problem that had the first releases of kubuntu 16.04 and he has mint kde 18.1
Then he can try kdesu.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

minitux
Level 5
Level 5
Posts: 860
Joined: Tue Sep 12, 2017 10:05 am

Re: [SOLVED] Dolphin error opening folder as root

Post by minitux » Mon Oct 09, 2017 5:52 am

is the same, to run the dolphin open as root service menu he only must to modify the. desktop as I said.

almost certainly, if he starts dolphin with kdesudo or kdesu gets the same problem as the service menu

mandaputra8
Level 1
Level 1
Posts: 1
Joined: Tue Nov 21, 2017 1:52 pm

Re: Dolphin error opening folder as root

Post by mandaputra8 » Tue Nov 21, 2017 1:59 pm

minitux wrote:That service menu on mint kde 18.2 work properly, I used only 18.2 , never had install 18.1.

However, try to edit the sevice menu .desktop for Dolphin Root

Code: Select all

kdesudo kate /usr/share/kservices5/ServiceMenus/mint_root_dolphin.desktop
and in the file , change the line Exec= in

Code: Select all

Exec=kdesudo -c "KDE_SESSION_VERSION=5 KDE_FULL_SESSION=true dbus-launch dolphin %U"
after editing, save the file and close it and try dolphin open folder as root

this is my first comment, thanks thats work for me too

minitux
Level 5
Level 5
Posts: 860
Joined: Tue Sep 12, 2017 10:05 am

Re: [SOLVED] Dolphin error opening folder as root

Post by minitux » Mon Nov 27, 2017 6:30 pm

Nice :)

User avatar
Destry
Level 4
Level 4
Posts: 274
Joined: Thu Mar 03, 2016 11:57 am

Re: Dolphin error opening folder as root

Post by Destry » Sat Dec 23, 2017 3:50 am

minitux wrote:That service menu on mint kde 18.2 work properly, I used only 18.2 , never had install 18.1.

However, try to edit the sevice menu .desktop for Dolphin Root

Code: Select all

kdesudo kate /usr/share/kservices5/ServiceMenus/mint_root_dolphin.desktop
and in the file , change the line Exec= in

Code: Select all

Exec=kdesudo -c "KDE_SESSION_VERSION=5 KDE_FULL_SESSION=true dbus-launch dolphin %U"
after editing, save the file and close it and try dolphin open folder as root
Worked for me! :D Thanks!
Distro: Linux Mint 19 KDE mod
Quad core Intel Core2 Quad Q9550
NVIDIA GM206 [GeForce GTX 960]
ID-1: size: 1000.2GB SSD
ID-2: size: 2000.4GB
ID-3: size: 2000.4GB
ID-4: size: 3000.6GB

User avatar
BG405
Level 7
Level 7
Posts: 1557
Joined: Fri Mar 11, 2016 3:09 pm
Location: England

Re: [SOLVED] Dolphin error opening folder as root

Post by BG405 » Mon Dec 25, 2017 9:47 am

Bookmarked for future reference. 8) I've had the same issue with Dolphin; worked the first time & then just gave the aforementioned error message every subsequent attempt.
Dell Inspiron 1525 - LM17.3 CE 64-------------------Acer D255E 2GB - Manjaro KDE, LM17.3 KDE 32
Toshiba NB305 - Manjaro KDE------------------------K7S5A AMD 1.2GHz - LM17.3 Xfce 32 & WinXP-Pro
Acer Aspire E11 ES1-111M - LM18.2 KDE 64 ----Dell PII 350 64MB - Puppy 4.3 & Win98-SE

maxyudin
Level 1
Level 1
Posts: 1
Joined: Fri Jul 27, 2018 5:14 am

Re: [SOLVED] Dolphin error opening folder as root

Post by maxyudin » Tue Sep 18, 2018 4:29 am

Unfortunately, minitux's solution does not work for me on 18.03. I can only open Dolphin as root once, next time the same error appears again.

The only solution works for me now is

Code: Select all

kdesudo dbus-run-session dolphin
run from Application Launcher item, KRunner or Konsole, but not placed as Exec= to the .desktop file.

User avatar
phd21
Level 17
Level 17
Posts: 7471
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: [SOLVED] Dolphin error opening folder as root

Post by phd21 » Wed Oct 17, 2018 4:31 pm

HI Taffman, maxyudin, & Anyone Else Interested in this,

I was not sure whether to add to this post or to create a new post.

Every time there is a major update or upgrade in the Ubuntu base like from Ubuntu 14.04 Trusty (Linux Mint 17.x), to Ubuntu 16.04 Xenial (Linux Mint 18.x), or now with Ubuntu 18.04 Bionic (Linux Mint 19.x), they change some security aspects of the operating system, and so do some of the desktop developers (Cinnamon, Mate, Xfce, and KDE) which of course supposedly makes it more secure, but creates hassles for users having to learn how to use new commands or apps with the new security in place..

In my Linux Mint KDE 18.3 system, they removed the "root" options for the excellent "Dolphin" file manager even though it already required entering in your "root" password which is a real pain because it was a very useful feature rather than having to enter numerous console terminal commands. The KDE developers went even further to make matters worse in KDE versions based on Ubuntu 18.04+ Bionic (Linux Mint 19.x) with the KDE desktop added, or using Kubuntu 18.04 or the new very nice KDE Neon operating systems, by actually preventing the Dolphin file manager from being run as root without major efforts because the kdesu/kdesudo/sudo no longer works! But through exhaustive research, I found solutions for these issues which I will describe below.
phd21 wrote:*** TIP 1: for all KDE users using Linux Mint 18.x or 19.x, if you want your GTK/Gnome applications to work and or to work well like Firefox, Yakuake, etc... install the GTK2 and GTK3 "adwaita" and Gnome themes from the "Synaptic Package Manager (SPM)" and then under the System Settings - Application Style - Gnome/GTK Application Style change the settings to Adwaita and at bottom to adwaita or Gnome (click Apply) then that will help. FYI: in the new KDE Neon, it required installing the "Synaptic Package Manager (SPM)" and then removing the neon-adwaita package. See screenshots below
phd21 wrote:*** Tip 2: There are special versions of Firefox and the Thunderbird email client for KDE Plasma users. For those interested, see the previous post or ask me.

- Linux Mint KDE 18.3 (18.x) based on Ubuntu 16.04 Xenial users could install the option below
Root Actions Servicemenu - store.kde.org
https://store.kde.org/p/998469/

Download this archive file from the link below, then right-click it and extract here, which creates a new "rootactions_servicemenu_2.9.1" folder, get into that folder, right-click the "install.sh" file in that folder select properties permission tab check to allow executable exit that, right-click in the white space and open terminal here, in the Konsole terminal, run the command below. I cannot remember if it is this or something else, but it is recommended to install "Ruby" first from the "Synaptic Package Manager (SPM)" or the command below.

Code: Select all

sudo apt install ruby
To install the root service menu for Dolphin.

Code: Select all

bash install.sh
or

Code: Select all

./install.sh
exit the Konsole terminal
restart dolphin.

Download link for the root service menu for Dolphin
https://store.kde.org/p/998469/startdow ... 9.1.tar.gz
.
.
.
- For Linux Mint 19.x users with the KDE desktop (Kubuntu or Neon) installed, or Kubuntu 18.04, or KDE Neon 5.14 based on Ubuntu 18.04 Bionic or any other KDE system based on Ubuntu 18.04 Bionic or newer, these instructions below will allow you to open Dolphin as root. "OpenSUSE KDE" already provides an option for Dolphin as root. I will provide all the links to articles and posts below, but those recommending using kdesu/kdesudo/sudo no longer work, so there are another "work arounds" or "hacks" that do work.


A.) For Linux Mint 19.x or 18.x: Easiest method: Just create a new desktop shortcut launcher to an application, or a new menu item, with a Name of "Dolphin Root" and copy then paste the line below into the Application command box.

Code: Select all

pkexec env DISPLAY=$DISPLAY XAUTHORITY=$XAUTHORITY KDE_SESSION_VERSION=5 KDE_FULL_SESSION=true dolphin

B.) Another method: Add a new Dolphin right-click Action for opening Dolphin as root

Create a new text file called "root_dolphin.desktop" in your home folder using any text editor, copy the contents below in the code box and paste it into that file, save the file, exit the text editor, then...

Code: Select all

[Desktop Entry]
Type=Service
X-KDE-ServiceTypes=KonqPopupMenu/Plugin
MimeType=inode/directory;
Actions=openRootDolphinHere;
X-KDE-AuthorizeAction=shell_access

[Desktop Action openRootDolphinHere]
Name=Open Root Dolphin Here
#TryExec=kdesu
Exec=pkexec env DISPLAY=$DISPLAY XAUTHORITY=$XAUTHORITY KDE_SESSION_VERSION=5 KDE_FULL_SESSION=true dolphin
#Exec=kdesu dolphin %U
Icon=folder-red
... open a konsole terminal which defaults into your home folder, and copy the command below into that, hit enter to copy the new root dolphin desktop file into a folder all users can use, close the konsole terminal window, restart Dolphin file manager. If you do not see the right-click Actions "Open Root Dolphin here", then you may have to go into the Dolphin Settings - Configure Dolphin - click Services on the left and make sure to check "Open Root Dolphin here" and apply and ok.

Code: Select all

sudo cp root_dolphin.desktop /usr/share/kservices5/ServiceMenus/

FYI: Here are the links to articles and posts where I found all this information on before doing all the trial and error testing stuff.

How to run Dolphin 18.08 as root with Kubuntu or KDE neon? • KDE Community Forums
https://forum.kde.org/viewtopic.php?f=224&t=153655

Security nonsense: KDE Dolphin does not run as root - Fix
https://www.dedoimedo.com/computers/kde ... -root.html

Linux Users, Bypass "Executing Dolphin as root is not possible" and Regain Your KDE Dolphin Root Privileges | IWF1
https://iwf1.com/linux-users-bypass-exe ... privileges

How To: Add "Open As Root" Entry Manually To KDE's Dolphin File Manager? | IWF1
https://iwf1.com/how-to-add-open-as-roo ... le-manager


Hope this helps ...
.
KDE_Ubuntu1804Bionic_Dolphin_Root1.jpg
Linux Mint 19.x with KDE based on Ubuntu 18.04 Bionic- New Desktop shortcut or menu item launcher
.
KDE_Ubuntu1804Bionic_Dolphin_Root2.jpg
Linux Mint 19.x with KDE based on Ubuntu 18.04 Bionic
- Dolphin right-click new action entry
.
.
KDE "Synaptic Package Manager (SPM)" showing recommended theme and icon packages to install for GTK2 and GTK3 and Gnome applications.
Image
.
.
KDE System Settings for changing the Gnome/GTK Application Settings to use Adwaita themes and icons, especially for GTK2 applications.
Image
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

Post Reply

Return to “KDE”