(Solved) Purge/ and Reinstall Kontact

Forum rules
Before you post please read how to get help
Conker
Level 1
Level 1
Posts: 45
Joined: Mon Nov 25, 2013 3:09 pm

(Solved) Purge/ and Reinstall Kontact

Post by Conker » Thu Oct 12, 2017 6:36 pm

As part of my linux learning curve I keep trying to make kontact (especially kmail) work consistently on my system and latest attempt was to purge it and then reinstall with
apt-get install kontact via terminal
I have the following message

The following packages have unmet dependencies:
kontact : Depends: libkdepim4 (= 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1) but 4:4.14.3-0ubuntu1~ubuntu14.04~ppa3 is to be installed
Depends: libkdepimdbusinterfaces4 (= 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1) but 4:4.14.3-0ubuntu1~ubuntu14.04~ppa3 is to be installed
E: Unable to correct problems, you have held broken packages.

I go into Synaptic and see that both libkdepim4 and libkdepimdbusinterfaces4 are the latest 4:4.14.3 versions.

Any advice on how to proceed would be appreciated.
Last edited by Conker on Mon Nov 13, 2017 7:32 pm, edited 1 time in total.
Mint 17.3 KDE 64-bit

minitux
Level 5
Level 5
Posts: 860
Joined: Tue Sep 12, 2017 10:05 am

Re: Purge/ and Reinstall Kontact

Post by minitux » Fri Oct 13, 2017 12:31 am

It Ask you the version 4.14.2 but There is also the 4.14.3 and it's no fine, because apt try to install 4.14.3

Have You external ppa's ?

Code: Select all

inxi -Sr
?

Conker
Level 1
Level 1
Posts: 45
Joined: Mon Nov 25, 2013 3:09 pm

Re: Purge/ and Reinstall Kontact

Post by Conker » Fri Oct 13, 2017 10:39 am

Thank you minitux, here is the inxi output

~ > inxi -Sr
System: Host: andy-Satellite-L355 Kernel: 3.19.0-32-generic x86_64 (64 bit) Desktop: KDE Plasma 4.14.13
Distro: Linux Mint 17.3 Rosa
Repos: Active apt sources in file: /etc/apt/sources.list.d/libreoffice-ppa-trusty.list
deb http://ppa.launchpad.net/libreoffice/ppa/ubuntu trusty main
deb-src http://ppa.launchpad.net/libreoffice/ppa/ubuntu trusty main
Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
deb http://packages.linuxmint.com rosa main upstream import
deb http://extra.linuxmint.com rosa main
deb http://archive.ubuntu.com/ubuntu trusty main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu trusty-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ trusty partner
Active apt sources in file: /etc/apt/sources.list.d/vivaldi.list
deb http://repo.vivaldi.com/stable/deb/ stable main

Still unsure what to do next. Could you make a recommendation?
Thank you
Mint 17.3 KDE 64-bit

minitux
Level 5
Level 5
Posts: 860
Joined: Tue Sep 12, 2017 10:05 am

Re: Purge/ and Reinstall Kontact

Post by minitux » Fri Oct 13, 2017 12:25 pm

there are the libreoffice ppa and the vivaldi repo, try to disable both from software sources and close the window and then run a update

Code: Select all

sudo apt-get update
then retry the install

Code: Select all

sudo apt-get install kontact

Conker
Level 1
Level 1
Posts: 45
Joined: Mon Nov 25, 2013 3:09 pm

Re: Purge/ and Reinstall Kontact

Post by Conker » Fri Oct 13, 2017 1:27 pm

Thanks for the suggestions minitux; I applied them but I get the same message as in first post after I run apt-get install kontact.
Any other ideas?
Mint 17.3 KDE 64-bit

minitux
Level 5
Level 5
Posts: 860
Joined: Tue Sep 12, 2017 10:05 am

Re: Purge/ and Reinstall Kontact

Post by minitux » Fri Oct 13, 2017 1:31 pm

Code: Select all

sudo apt-get install -f
?

Conker
Level 1
Level 1
Posts: 45
Joined: Mon Nov 25, 2013 3:09 pm

Re: Purge/ and Reinstall Kontact

Post by Conker » Fri Oct 13, 2017 2:04 pm

I tried this also and it gave me 0 results
apt-get upgrade kontact shows same message as in first post
Thunderbird works fine for my email but I try to learn more by making kontact work!
apt-cache show kontact shows two versions, 4.14.2 and 4.14.3 but I don't know what to do with this information.
Thanks again for the support so far.
Mint 17.3 KDE 64-bit

minitux
Level 5
Level 5
Posts: 860
Joined: Tue Sep 12, 2017 10:05 am

Re: Purge/ and Reinstall Kontact

Post by minitux » Fri Oct 13, 2017 2:44 pm

where are from the packages?

Code: Select all

apt-cache policy kontact

Code: Select all

apt-cache policy libkdepim4

Code: Select all

apt-cache policy libkdepimdbusinterfaces4

Conker
Level 1
Level 1
Posts: 45
Joined: Mon Nov 25, 2013 3:09 pm

Re: Purge/ and Reinstall Kontact

Post by Conker » Fri Oct 13, 2017 2:55 pm

Here are the results

andy@andy-Satellite-L355:~ > apt-cache policy kontact
kontact:
Installed: (none)
Candidate: 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1
Version table:
4:4.14.2-0ubuntu1~ubuntu14.04~ppa1 0
500 http://packages.linuxmint.com/ rosa/import amd64 Packages
4:4.13.3-0ubuntu0.1 0
500 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe amd64 Packages
4:4.13.0-0ubuntu1 0
500 http://archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
andy@andy-Satellite-L355:~ > apt-cache policy libkdepim4
libkdepim4:
Installed: 4:4.14.3-0ubuntu1~ubuntu14.04~ppa3
Candidate: 4:4.14.3-0ubuntu1~ubuntu14.04~ppa3
Version table:
*** 4:4.14.3-0ubuntu1~ubuntu14.04~ppa3 0
100 /var/lib/dpkg/status
4:4.14.2-0ubuntu1~ubuntu14.04~ppa1 0
500 http://packages.linuxmint.com/ rosa/import amd64 Packages
4:4.13.3-0ubuntu0.1 0
500 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe amd64 Packages
4:4.13.0-0ubuntu1 0
500 http://archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
andy@andy-Satellite-L355:~ > apt-cache policy libkdepimdbusinterfaces4
libkdepimdbusinterfaces4:
Installed: 4:4.14.3-0ubuntu1~ubuntu14.04~ppa3
Candidate: 4:4.14.3-0ubuntu1~ubuntu14.04~ppa3
Version table:
*** 4:4.14.3-0ubuntu1~ubuntu14.04~ppa3 0
100 /var/lib/dpkg/status
4:4.14.2-0ubuntu1~ubuntu14.04~ppa1 0
500 http://packages.linuxmint.com/ rosa/import amd64 Packages
4:4.13.3-0ubuntu0.1 0
500 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe amd64 Packages
4:4.13.0-0ubuntu1 0
500 http://archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
andy@andy-Satellite-L355:~ >

It wants me to downgrade to an earlier version?
Still confused!
Mint 17.3 KDE 64-bit

User avatar
phd21
Level 16
Level 16
Posts: 6195
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Purge/ and Reinstall Kontact

Post by phd21 » Fri Oct 13, 2017 3:11 pm

Hi "Conker",

I just read your post and the good replies to it. Here are my thoughts on this as well.

It would help to know more about your system setup. If you run "inxi -Fxzd" from the console terminal prompt, highlight the results, copy and paste them back here, that should provide enough information.

I have never had any issues with the KDE applications in Linux Mint 17.3 KDE including all the PIM apps like Kontact or Korganizer, or Kmail.

You can uninstall (purge) the kde PIM apps and then reinstall them. Because you are claiming to have issues with these, I would remove them, install the PPA below, then reinstall them. Or, just install the PPA and run an update to see what happens.

Code: Select all

sudo apt-get purge kdepim
or

Code: Select all

sudo apt-get purge kde-runtime
and

Code: Select all

sudo apt-get purge kmail
I would recommend installing the "kubuntu" backports PPA if you have not already done that. This PPA is now part of Linux Mint 18.

Code: Select all

sudo add-apt-repository ppa:kubuntu-ppa/backports

Code: Select all

sudo apt-get update

Code: Select all

sudo apt-get install kdepim
or

Code: Select all

sudo apt-get install kde-runtime

Code: Select all

sudo apt-get install kmail

Good luck ...

Hope this helps ...
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

minitux
Level 5
Level 5
Posts: 860
Joined: Tue Sep 12, 2017 10:05 am

Re: Purge/ and Reinstall Kontact

Post by minitux » Fri Oct 13, 2017 3:24 pm

Before doing anything of phd21 said, look at these things

there are inconsistencies in the packets present in mint and ubuntu repo, kontact's candidate is mint mint repos, but is back compared to ubuntu repo and wants to install that of mint
Conker wrote:Candidate: 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1
Version table:
4:4.14.2-0ubuntu1~ubuntu14.04~ppa1 0
500 http://packages.linuxmint.com/ rosa/import amd64 Packages
4:4.13.3-0ubuntu0.1 0
500 http://archive.ubuntu.com/ubuntu/ trusty-updates/universe amd64 Packages
4:4.13.0-0ubuntu1 0
500 http://archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
instead the dependencies are installed at the right version
andy@andy-Satellite-L355:~ > apt-cache policy libkdepim4
libkdepim4:
Installed: 4:4.14.3-0ubuntu1~ubuntu14.04~ppa3
Candidate: 4:4.14.3-0ubuntu1~ubuntu14.04~ppa3
andy@andy-Satellite-L355:~ > apt-cache policy libkdepimdbusinterfaces4
libkdepimdbusinterfaces4:
Installed: 4:4.14.3-0ubuntu1~ubuntu14.04~ppa3
Candidate: 4:4.14.3-0ubuntu1~ubuntu14.04~ppa3
try to install the kontact version 4:4.13.3-0ubuntu0.1 0 instead of candidate

Code: Select all

sudo apt-get install kontact=4:4.13.3-0ubuntu0.1 0
Last edited by minitux on Fri Oct 13, 2017 3:41 pm, edited 1 time in total.

Conker
Level 1
Level 1
Posts: 45
Joined: Mon Nov 25, 2013 3:09 pm

Re: Purge/ and Reinstall Kontact

Post by Conker » Fri Oct 13, 2017 3:39 pm

I am getting closer minitux

andy@andy-Satellite-L355:~ > sudo apt-get install kontact=4:4.13.3-0ubuntu0.1
[sudo] password for andy:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kontact : Depends: libkdepim4 (= 4:4.13.3-0ubuntu0.1) but 4:4.14.3-0ubuntu1~ubuntu14.04~ppa3 is to be installed
Depends: libkdepimdbusinterfaces4 (= 4:4.13.3-0ubuntu0.1) but 4:4.14.3-0ubuntu1~ubuntu14.04~ppa3 is to be installed
E: Unable to correct problems, you have held broken packages.

But now 4.14.3 is mentioned?!
Do I now try
sudo apt-get install kontact=4:4.14.3-0ubuntu1~ubuntu14.04~ppa3
?
Mint 17.3 KDE 64-bit

minitux
Level 5
Level 5
Posts: 860
Joined: Tue Sep 12, 2017 10:05 am

Re: Purge/ and Reinstall Kontact

Post by minitux » Fri Oct 13, 2017 3:43 pm

yes try

Conker
Level 1
Level 1
Posts: 45
Joined: Mon Nov 25, 2013 3:09 pm

Re: Purge/ and Reinstall Kontact

Post by Conker » Fri Oct 13, 2017 3:49 pm

Well, I tried....

andy@andy-Satellite-L355:~ > sudo apt-get install kontact=4:4.14.3-0ubuntu1~ubuntu14.04~ppa3
[sudo] password for andy:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Version '4:4.14.3-0ubuntu1~ubuntu14.04~ppa3' for 'kontact' was not found
Mint 17.3 KDE 64-bit

minitux
Level 5
Level 5
Posts: 860
Joined: Tue Sep 12, 2017 10:05 am

Re: Purge/ and Reinstall Kontact

Post by minitux » Fri Oct 13, 2017 3:57 pm

it was just as I said before, try this again, remove the two packages and see if in the reinstallation of kontact install the right ones for

Code: Select all

sudo apt-get remove libkdepim4 libkdepimdbusinterfaces4

Code: Select all

sudo apt-get install kontact

Conker
Level 1
Level 1
Posts: 45
Joined: Mon Nov 25, 2013 3:09 pm

Re: Purge/ and Reinstall Kontact

Post by Conker » Fri Oct 13, 2017 4:18 pm

I removed the two packages and I now get

sudo apt-get install kontact
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kontact : Depends: libkdepim4 (= 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Do I now try
sudo apt-get install kontact=4:4.14.2-0ubuntu1~ubuntu14.04~ppa1
?
or maybe follow phd21 and reinstall all PIM?
Mint 17.3 KDE 64-bit

minitux
Level 5
Level 5
Posts: 860
Joined: Tue Sep 12, 2017 10:05 am

Re: Purge/ and Reinstall Kontact

Post by minitux » Fri Oct 13, 2017 4:59 pm

try to follow phd21.

what I think is, there is a problem between package versions in Mint repositories and Ubuntu repository repositories

Conker
Level 1
Level 1
Posts: 45
Joined: Mon Nov 25, 2013 3:09 pm

Re: Purge/ and Reinstall Kontact

Post by Conker » Fri Oct 13, 2017 9:29 pm

Thanks for support phd21, here is the inxi output

andy@andy-Satellite-L355:~ > inxi -Fxzd
System: Host: andy-Satellite-L355 Kernel: 3.19.0-32-generic x86_64 (64 bit gcc: 4.8.2)
Desktop: KDE Plasma 4.14.13 (Qt 4.8.6) Distro: Linux Mint 17.3 Rosa
Machine: System: TOSHIBA product: Satellite L355 v: PSLD8U-01F00Y
Mobo: TOSHIBA model: Portable PC Bios: INSYDE v: 2.20 date: 12/09/2009
CPU: Dual core Intel Core2 Duo T5800 (-MCP-) cache: 2048 KB flags: (lm nx sse sse2 sse3 ssse3) bmips: 7981
clock speeds: max: 2000 MHz 1: 1200 MHz 2: 2000 MHz
Graphics: Card: Intel Mobile 4 Series Integrated Graphics Controller bus-ID: 00:02.0
Display Server: X.Org 1.15.1 drivers: intel (unloaded: fbdev,vesa) Resolution: 1600x900@60.0hz
GLX Renderer: Mesa DRI Mobile Intel GM45 Express GLX Version: 2.1 Mesa 10.1.3 Direct Rendering: Yes
Audio: Card Intel 82801I (ICH9 Family) HD Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k3.19.0-32-generic
Network: Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
driver: r8169 v: 2.3LK-NAPI port: 3000 bus-ID: 02:00.0
IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
Card-2: Intel WiFi Link 5100 driver: iwlwifi v: in-tree: bus-ID: 03:00.0
IF: wlan0 state: down mac: <filter>
Drives: HDD Total Size: 320.1GB (13.3% used) ID-1: /dev/sda model: Hitachi_HTS54323 size: 320.1GB
Optical: /dev/sr0 model: PIOR DVD-RW DVRTD08L rev: 2.54 dev-links: cdrom
Features: speed: 24x multisession: yes
audio: yes dvd: yes rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
Partition: ID-1: / size: 290G used: 36G (14%) fs: ext4 dev: /dev/sda1
ID-2: swap-1 size: 4.16GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 48.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 174 Uptime: 7:56 Memory: 1084.9/3822.8MB Init: Upstart runlevel: 2 Gcc sys: 4.8.4
Client: Shell (bash 4.3.111) inxi: 2.2.28

Before I decide on using the kubuntu backport (listed as possibly unstable/ not officially supported to some extent) here is a little background. I am very much still on the linux learning curve and therefore have chosen a conservative system - still on Mint KDE 17.3 which means KDE 4.14.13. (and it has worked very well for me - kudos to the team). In other words you are comfortable to put a non official repository on Mint 17.3 which is officially supported for another two years?
Do I understand correctly that the kubuntu backport would still keep me on KDE4 if I implement your suggestions?
Mint 17.3 KDE 64-bit

Conker
Level 1
Level 1
Posts: 45
Joined: Mon Nov 25, 2013 3:09 pm

Re: Purge/ and Reinstall Kontact

Post by Conker » Sun Oct 15, 2017 1:18 pm

Does the inxi information look OK phd21
I followed your suggestions and am now in a mess - dozens of dependency problems and several key apps like dolphin, gweniew, software sources no longer there.
I reinstalled dolphinfrom terminal so could get some work done but this morning, when I booted up, I cannot login
Message reads

Session only lasted 10 seconds
mdm[1416]: GLib-CRITICAL:
g-key-file:: assertion 'key-file!=NULL" failed

I can get o a terminal with ctl-alt-F1and any suggestions what I should do there would be most welcome
(Cannot launch firefox for example due to GDK Backend does not match available displays)
Mint 17.3 KDE 64-bit

User avatar
phd21
Level 16
Level 16
Posts: 6195
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Purge/ and Reinstall Kontact

Post by phd21 » Sun Oct 15, 2017 4:21 pm

Hi "Conker",

You are welcome...

You did not wait for a reply from your previous post before installing the PPA.

I do not see anything wrong with the results of the "inxi -Fxzd", which is good.

I think Linux Mint 17.3 all editions including KDE are superb and super stable. KDE 17.3 is still my favorite Linux Mint.

I always install Linux Mint KDE 17.3 and right afterwards, I install the Kubuntu Backport PPA to avoid conflicts. I have been doing this since KDE 17.3 came out and it works great on my system.

I do not know what may have caused your current issues.

I will assume you have good backups of anything you need like data, docs, multimedia files, passwords, etc...

Anyone installing anything in anyway on any computer operating system, should always check to see if the installation of something is going to remove anything, and if it states that it will and you do not want that or are unsure, then say no to continue installation, and ask here before trying again. Sometimes you can write down what it is removing and install (re-install) those applications or packages afterwards.

Here are some things you can try. Read these first. I think option #3 is your best option.

1.) See if the system will update and upgrade the KDE apps using the now installed Kubuntu PPA from the console terminal prompt,

Code: Select all

sudo apt-get upgrade

Code: Select all

sudo apt-get install -f
Reboot

OR

2.) Remove the Kubuntu ppa

Code: Select all

sudo apt-get install ppa-purge

Code: Select all

sudo ppa-purge ppa:kubuntu-ppa/backports

Code: Select all

sudo apt-get update

Code: Select all

sudo apt-get install -f
reboot

3.) Re-install Linux Mint KDE 17.3, run the Mint Updates, right afterwards install the PPA "ppa:kubuntu-ppa/backports", re-run updates, then you should be fine to install the applications you had before. The PPA will provide newer KDE applications than the default Linux Mint KDE 17.x system.


Hope this helps ...
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

Post Reply

Return to “KDE”