[SOLVED] Mint 18.3 KDE performance problems

Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 6
Joined: Fri Jun 26, 2015 3:34 am

[SOLVED] Mint 18.3 KDE performance problems

Post by RichardR » Thu Jan 11, 2018 6:35 am

I've been using Mint 17.3 KDE for some time now, but yesterday, a kernel update (probably for the Spectre/Meltdown CPU vulnerability) broke nVidia proprietary driver support. So far, there appears no way to fix this, so I decided to install 18.3 KDE as multi-boot next to 17.3, so that I can revert to 17.3 if necessary.

Unfortunately, I'm having a rather severe performance problem with 18.3: very often, things 'freeze' for seconds on end. Just now, while typing this text, this happened again. After several seconds, the system catches up, the typed characters finally appear, and everything goes on like nothing happened. It can get even worse when opening a new application from the KDE menu (or doing something else that probably involves a context switch): after hovering the mouse pointer over a main category, it often takes up to 10 seconds before the secondary menu appears.

Note: it was noticeably worse when I first simply started 18.3 KDE with a full copy of my 17.3 home directory, including all hidden files and folders from 17.3 such as .config, .local and .kde. After logging out and doing away with these hidden folders via a virtual console, things improved, but they haven't gone away completely.

Here's my system info:

Code: Select all

$ inxi -Fxz
System:    Host: linetec Kernel: 4.13.0-26-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: KDE Plasma 5.8.8 (Qt 5.6.1) Distro: Linux Mint 18.3 Sylvia
Machine:   Mobo: ASUSTeK model: P8H77-M LE v: Rev X.0x Bios: American Megatrends v: 1005 date: 10/11/2012
CPU:       Quad core Intel Core i5-3350P (-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 24743
           clock speeds: max: 3300 MHz 1: 3092 MHz 2: 3092 MHz 3: 3092 MHz 4: 3092 MHz
Graphics:  Card: NVIDIA GK107 [GeForce GT 640] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz, 1920x1080@60.00hz
           GLX Renderer: GeForce GT 640/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 384.111 Direct Rendering: Yes
Audio:     Card-1 Intel 7 Series/C210 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 NVIDIA GK107 HDMI Audio Controller driver: snd_hda_intel bus-ID: 01:00.1
           Sound: Advanced Linux Sound Architecture v: k4.13.0-26-generic
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 03:00.0
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 4120.8GB (21.3% used) ID-1: /dev/sda model: Samsung_SSD_840 size: 120.0GB
           ID-2: /dev/sdb model: WDC_WD20EARX size: 2000.4GB ID-3: /dev/sdc model: WDC_WD20EARX size: 2000.4GB
Partition: ID-1: / size: 29G used: 10G (37%) fs: ext4 dev: /dev/sda6
           ID-2: /home size: 1.8T used: 785G (46%) fs: ext4 dev: /dev/dm-4
           ID-3: swap-1 size: 8.00GB used: 0.00GB (0%) fs: swap dev: /dev/dm-3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 0.0:39C
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 216 Uptime: 11:44 Memory: 3514.7/7927.7MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35
dmesg and kernel log give some errors that may hint at the cause. Immediately after booting, this happens:

Code: Select all

[   13.682401] nvidia-modeset: Allocated GPU:0 (GPU-3402778f-65ca-4707-4f70-adb1ae13d15b) @ PCI:0000:01:00.0
[  317.894633] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
[ 2531.176060] EXT4-fs (sda5): mounted filesystem with ordered data mode. Opts: (null)
[ 2844.557957] show_signal_msg: 9 callbacks suppressed
[ 2844.557959] kactivitymanage[2228]: segfault at 7f5e65ef8cd0 ip 00007f5e64024301 sp 00007ffe23b6f208 error 4 in libQt5Sql.so.5.6.1[7f5e6400e000+45000]
[ 2844.562914] QDBusConnection[6669]: segfault at 7f8c10f32f10 ip 00007f8c2a5686c7 sp 00007f8c11f6e9a0 error 4 in libQt5Core.so.5.6.1[7f8c2a2b6000+4c0000]
[ 2844.955352] nvidia-modeset: Freed GPU:0 (GPU-3402778f-65ca-4707-4f70-adb1ae13d15b) @ PCI:0000:01:00.0
[ 2846.358780] nvidia-modeset: Allocated GPU:0 (GPU-3402778f-65ca-4707-4f70-adb1ae13d15b) @ PCI:0000:01:00.0
[ 3684.501376] kactivitymanage[6982]: segfault at 7f606c094cd0 ip 00007f606c03a301 sp 00007ffd285ce9e8 error 4 in libQt5Sql.so.5.6.1[7f606c024000+45000]
[ 3684.506017] QDBusConnection[9757]: segfault at 7fb57c181f10 ip 00007fb5907a46c7 sp 00007fb577ffe9a0 error 4 in libQt5Core.so.5.6.1[7fb5904f2000+4c0000]
[ 3684.885291] nvidia-modeset: Freed GPU:0 (GPU-3402778f-65ca-4707-4f70-adb1ae13d15b) @ PCI:0000:01:00.0
[ 3686.305845] nvidia-modeset: Allocated GPU:0 (GPU-3402778f-65ca-4707-4f70-adb1ae13d15b) @ PCI:0000:01:00.0
[ 5561.035151] PM: Syncing filesystems ... done.
These segfaults only happen at boot time, not later on. What does occur regularly, are these ACPI errors:

Code: Select all

[ 5568.225796] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20170531/psargs-364)
[ 5568.225801] ACPI Error: Method parse/execution failed \_SB.PCI0.SAT0.SPT0._GTF, AE_NOT_FOUND (20170531/psparse-550)
But this apparently has to do with the BIOS version; perhaps I should flash the latest version, but I have to find out how to do that first.

And oh, there's this:

Code: Select all

[ 7480.133716] perf: interrupt took too long (2507 > 2500), lowering kernel.perf_event_max_sample_rate to 79750
[10323.172938] perf: interrupt took too long (3147 > 3133), lowering kernel.perf_event_max_sample_rate to 63500
The system runs off an SSD drive (/dev/sda) with a simple mirrored RAID (/dev/sdc) for my user data, and system specs aren't exactly shabby.
I wondered if there's a way to find out what is causing the temporary freezing? I didn't have this at all under 17.3, so I don't think that the SSD drive is to blame (and the partition where 18.3 was installed has never been used up until now).

Can someone give some hints how to find the cause of this performance problem? Or maybe the above already has some important clues? As you probably noticed by now, I am knowledgeable up to a point, but not a real expert on this subject matter - hence my asking for help here :?



I did some timing, and things are Not Good:
- Time between clicking KDE menu and menu actually appearing: 11 seconds
- Time between clicking Dolphin file manager and Dolphin starting: 15 seconds
- Time between pressing F4 in Dolphin and Terminal window appearing: 22 seconds
- [and so on]

This is crazy; there must be something seriously wrong with KDE, but I can't figure out what at the moment. Maybe I'll try another clean install, reconstructing my home directory from scratch, because this is unworkable.

[update 2]
After once more rebooting and again removing .kde, .local, .config etcetera before logging in to give KDE a clean slate, things are much better. Maybe I missed something the first time.
Hopefully things are OK now, but I'll give it a bit more time before marking this as solved.

Final update:
OK, after another 24 hours of testing, things still seem normal. I still don't know for certain what caused the initial issues, but everything points to incompatibility between KDE configuration files.
So when installing Mint 18.x while retaining a previous version's /home directory/partition, it seems advisable to delete all KDE-related hidden folders first.

Mint 18.3 KDE now works just fine, and the only disappointment so far is that there appears to be no easy way to customize individual virtual desktops (I used to have an unobtrusive blue background for daytime work, a darker reddish-brown one for night-time stuff, and a black one for playing small games and watching videos on my dual-screen desktop).

Post Reply

Return to “KDE”