Critcial bug of konsole in KDE5

Forum rules
Before you post please read how to get help
Post Reply
braingateway
Level 3
Level 3
Posts: 105
Joined: Thu Sep 29, 2011 4:21 pm

Critcial bug of konsole in KDE5

Post by braingateway » Fri Mar 23, 2018 4:01 am

the closed konsole window will cause a residue console process 100% for one CPU core.
How to repeat:
open system activity, search konsole. You will see nothing there.
start a konsole window. you can see the new process of konsole.
Close that window, the konsole window disappear but the konsole process will went to 100% for one core and never terminate.

thunder422
Level 2
Level 2
Posts: 52
Joined: Wed May 16, 2012 7:26 am

Re: Critcial bug of konsole in KDE5

Post by thunder422 » Fri Mar 23, 2018 7:25 am

I'm not seeing that here - when Konsole is closed, it disappears from System Activity and the CPU is not at a 100%. Perhaps it is getting hung up in a bash script (.bashrc, .bash_profile, etc.) from some program that was started in there.

Try this, clear the search window in System Activity and select "All Processes, Tree" (upper right corner), and start Konsole. Find konsole in System Activity (not using search) and click the right arrow on konsole to open the applications under konsole (if you use search for "konsole" no other programs will show, so you must clear the search). You should see "bash" under it. Any applications started by bash will be under bash (I see none).

For example if you type the command "ls -R /" (a command that will not complete instantly), and wait a tiny bit, you will see "ls" appear under bash under konsole in System Activity. If perhaps some other application has been started (by bash or maybe konsole), you should see that too. If there is another app running, it may be preventing konsole from terminating. Normally upon exit, konsole will pop up a warning, though any program is running in the background will be terminated (I tried doing "ls -lR / &" and then closed konsole, and bash/ls was also terminated). But maybe some program is there stuck and not terminating like it should.
Mint 17.3 KDE: AMD FX-6300, 16GB RAM, GTX 660Ti (2GB), Gigabyte 990FXA-UD5
(with Windows XP, Windows 10, and Mint 18.3 KDE VMs on VirtualBox)

Post Reply

Return to “KDE”