KDE Installed On Cinnamon

Forum rules
Before you post please read how to get help
Post Reply
mroctober77
Level 1
Level 1
Posts: 1
Joined: Sat Apr 14, 2018 10:33 pm

KDE Installed On Cinnamon

Post by mroctober77 » Sat Apr 14, 2018 10:43 pm

I tried to install Plasma on 18.3 Cinnamon, it seems to have worked with a few issues. the Konsole was not installed, so had to install it. there was no audio, installed kmix to fix that. Only issue left is, there is no Screen Locking setting under Desktop Behavior. I installed a Widget, Batteries and Brightness that works to stop the locking, but does not remember the setting after reboot or logout.

Is there another way to disable to screen locking?

User avatar
catweazel
Level 17
Level 17
Posts: 7747
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: KDE Installed On Cinnamon

Post by catweazel » Sun Apr 15, 2018 12:33 am

mroctober77 wrote:
Sat Apr 14, 2018 10:43 pm
Is there another way to disable to screen locking?
You've created a frankendesktop. If you need KDE, use the Mint KDE iso. Also see this.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

thunder422
Level 2
Level 2
Posts: 52
Joined: Wed May 16, 2012 7:26 am

Re: KDE Installed On Cinnamon

Post by thunder422 » Sun Apr 15, 2018 10:15 am

mroctober77 wrote:
Sat Apr 14, 2018 10:43 pm
Is there another way to disable to screen locking?
I've had trouble with the Mint KDE's over the years with the screen saver time setting essentially being ignored even when disabled. The screen saver/lock always kicked in after 10 minutes. Very aggravating that I eventually just disabled the locking option.

I did eventually find a partial solution (on Mint 17.3, I haven't switched to 18.3 yet, only have it running in a VM at the moment). It appears that there are multiple screen savers running, the KDE one and the X one. I found that running the command xscreensaver-demo gets to the X screen saver options. You need to first install the xscreensaver package.

Upon running this command (from a terminal, i.e. Konsole), it first comes out with the message "The XScreenSaver daemon doesn't seem to be running on display ":0". Launch it now?" Click OK and then there is the Screensaver Preferences windows (which was underneath the message box). You should see the current setting is 10 minutes (which is where I believe the 10 minutes was coming from regardless of what time was entered in the KDE screen saver options). From here, you can select Mode: Disable Screen Saver and the X screen saver will be completely disabled, so only the KDE screen should be active. It appears to remember these settings after reboot or power off.

I know this seems strange that even though the xscreensaver package is neither initially installed and upon running -demo it says that it is not running, but I suspect that something in X is indeed installed and running. It wasn't until after installing and running the xscreensaver-demo program and setting it to disabled, did the KDE screen saver settings start to work. This was under Mint 13 and 17.3. I did not play with 18.3 enough yet - it has the KDE default set to 5 minutes, which seems kind of short.

Back to your original question, if the Screen Locking option is not under Desktop Behavior, then some KDE package didn't get installed. Looking at installed packaged with "lock" in that name, I only see libkscreenlocker5. Check if that is installed, though I suspect that may not have anything to do with the settings being missing. The screen locker settings are in the ~/.config/kscreenlockerrc configuration file. The lock option is turned off by adding "LockOnResume=false" under the "[Daemon]" section.

Alternatively if you can't get the KDE screen saver installed, maybe you can use the xscreensaver. In any case, this is the problem with trying to install KDE on top of another DE. The mint-meta-kde should install all of the packages needed, but in the absence of this package (e.g. Mint 19+), it will be hard to get all of the packages you need installed. Plus there is the problem of borking something by conflicting packages/libraries with the existing DE.
Mint 17.3 KDE: AMD FX-6300, 16GB RAM, GTX 660Ti (2GB), Gigabyte 990FXA-UD5
(with Windows XP, Windows 10, and Mint 18.3 KDE VMs on VirtualBox)

o-l-d
Level 3
Level 3
Posts: 116
Joined: Sun Sep 25, 2016 1:19 am

Re: KDE Installed On Cinnamon

Post by o-l-d » Sun Apr 15, 2018 12:00 pm

Screen locking can be disabled by going to Menu > System Settings > Desktop Behavior > Screen Locking uncheck the check boxes and click Apply. Also System Settings> Power Management> Activities> uncheck Default and check Define a Special Behavior then check the boxes you feel suit your needs and click Apply. By default screensavers are disabled in KDE Plasma. This works if you did a full install of the KDE environment.

Post Reply

Return to “KDE”