Fonts looks really bad.

Forum rules
Before you post please read how to get help
Post Reply
nepius
Level 1
Level 1
Posts: 4
Joined: Sat Apr 21, 2018 12:18 pm

Fonts looks really bad.

Post by nepius » Sat Apr 21, 2018 12:27 pm

Hello,

i'm on Linux Mint 18.3 Sylvia x86_64. Every fonts looks very "aliased" and bad like in https://imgur.com/TpZ0cBp this image, in font settings i've set anti-aliasing to "enable" then sub-pixel rendering to "RGB" and hinting style to "medium". I even tried to install the Roboto font but it still looks "bad".

Is there something i can do? Thanks

User avatar
catweazel
Level 17
Level 17
Posts: 7519
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Fonts looks really bad.

Post by catweazel » Sat Apr 21, 2018 4:04 pm

nepius wrote:
Sat Apr 21, 2018 12:27 pm
Is there something i can do?
Please post the output of this terminal command:

Code: Select all

inxi -Fxz
Enclose the results inbetween [ⅽode] and [/ⅽode] code markers by selecting </> from the mini toolbar above the textbox where you type your reply.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

nepius
Level 1
Level 1
Posts: 4
Joined: Sat Apr 21, 2018 12:18 pm

Re: Fonts looks really bad.

Post by nepius » Sat Apr 21, 2018 6:44 pm

catweazel wrote:
Sat Apr 21, 2018 4:04 pm
nepius wrote:
Sat Apr 21, 2018 12:27 pm
Is there something i can do?
Please post the output of this terminal command:

Code: Select all

inxi -Fxz
Enclose the results inbetween [ⅽode] and [/ⅽode] code markers by selecting </> from the mini toolbar above the textbox where you type your reply.

Code: Select all

System:    - Kernel: 4.13.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: KDE Plasma 5.8.9 (Qt 5.6.1) Distro: Linux Mint 18.3 Sylvia
Machine:   Mobo: MSI model: H110M PRO-VD (MS-7996) v: 1.0
           Bios: American Megatrends v: 2.E0 date: 08/11/2017
CPU:       Dual core Intel Core i3-6100 (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 14784
           clock speeds: max: 3700 MHz 1: 1600 MHz 2: 1599 MHz 3: 1599 MHz
           4: 1600 MHz
Graphics:  Card: Intel Sky Lake Integrated Graphics bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: Mesa DRI Intel HD Graphics 530 (Skylake GT2)
           GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes
Audio:     Card-1 Intel Sunrise Point-H HD Audio
           driver: snd_hda_intel bus-ID: 00:1f.3
           Card-2 GYROCOM C&C driver: USB Audio usb-ID: 001-004
           Sound: Advanced Linux Sound Architecture v: k4.13.0-38-generic
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 01:00.0
           IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 1750.4GB (30.9% used)
           ID-1: /dev/sda model: Crucial_CT750MX3 size: 750.2GB
           ID-2: USB /dev/sdb model: External_USB_3.0 size: 1000.2GB
Partition: ID-1: / size: 679G used: 470G (73%) fs: ext4 dev: /dev/dm-0
           ID-2: /boot size: 473M used: 131M (30%) fs: ext2 dev: /dev/sda2
           ID-3: swap-1 size: 8.47GB used: 0.00GB (0%) fs: swap dev: /dev/dm-1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 44.0C mobo: 29.8C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 217 Uptime: 6:06 Memory: 2902.7/7869.8MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 

User avatar
catweazel
Level 17
Level 17
Posts: 7519
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Fonts looks really bad.

Post by catweazel » Sat Apr 21, 2018 7:06 pm

nepius wrote:
Sat Apr 21, 2018 6:44 pm

Code: Select all

Graphics:  Card: Intel Sky Lake Integrated Graphics bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: (unloaded: fbdev,vesa)
There's your problem. See this article in the section titled Solving freezes during the boot sequence.

I know you're not getting freezes but the it's the same fix. Ignore the part about nVidia graphics. You need to set the "nomodeset" option.

Also see the last post here: viewtopic.php?f=46&t=267487&p=1456311&h ... t#p1456311

That's for Cinnamon but it's the same problem, and the same fix.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

User avatar
trytip
Level 8
Level 8
Posts: 2137
Joined: Tue Jul 05, 2016 1:20 pm

Re: Fonts looks really bad.

Post by trytip » Sat Apr 21, 2018 9:21 pm

backup/compress/rename .config/fontconfig/fonts.conf or if you don't have one create a blank text call it fonts.conf paste this save and reboot. if it's the same just undo the work or keep it

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
    <match target="font">
        <edit name="antialias" mode="assign">
            <bool>true</bool>
        </edit>
        <edit name="hinting" mode="assign">
            <bool>true</bool>
        </edit>
        <edit name="hintstyle" mode="assign">
            <const>hintslight</const>
        </edit>
        <edit name="rgba" mode="assign">
            <const>rgb</const>
        </edit>
        <edit name="autohint" mode="assign">
            <bool>true</bool>
        </edit>
        <edit name="lcdfilter" mode="assign">
            <const>lcddefault</const>
        </edit>
        <edit name="dpi" mode="assign">
            <double>102</double>
        </edit>
    </match>
    <match target="font">
        <test name="weight" compare="more">
            <const>medium</const>
        </test>
        <edit name="autohint" mode="assign">
            <bool>true</bool>
        </edit>
    </match>
</fontconfig>
Image

User avatar
Flemur
Level 16
Level 16
Posts: 6109
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Fonts looks really bad.

Post by Flemur » Sat Apr 21, 2018 9:48 pm

nepius wrote:
Sat Apr 21, 2018 12:27 pm
Every fonts looks very "aliased" and bad like in https://imgur.com/TpZ0cBp this image, in font settings i've set anti-aliasing to "enable" then sub-pixel rendering to "RGB" and hinting style to "medium".
The font above the label "Anti-aliasing on" isn't aliased, and it looks just like your settings would indicate. Is it the one you think looks bad?
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

nepius
Level 1
Level 1
Posts: 4
Joined: Sat Apr 21, 2018 12:18 pm

Re: Fonts looks really bad.

Post by nepius » Sun Apr 22, 2018 3:30 pm

catweazel wrote:
Sat Apr 21, 2018 7:06 pm
nepius wrote:
Sat Apr 21, 2018 6:44 pm

Code: Select all

Graphics:  Card: Intel Sky Lake Integrated Graphics bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: (unloaded: fbdev,vesa)
There's your problem.
That's because i've run

Code: Select all

sudo apt-get remove xserver-xorg-video-intel
hoping to use

Code: Select all

modesetting
driver instead.
Flemur wrote:
Sat Apr 21, 2018 9:48 pm
nepius wrote:
Sat Apr 21, 2018 12:27 pm
Every fonts looks very "aliased" and bad like in https://imgur.com/TpZ0cBp this image, in font settings i've set anti-aliasing to "enable" then sub-pixel rendering to "RGB" and hinting style to "medium".
The font above the label "Anti-aliasing on" isn't aliased, and it looks just like your settings would indicate. Is it the one you think looks bad?
Mine look like anti-aliasing off!

User avatar
catweazel
Level 17
Level 17
Posts: 7519
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Fonts looks really bad.

Post by catweazel » Mon Apr 23, 2018 1:58 am

nepius wrote:
Sun Apr 22, 2018 3:30 pm
catweazel wrote:
Sat Apr 21, 2018 7:06 pm
There's your problem.
That's because i've run

Code: Select all

sudo apt-get remove xserver-xorg-video-intel
hoping to use

Code: Select all

modesetting
driver instead.
Yet you make no mention of this important fact.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

User avatar
Flemur
Level 16
Level 16
Posts: 6109
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Fonts looks really bad.

Post by Flemur » Mon Apr 23, 2018 8:10 am

nepius wrote:
Sun Apr 22, 2018 3:30 pm
Mine look like anti-aliasing off!
OK. Your first post wasn't clear.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

nepius
Level 1
Level 1
Posts: 4
Joined: Sat Apr 21, 2018 12:18 pm

Re: Fonts looks really bad.

Post by nepius » Mon Apr 23, 2018 10:27 am

trytip wrote:
Sat Apr 21, 2018 9:21 pm
backup/compress/rename .config/fontconfig/fonts.conf or if you don't have one create a blank text call it fonts.conf paste this save and reboot. if it's the same just undo the work or keep it

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
    <match target="font">
        <edit name="antialias" mode="assign">
            <bool>true</bool>
        </edit>
        <edit name="hinting" mode="assign">
            <bool>true</bool>
        </edit>
        <edit name="hintstyle" mode="assign">
            <const>hintslight</const>
        </edit>
        <edit name="rgba" mode="assign">
            <const>rgb</const>
        </edit>
        <edit name="autohint" mode="assign">
            <bool>true</bool>
        </edit>
        <edit name="lcdfilter" mode="assign">
            <const>lcddefault</const>
        </edit>
        <edit name="dpi" mode="assign">
            <double>102</double>
        </edit>
    </match>
    <match target="font">
        <test name="weight" compare="more">
            <const>medium</const>
        </test>
        <edit name="autohint" mode="assign">
            <bool>true</bool>
        </edit>
    </match>
</fontconfig>
Thank you with this fonts look better.

User avatar
trytip
Level 8
Level 8
Posts: 2137
Joined: Tue Jul 05, 2016 1:20 pm

Re: Fonts looks really bad.

Post by trytip » Mon Apr 23, 2018 12:09 pm

there are a few fonts.conf some work better some not much difference depending on the desktop you use. when you mix desktops like having installed default cinnamon and then adding kde you can really mess things up if you also install the kde control system settings and try to change fonts with that. here's another. for anti-alias hinting use slight or full, for me slight works good

Code: Select all

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>

  <match target="font">
    <edit name="autohint" mode="assign"><bool>false</bool></edit>
    <edit name="antialias" mode="assign"><bool>true</bool></edit>
    <edit name="hinting" mode="assign"><bool>true</bool></edit>
    <edit name="hintstyle" mode="assign"><const>hintslight</const></edit>
    <edit name="lcdfilter" mode="assign"><const>lcddefault</const></edit>
  </match>

  <!-- Info:
       xeffects thread:  http://forums.gentoo.org/viewtopic-t-511382.html
       http://wiki.archlinux.org/index.php/XOrg_Font_Configuration
       http://antigrain.com/research/font_rasterization/index.html
       http://fontconfig.org/fontconfig-user.html
  -->

  <!-- http://bugs.gentoo.org/show_bug.cgi?id=130466 -->
  <alias>
    <family>serif</family>
    <prefer>
      <family>DejaVu Serif</family>
      <family>Bitstream Vera Serif</family>
      <family>Liberation Serif</family>
    </prefer>
  </alias>

  <alias>
    <family>sans-serif</family>
    <prefer>
      <family>DejaVu Sans</family>
      <family>Bitstream Vera Sans</family>
      <family>Verdana</family>
      <family>Liberation Sans</family>
      <family>Arial</family>
    </prefer>
  </alias>

  <alias>
    <family>monospace</family>
    <prefer>
      <family>DejaVu Sans Mono</family>
      <family>Bitstream Vera Sans Mono</family>
      <family>Liberation Mono</family>
    </prefer>
  </alias>

  <!-- Reject bitmap fonts in favour of Truetype, Postscript, etc. -->
  <selectfont>
    <rejectfont>
      <pattern>
        <patelt name="scalable">
          <bool>false</bool>
        </patelt>
      </pattern>
    </rejectfont>
  </selectfont>

  <match target="pattern">
    <test qual="any" name="family"><string>fixed</string></test>
    <edit name="family" mode="assign"><string>monospace</string></edit>
  </match>

  <!-- Avoid embedded bitmap for all fonts -->
  <match target="font">
    <edit name="embeddedbitmap"><bool>false</bool></edit>
  </match>
</fontconfig>
Image

Post Reply

Return to “KDE”