Desktop Rendering issues on AMD/Nvidia system

Forum rules
Before you post please read how to get help
Post Reply
Chrisblobster
Level 1
Level 1
Posts: 2
Joined: Fri May 04, 2018 7:22 pm

Desktop Rendering issues on AMD/Nvidia system

Post by Chrisblobster » Fri May 04, 2018 7:47 pm

Hi all, I installed Mint 18.3 x64 KDE edition on a spare partition, but I'm getting intermittent fuzzy blurry looking elements on the desktop, taskbar, and in applications, particularly when moving things around the desktop, but also when there is no activity - I've not found any pattern to actions that trigger it. My system is an AMD Phenom 2 X6 1090T with 8GB RAM on a basic consumer level Gigabyte AM3 motherboard, and an NVidia GTX970 PCIe graphics card driving a 2560x1440 Dell U2711 monitor via DP. I couldn't boot the install DVD without using "nomodeset", and was limited to a 640x480 desktop until NVidia 384 was installed, but everything seems fine other than the rendering issues. See attached screen photo below. I'm picking KDE as the prime suspect in this as I have seen this before (but not as bad) running KDE 4.x on the same PC but with an older GTX 560 Ti graphics card and openSUSE. I'm aware that this is possibly the last KDE based Mint release, but before I grab either Cinnamon or Mate editions has anyone ever encountered something like this on their KDE/NVidia/Mint system?

Here is the photo, notice the mouse and text bubble are sharp and clear, but the Firefox browser has blurred out to almost the point of being unreadable - ugly stuff!

LinuxMint18.3 blurry desktop problem.jpg
LinuxMint18.3 blurry desktop problem.jpg (18.65 KiB) Viewed 455 times
Regards,

Chris, New Zealand

User avatar
catweazel
Level 17
Level 17
Posts: 7767
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Desktop Rendering issues on AMD/Nvidia system

Post by catweazel » Fri May 04, 2018 8:18 pm

Chrisblobster wrote:
Fri May 04, 2018 7:47 pm
intermittent fuzzy blurry looking elements on the desktop, taskbar, and in applications, particularly when moving things around the desktop, but also when there is no activity
System settings > Fonts > Force fonts DPI (on, 96)
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

Chrisblobster
Level 1
Level 1
Posts: 2
Joined: Fri May 04, 2018 7:22 pm

Re: Desktop Rendering issues on AMD/Nvidia system

Post by Chrisblobster » Fri May 04, 2018 9:08 pm

System settings > Fonts > Force fonts DPI (on, 96)
Before I saw your suggestion on a hunch I turned off compositing, and rebooted - problem went away, then I saw your suggestion and changed the font setting to force 96 dpi, and turned compositing back on in the hope the font dpi thing helped - the problem returned. So it is compositing causing it. It affects the *entire* desktop, including the wallpaper. Basically unusable as smaller text is blurred to the point of being almost unreadable despite my WQHD monitor.

I might just ditch KDE, and try Cinnamon - I wasted days trying to fix similar issues in KDE 4.x under openSUSE, years ago, but only entire point updates seemed to do anything - I still run openSUSE 13.1 with the default KDE 4.14 because that one worked for me, and a later openSUSE KDE didn't, so I regressed it.

Cheers for the suggestion, that may fix other ills. :)

Chris, New Zealand

Post Reply

Return to “KDE”