Can't set default programs

Forum rules
Before you post please read how to get help
Post Reply
funinthesun
Level 1
Level 1
Posts: 19
Joined: Tue Feb 11, 2014 5:19 pm

Can't set default programs

Post by funinthesun » Tue May 08, 2018 12:22 am

I have Mint 17.2 KDE on this machine. I know it's old but it works for me and I have a ton of addon programs that I would have to reinstall if I upgraded. My problem is getting VLC media player to start when I double click a 3GP file. It always wants to start in Amarok which I don't want. If I right click the file, select open with, choose other and deliberately select VLC and then check the Remember application association a dialog pops up that indicates that the system is updating the change. However on double clicking a 3gp file nothing has changed and it still tries to start with Amarok. How do I get the file to reassociate with the program I want.

thunder422
Level 2
Level 2
Posts: 51
Joined: Wed May 16, 2012 7:26 am

Re: Can't set default programs

Post by thunder422 » Tue May 08, 2018 6:51 am

I'm still on 17.3 - it works and is still supported.

Yes, I've seen that option to remember, but it doesn't seem to actually remember. Here's what I do instead: Settings, under Common Appearance and Behavior select File Associations. Open video (click on the '+' or triangle in front of it). Click on 3gpp. On the right your see various Filename Patterns, one of which is *.3gp. Below is the Application Preference Order. Click on VLC media player, which is probably not at the top, click on Move Up until it is. Click Apply and that should do it.
Mint 17.3 KDE: AMD FX-6300, 16GB RAM, GTX 660Ti (2GB), Gigabyte 990FXA-UD5
(with Windows XP and Windows 10 VMs on VirtualBox)

blue_bullet
Level 2
Level 2
Posts: 76
Joined: Wed May 11, 2011 8:45 pm
Location: NW Montana

Re: Can't set default programs

Post by blue_bullet » Tue May 08, 2018 1:35 pm

I am also happily running 17.3 and watch a trial version of 18.3 on an old laptop. Still not happy with 18.3.

Here's what I did and it worked as well. In dolphin right click on a .mp3 file, select properties, click on file type options, click on VLC, click on Move Up button, click on Apply, click on OK, click on OK. Your are done.

funinthesun
Level 1
Level 1
Posts: 19
Joined: Tue Feb 11, 2014 5:19 pm

Re: Can't set default programs

Post by funinthesun » Tue May 15, 2018 5:41 pm

Thanks for the advice. I used thunder422s recommendation but it didn't work, so I just removed Amarok and Dragon from the list and then it worked the way I wanted. Thanks again.

Post Reply

Return to “KDE”