Isadora KDE Development Progress Report

Forum rules
Before you post please read how to get help
User avatar
Boo
Level 7
Level 7
Posts: 1634
Joined: Mon Mar 26, 2007 7:48 am

Re: Isadora KDE Development Progress Report

Post by Boo » Sat May 15, 2010 1:12 am

you must have a missing repository.
or
a missing key for a repository.

acetoneiso and miro are in the lucid universe repo.
deb http://us.archive.ubuntu.com/ubuntu/ lucid universe

plymouth-them-mint-kde is in the isadora-kde repo.
deb http://packages.linuxmint.com isadora-kde main upstream import

Boo
Image
Now where was i going? Oh yes, crazy!

User avatar
Andrew33
Level 4
Level 4
Posts: 462
Joined: Fri Mar 26, 2010 12:58 pm
Location: Maple Heights, Ohio Republic USA
Contact:

Re: Isadora KDE Development Progress Report

Post by Andrew33 » Sat May 15, 2010 1:57 am

Hello Boo, I hate to sound like a pest, but the plymouth theme still isn't installing due to unsatisfied dependencies. I also know that when I go to install KDE 4.4.3, it will mess up the current Isadora config, because Isadora isn't complete yet. Every time I do that, I end up with just a black screen and tty. Through apt-get dist-upgrade, it takes out the very packages that were just installed and I'm not an expert at any of this...so again, I appologize for being a pest with all this. I really do appreciate all your wonderful work Boo. With what you have going with Isadora, KDE 4.4.3 isn't compatible right now with it...thank you for all your help

Andrew

User avatar
Boo
Level 7
Level 7
Posts: 1634
Joined: Mon Mar 26, 2007 7:48 am

Re: Isadora KDE Development Progress Report

Post by Boo » Sat May 15, 2010 4:22 am

I think the mint versions of plymouth (in the mint repos) may be causing your plymouth problems.
I have not installed/updated to the mint versions of plymouth. there could be dependency problems.

I have installed my laptop with kubuntu, updated and then updated to KDE 4.4.3.
all is fine.
then i installed plymouth-theme-mint-kde and it works too.

Boo
Image
Now where was i going? Oh yes, crazy!

User avatar
Boo
Level 7
Level 7
Posts: 1634
Joined: Mon Mar 26, 2007 7:48 am

Re: Isadora KDE Development Progress Report

Post by Boo » Sat May 15, 2010 6:47 pm

Note to people installing mint KDE packages on a Gnome install.
mint-configuration-kde deletes /etc/gdm.
This was done in mint 8 KDE due to at least one file in /etc/gdm causing big problems.
I will change this with an update and see if the gdm problem appears again.
so if you have no gdm now install it with
apt-get install gdm


Boo
Image
Now where was i going? Oh yes, crazy!

User avatar
Catmint
Level 1
Level 1
Posts: 20
Joined: Thu May 13, 2010 11:20 am

Re: Isadora KDE Development Progress Report

Post by Catmint » Tue May 18, 2010 3:51 pm

Now that the final version of Mint 9 has been released, any updates on when the Kde64 version will come? :?:
With Mint 8, it took over two months after the final release. I hope it won't take that long this time.

User avatar
Andrew33
Level 4
Level 4
Posts: 462
Joined: Fri Mar 26, 2010 12:58 pm
Location: Maple Heights, Ohio Republic USA
Contact:

Re: Isadora KDE Development Progress Report

Post by Andrew33 » Tue May 18, 2010 5:21 pm

Boo,

I'm still playing with the repo's on Isadora, I noticed you updated mint-configuration-kde_1.9.6_all.deb....I just tried to install that after downloading and I got this:

(Reading database ... (Reading database ... 5%(Reading database ... 10%(Reading database ... 15%(Reading database ... 20%(Reading database ... 25%(Reading database ... 30%(Reading database ... 35%(Reading database ... 40%(Reading database ... 45%(Reading database ... 50%(Reading database ... 55%(Reading database ... 60%(Reading database ... 65%(Reading database ... 70%(Reading database ... 75%(Reading database ... 80%(Reading database ... 85%(Reading database ... 90%(Reading database ... 95%(Reading database ... 100%(Reading database ... 148663 files and directories currently installed.)
Preparing to replace mint-configuration-kde 1.9.6 (using .../mint-configuration-kde_1.9.6_all.deb) ...
Unpacking replacement mint-configuration-kde ...
Setting up mint-configuration-kde (1.9.6) ...
cp: cannot stat `usr/lib/linuxmint/mintSystem/adjustments/kde/startkde': No such file or directory
dpkg: error processing mint-configuration-kde (--install):
subprocess installed post-installation script returned error exit status 1
Processing triggers for mintsystem ...
Errors were encountered while processing:
mint-configuration-kde

Is there a special way I should be trying to install this, should I use term. I know this was just put out today...but I'm just curious...let me know...thanks Boo...great work.


Andrew

User avatar
Boo
Level 7
Level 7
Posts: 1634
Joined: Mon Mar 26, 2007 7:48 am

Re: Isadora KDE Development Progress Report

Post by Boo » Tue May 18, 2010 11:13 pm

mint-configuration-kde
well I could have made a typo when looking at startkde in the adjustments or the postinst script.
looks like i might have deleted the first "/".
I will check tonight.

Mint KDE will not be too far behind. I have had less problems this time around.
KDE 4.4 now can use a javascript api to configure the desktop widgets, so im having fun learning that too.
I have not updated to KDE 4.4.3 yet, that will be tonights fun.

Boo
Image
Now where was i going? Oh yes, crazy!

User avatar
Andrew33
Level 4
Level 4
Posts: 462
Joined: Fri Mar 26, 2010 12:58 pm
Location: Maple Heights, Ohio Republic USA
Contact:

Re: Isadora KDE Development Progress Report

Post by Andrew33 » Wed May 19, 2010 12:03 am

Boo,

I just had to reinstall Mint 8 KDE due to the mint-configuration-kde_1.9.6_all.deb that took out the task bar on reboot in Isadora, so when anyone else that experimenting with Isadora, they'll notice this too. Upon installing and rebooting, that file renders Isadora useless....so for right now, I can't do anymore testing until that file gets fixed....sorry to be the bringer of bad news, but these are facts...your work thus far has been awsome, just that one file. Also?, in what order should the repo files be installed (for correct functionality). Thanks Boo...hope you can fix this so we all can move forward on this....have a great evening.


Andrew

User avatar
blazemore
Level 2
Level 2
Posts: 75
Joined: Wed Jul 16, 2008 6:49 am

Re: Isadora KDE Development Progress Report

Post by blazemore » Wed May 19, 2010 4:39 am

OMG what is taking u so long, how long can it take jeez u need a predictable release schedule just release already!
</joke>

Looking forward to the release, Kubuntu Lucid was the first KDE distro worth looking at, so Mint stands to be even better!

User avatar
Boo
Level 7
Level 7
Posts: 1634
Joined: Mon Mar 26, 2007 7:48 am

Re: Isadora KDE Development Progress Report

Post by Boo » Wed May 19, 2010 4:47 am

I guess it could have been the new javascript api scripts that killed your panel.
It has not got me yet...
previous updates have added an extra panel.

Boo
Image
Now where was i going? Oh yes, crazy!

User avatar
Andrew33
Level 4
Level 4
Posts: 462
Joined: Fri Mar 26, 2010 12:58 pm
Location: Maple Heights, Ohio Republic USA
Contact:

Re: Isadora KDE Development Progress Report

Post by Andrew33 » Wed May 19, 2010 6:08 am

Boo,

I just downloaded and installed the repo's including the new mint-configuration-kde_1.9.7_all.deb....sorry buddy, still have no task bar....gonna have to reinstall LM8 again and start over.....I'll talk to you more a little later...gonna go to bed for a bit and recharge.

Andrew :)

User avatar
Andrew33
Level 4
Level 4
Posts: 462
Joined: Fri Mar 26, 2010 12:58 pm
Location: Maple Heights, Ohio Republic USA
Contact:

Re: Isadora KDE Development Progress Report

Post by Andrew33 » Wed May 19, 2010 4:13 pm

OK...LM8 is up....again...lol...updating files and to 4.4.2 for now, just waiting on Isadora mint-configuration-kde fix or update from you....no worries mate....keep up the great work.


Andrew

User avatar
Andrew33
Level 4
Level 4
Posts: 462
Joined: Fri Mar 26, 2010 12:58 pm
Location: Maple Heights, Ohio Republic USA
Contact:

Re: Isadora KDE Development Progress Report

Post by Andrew33 » Wed May 19, 2010 4:30 pm

Oh....BTW, the plymouth theme and mint-meta kde's still won't install. I'm not trying to do this under 4.4.2 LM8...this is done under and after installing the Isadora repo's. So I don't know if you're still working on those or not.....let's keep in touch with each other so we can work through this...thanks Boo

Andrew

User avatar
Boo
Level 7
Level 7
Posts: 1634
Joined: Mon Mar 26, 2007 7:48 am

Re: Isadora KDE Development Progress Report

Post by Boo » Thu May 20, 2010 2:25 am

for plymouth you have to run:
sudo update-alternatives --config default.plymouth
choose mintkde one
sudo update-initrd -u

but ive seen some posts saying update-initrd may be a bit flaky for plymounth.

Boo
Image
Now where was i going? Oh yes, crazy!

User avatar
Andrew33
Level 4
Level 4
Posts: 462
Joined: Fri Mar 26, 2010 12:58 pm
Location: Maple Heights, Ohio Republic USA
Contact:

Re: Isadora KDE Development Progress Report

Post by Andrew33 » Thu May 20, 2010 4:23 am

OK, I'll try that, I just need the mint-configuration-kde_1.9.7 file to work without messing up the task bar....let me know if and when it's fixed.....thanks Boo


Andrew :)

keljaden
Level 2
Level 2
Posts: 98
Joined: Sun Aug 23, 2009 3:50 pm

Re: Isadora KDE Development Progress Report

Post by keljaden » Fri May 21, 2010 1:06 pm

I can't wait guys. Kubuntu *and even ubuntu* Lucid ran terrible on my desktop, I am hoping Kmint 9 will clean up the problems like they have in the past. I can not wait for the release. Keep up the phenomenal work.

User avatar
Andrew33
Level 4
Level 4
Posts: 462
Joined: Fri Mar 26, 2010 12:58 pm
Location: Maple Heights, Ohio Republic USA
Contact:

Re: Isadora KDE Development Progress Report

Post by Andrew33 » Fri May 21, 2010 2:00 pm

keljaden,

What type of desktop do you have, (i.e, make model, monitor, memory, cpu, etc.) I have Ubuntu 10.04 on my desktop in the other room and it runs just fine, it's an old Power Spec 6340. Ubuntu has always run good on it....I too am waiting patiently for LM9. What are some of the problems you're having with your desktop....let me know, maybe I can help...thanks

Andrew

User avatar
Andrew33
Level 4
Level 4
Posts: 462
Joined: Fri Mar 26, 2010 12:58 pm
Location: Maple Heights, Ohio Republic USA
Contact:

Re: Isadora KDE Development Progress Report

Post by Andrew33 » Fri May 21, 2010 11:38 pm

Hey Boo,

Is there a string of code missing from the start up or boot line. The reason I'm asking is that the task bar still doesn't get loaded upon boot sequence....so I'm just wondering if the linecode for the task bar got missed....is or was there something different you did between the first set of repo's and now. The first set was able to reboot and everything came up just fine, just wasn't able to advance to KDE 4.4.3 without things getting messed up. I'll be reloading LM8 on my laptop, so I'll be back shortly.....have a great day mate and take care.


Andrew :)

Zom
Level 1
Level 1
Posts: 5
Joined: Wed May 19, 2010 8:05 am
Location: The icy lands of the north.
Contact:

Re: Isadora KDE Development Progress Report

Post by Zom » Sat May 22, 2010 4:20 am

Hey boo, if you need more testers, send me a PM.

AnthonyA

Re: Isadora KDE Development Progress Report

Post by AnthonyA » Sat May 22, 2010 6:26 am

Hey Boo

Is there any chance at this stage the fix for USB Wacom Bamboo tablets can be added? Or is it too late for that?

This link seems to be one of the better fixes for this issue

http://ubuntuforums.org/showpost.php?p= ... ostcount=1

Post Reply

Return to “KDE”