Fortune Won't Go Away . . .

Forum rules
Before you post please read how to get help
Post Reply
enigma
Level 1
Level 1
Posts: 44
Joined: Wed Aug 05, 2009 3:26 pm
Location: ON, CA

Fortune Won't Go Away . . .

Post by enigma » Wed May 05, 2010 10:27 pm

I'm missing something here.

I went to /etc/bash.bashrc and I commented out the fortune line at the end of the text. PowerDown & PowerUp and Fortune is back in my terminal. I erased the line -- the same result.

I tried to modify my user .bashrc file none is present.

The header info at the top of /etc/bash.bashrc refers to /etc/profile. This bash script essentially says if /etc/bash.bashrc is present then run it. My bash scripting is minimal. I don't know the first block of code.

Obviously this file is being rewritten by fortune cookie monster! Does anyone know this animal :) ?

I am using LM KDE CE 8 upgraded to KDE4.4.2

enigma
Level 1
Level 1
Posts: 44
Joined: Wed Aug 05, 2009 3:26 pm
Location: ON, CA

Re: Fortune Won't Go Away . . .

Post by enigma » Thu May 06, 2010 2:37 pm

Haven't got the right answer yet so It's time to create a workaround.

Deleting /usr/bin/mint-fortune just causes a line to appear advising the file is missing. The workaround is worse that the problem.

The elegant way of working around this issue is to create a substitute mint-fortune that does nothing. The file is a bash executable root script so I wrote a substitute script that contains no text other than the header, renamed the original mint-fortune, and copied the new script into /usr/bin.

It works great but it is still only a workaround.

The question is still good.

Thanks.

User avatar
distro hopper
Level 2
Level 2
Posts: 50
Joined: Wed Sep 16, 2009 12:06 pm
Location: Toronto, Ontario

Re: Fortune Won't Go Away . . .

Post by distro hopper » Thu May 06, 2010 2:53 pm

I just commented out the last line of /etc/bash.bashrc (as you did) and it works fine... no problems here.
Distrohopper
Image

User avatar
mintnoob
Level 5
Level 5
Posts: 631
Joined: Wed Nov 04, 2009 11:46 pm
Location: USA

Re: Fortune Won't Go Away . . .

Post by mintnoob » Sun May 09, 2010 9:54 pm

Fortunes on my Terminal won't go away either! I did both the "##" and deleted the line and it still coming back. I don't mind the small fortunes, but the long ones are annoying.
Chakra Linux

User avatar
gychang
Level 3
Level 3
Posts: 138
Joined: Tue Dec 09, 2008 12:24 pm

Re: Fortune Won't Go Away . . .

Post by gychang » Mon Oct 04, 2010 9:23 am

I have the same problem on the latest KDE. locating last line is just "fi" on sudo nano /etc/bash.bashrc.

anyone have a easy solution?

gychang
--
cruising the desert
--

User avatar
Steely
Level 3
Level 3
Posts: 101
Joined: Sun Mar 16, 2008 5:29 pm

Re: Fortune Won't Go Away . . .

Post by Steely » Mon Oct 04, 2010 9:59 am

It depends on which version of Mint KDE you are using as it is done differently in the last 3 versions.

Mint 7 KDE if anyone is still using it is

kdesudo kate /etc/bash.bashrc
comment out the line at the end ie # /usr/bin/mint-fortune

Mint 8 KDE

kdesudo kate /etc/bash.bashrc

kdesudo kate /usr/lib/linuxmint/mintSystem/adjustments/kde/bash.bashrc

comment out the line at the end ie # /usr/bin/mint-fortune

Mint 9 KDE

In your home folder make sure that show hidden files is enabled and open .bashrc

comment out the line at the end ie # /usr/bin/mint-fortune

HTH

Dale

Post Reply

Return to “KDE”