How I'm Already Running Mint 9 KDE x64

Forum rules
Before you post please read how to get help
Post Reply
User avatar
Level 3
Level 3
Posts: 105
Joined: Wed May 19, 2010 8:14 pm
Location: Toronto, Ontario

How I'm Already Running Mint 9 KDE x64

Post by distrohopper »

DISCLAIMER: Let me be clear! DO NOT try this unless you understand there is a possibility this won't work as well for you! You risk breaking your system, and will likely not get any help!

I was impatient. I couldn't wait any longer and hacked together my own Mint 9 KDE. I was having problems trying to install Kubuntu, so I figured Mint will install just fine.. I'll start there. So I installed a fresh and clean Mint 9 x64. I then proceeded to install Kubuntu-desktop, login to KDE and strip out as much of the GNOME desktop as I could possibly find. I started with the GNOME applications, then a number of packages which were more 'behind the scenes' dependency packages. I'm pretty sure I got most of it.

So I then started stripping out some of the stuff that the Kubuntu-desktop package installs. Things like kpackagekit, uBlog, Kopete and anything else I didn't want. At this point I noticed I was using a load of memory (like 1.2 GB), so I did a complete reboot (also, to make sure everything was going well so far). So far, so good, but there was that ugly Kubuntu Plymouth screen.. I googled how to change the Plymouth theme and found some help at the Ubuntu forums and decided to install Mint's Fade-in theme (search synaptic).

Also, when I rebooted, Mintwelcome popped up on the desktop, but when I tried to click the checkbox and tell it not to load up again, it didn't actually close it. For some reason it became hidden. I removed the package all together. Problem solved.

Mintupdate wouldn't open when I clicked on it either. Now, this is really the most controversial part of this whole experience because Mint has removed the 'Mark All Upgrades' button from Synaptic for 'safety' reasons. But I'm faced with the fact MintUpdate won't run either. I decided to uninstall MintUpdate. If you go to /etc/linuxmint/adjustments/ there's a file, it's called 10-mintsystem-synaptic.overwrite. I removed the file and reinstalled Synaptic. I now have 'Mark All Upgrades' again.

So that was pretty much it. I went about installing all my preferred KDE apps (oh and this script for root actions in dolphin).

Although this has worked out really well (so far, for me) I can't stress enough how easy it is to break your system (especially when you're ripping out the GNOME stuff). Unless you are definitely comfortable taking the risk doing this, DON'T DO IT, wait for the actual release.
User avatar
Level 1
Level 1
Posts: 20
Joined: Thu May 13, 2010 11:20 am

Re: How I'm Already Running Mint 9 KDE x64

Post by Catmint »

Since I was getting fed up with waiting as well, I also tried this on Wednesday :twisted:
The only things I removed were 'mintwelcome' (useless anyway) and 'mintupdate' (to get a properly working synaptic with "mark all updates" entry). After removing 'mintupdate' and reinstalling synaptic however, I noticed that the distro list (software sources) was broken, and I couldn't access it anymore. Only after installing 'mintupdate' again (and disabling it in the startup options) I got the distro list back :?

After applying all updates and rebooting, I installed 'kde-full' from the kubuntu repo on top of it. After another reboot, I arrived at the kdm login. This was broken, however - the session menu and the shutdown menu didn't work, so I could only do a console login :evil:
So I started Kde from the console with 'startkde', and it started normally. I went to the systemsettings right away and there to the login settings for kdm - just to find that those were broken as well. Whenever I changed some of the settings and clicked on Apply, I got some strange error message. I then reinstalled kdm in synaptic and rebooted, but the kdm login and the kdm login settings in system settings were just as broken. I consulted the kdm documentation and tried to fix things, but nothing I tried could fix kdm.

Something I had already noted, and which was just confirmed using Kde longer, was that Kde as a whzole was running very slow and sluggish, with animations running in slow motion and all such. This was even the case with the proprietary driver installed. With my pretty meaty and modern computer configuration, Kde always flies on it, so I had never seen sluggish behaviour before. Some other things didn't work properly either, applications (KWrite, Kate etc.) weren't keeping settings and recent files. Together with the annoying login (having to do a console login first and the launching Kde manually), I finally decided to scrap it.

Out of curiosity, I yesterday decided to try installing Ubuntu and then putting Kde on top of it. So I downloaded Ubutntu 10.04 x64, installed it, applied all updates and rebooted - same as before with Mint. I then installed 'kde-full' on top of it (without the 'kubuntu' settings and stuff) and rebooted again.
Here, the kdm login worked just fine, session menu and shutdown menu were fully functional, and I could do a Kde login without any problems. The kdm login settings in systemsettings woked also fine. Trying out Kde in general, it was very quick and snappy, just as it should be. Applications were keeping their settings and recent files as they should, as well. Trying out further things, anything woked just fine without any problems.

All in all I'm quite surprised how well and effortlessly Ubuntu with Kde on top of it (without Kubuntu settings) works :shock:
Also surprising how poorly Mint with Kde on top of it performs. Actually, I had expected it to be just the other way round :?
I'll keep my Kde-ised Ubuntu for now and try out the Kde-Mint when it comes out in a month or two or sometimes next year. I don't have high hopes there anymore though :cry:
Post Reply

Return to “KDE”