Can't disable nouveau

Forum rules
Before you post please read how to get help
Raffles10
Level 1
Level 1
Posts: 19
Joined: Sun Aug 24, 2008 11:16 am

Re: Can't disable nouveau

Post by Raffles10 » Sat Aug 14, 2010 9:47 am

rec9140 wrote:
condowax wrote:I don't know if it is specific to mint, but the people who were having similar issues on other *buntus fixed it by just adding nouveau in the blacklisted modules. This solution didn't work in mint, the blacklist has to be done in grub.
I've seen a LOT of resolutions to this in varying ways, and it is NOT specific to KMint, its is a *buntu issue in general... There is a larger bug at work here.
No there isn't. This issue is specific to Mint KDE. You are delusional. Spreading inaccurate information helps no one. You seem incapable of understanding the problems surrounding Mint KDE's implementation of nouveau and their lack of support for the current default nvidia driver as provided in the repo'. This is specific to Mint and does not affect kubuntu 10.04.

I am of the opinion now that you are just trolling. People who continually post incorrect information for the sake of it or who write about things they don't understand are trolls.

User avatar
Boo
Level 7
Level 7
Posts: 1634
Joined: Mon Mar 26, 2007 7:48 am

Re: Can't disable nouveau

Post by Boo » Sat Aug 14, 2010 10:59 am

so has any one tried to blacklist the module like this.
in /etc/modprobe.d/blacklist
add the line
blacklist nouveau
or
install nouveau /bin/true

the second one looks like it is installing the module but it is quite the opposite.
root can not even modprobe the module with the second version.

cheers
Jamie
Image
Now where was i going? Oh yes, crazy!

Nicekiwi9
Level 1
Level 1
Posts: 10
Joined: Mon Jan 11, 2010 8:55 pm

Re: Can't disable nouveau

Post by Nicekiwi9 » Sat Aug 14, 2010 7:32 pm

Indeed, I gave up on KDE Mint and tried Kubuntu which as I knew had its own set of problems but the video works fine. Any OS that is being marketed the way C is marketing Ubuntu and Kubuntu should not be this annoying for its users. Linux Mint claims to be better... 0_o yes, but no..

condowax
Level 1
Level 1
Posts: 36
Joined: Tue Jun 10, 2008 9:50 pm

Re: Can't disable nouveau

Post by condowax » Mon Aug 16, 2010 11:07 pm

@Boo

I tried adding the line: blacklist nouveau, but it didn't seem to make a difference. I even blacklisted it using the Nvidia driver installer which automatically creates an entry to blacklist it but once again it seems like the nouveau driver just ignores this blacklist. However I didn't try the other line you suggest.

Splatter665
Level 1
Level 1
Posts: 1
Joined: Thu Jun 17, 2010 5:09 pm

Re: Can't disable nouveau

Post by Splatter665 » Sun Aug 22, 2010 7:44 am

Maybe this helps someone ... but i apologize for my bad english

I finally got rid of the Nouveau Driver and installed the newest driver from the NVidia Homepage.

After installing KMint i noticed that there are two Kernels. 2.6.32-21 and 2.6.32-23.

I followed the steps on https://wiki.kubuntu.org/X/Troubleshooting/Nouveau in the section "Disabling nouveau" and noticed, that the update-initramfs script automatically updates the 2.6.32-21 initrd image. But this is not the correct image, cause i'm booting the 2.6.32-23 Kernel.

So i used the following commands:

Code: Select all

echo options nouveau modeset=0 | sudo tee -a /etc/modprobe.d/nouveau-kms.conf
update-initramfs -u -k `uname-r`
The script finally updated the correct image.

After this i rebooted and selected in Grub the Linux Mint 2.6.3.32-23 recovery mode, entered a root terminal, switched to runlevel 3 and installed the NVidia driver that i downloaded before.

Well, it's not the most elegant way, but it's something :D

condowax
Level 1
Level 1
Posts: 36
Joined: Tue Jun 10, 2008 9:50 pm

Re: Can't disable nouveau

Post by condowax » Sat Sep 04, 2010 1:35 am

Maybe this helps someone ... but i apologize for my bad english

I finally got rid of the Nouveau Driver and installed the newest driver from the NVidia Homepage.

After installing KMint i noticed that there are two Kernels. 2.6.32-21 and 2.6.32-23.

I followed the steps on https://wiki.kubuntu.org/X/Troubleshooting/Nouveau in the section "Disabling nouveau" and noticed, that the update-initramfs script automatically updates the 2.6.32-21 initrd image. But this is not the correct image, cause i'm booting the 2.6.32-23 Kernel.

So i used the following commands:

Code: Select all

echo options nouveau modeset=0 | sudo tee -a /etc/modprobe.d/nouveau-kms.conf
    update-initramfs -u -k `uname-r`
Seems like the whole problem is originated from the two kernels being installed by default. Maybe Boo or clem should take a look at this and correct it if they can or at least avoid this for the next release.

The script finally updated the correct image.

After this i rebooted and selected in Grub the Linux Mint 2.6.3.32-23 recovery mode, entered a root terminal, switched to runlevel 3 and installed the NVidia driver that i downloaded before.

Well, it's not the most elegant way, but it's something :D

ferro
Level 1
Level 1
Posts: 23
Joined: Sat Sep 04, 2010 12:14 am

Re: Can't disable nouveau

Post by ferro » Sun Sep 05, 2010 10:13 pm

The easiest way is to add nouveau.blacklist=1 to

GRUB_CMDLINE_LINUX_DEFAULT=

and then running sudo update-grub

By adding it there it will not be removed if grub happens to be updated later on down the road.

jemajoign
Level 1
Level 1
Posts: 2
Joined: Thu Mar 10, 2011 11:45 pm

Re: Can't disable nouveau

Post by jemajoign » Thu Mar 10, 2011 11:49 pm

@Splatter665

What you proposed worked great! Thanks a million. If anyone else is having a problem with Linux Mint KDE 10 and nvidia drivers, try those steps.

In case it helps, my card is a nvidia geforce gt 220.

User avatar
vaxxipooh
Level 2
Level 2
Posts: 57
Joined: Wed Mar 02, 2011 10:23 pm
Location: Stensele, Sweden
Contact:

Re: Can't disable nouveau

Post by vaxxipooh » Fri Mar 11, 2011 9:33 pm

condowax wrote:I've been trying to prevent the nouveau module from loading at boot in order to install the Nvidia driver manually, but no matter what I try, the module is always loaded. I've tried blacklisting it, removing it from synaptic, even deleting the module and still every time I boot it says the module is in use. Is there a way to disable this module form loading?
Hi

You need too boot without X running - do this:

first add this to: /etc/modprobe.d/blacklist.conf

blacklist vga16fb
blacklist nouveau
blacklist rivafb
blacklist nvidiafb
blacklist rivatv

and after that run this:

sudo apt-get --purge remove nvidia-*

and after that:

sudo kate /etc/default/grub

find the line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
and replace it whith: GRUB_CMDLINE_LINUX_DEFAULT="text"

run 'sudo update-grub'

reboot your machine - now you should came into plain text terminal with no X server running

navigate to where you have the NVIDIA-Linux-x86-xxx.xx.run and run it with ' sh NVIDIA-Linux-x86-xxx.xx.run'

now the Nvidia drivers should install ...

try it out with 'startx*

if all work fine you can can change back to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" in /etc/default/grub and run 'sudo update-grub'

Hope this helps
~.: Vaxxipooh :.~
Gunnarn, Sweden
http://kahli.dmz.se

I'd rather have a free bottle in front of me than a prefrontal lobotomy ...

jemajoign
Level 1
Level 1
Posts: 2
Joined: Thu Mar 10, 2011 11:45 pm

Re: Can't disable nouveau

Post by jemajoign » Sat Mar 12, 2011 1:38 pm

When I restarted my computer, it was all messed up. So I followed vaxxipooh's steps and got it working again. I restarted and everything still seems good.

Thanks guys..

User avatar
vaxxipooh
Level 2
Level 2
Posts: 57
Joined: Wed Mar 02, 2011 10:23 pm
Location: Stensele, Sweden
Contact:

Re: Can't disable nouveau

Post by vaxxipooh » Sat Mar 12, 2011 5:09 pm

jemajoign wrote:When I restarted my computer, it was all messed up. So I followed vaxxipooh's steps and got it working again. I restarted and everything still seems good.

Thanks guys..
Aww --

Glad it worked . . it still work's and you can run "nvidia-settings" and so on ? Desktop effects working and all that ?
~.: Vaxxipooh :.~
Gunnarn, Sweden
http://kahli.dmz.se

I'd rather have a free bottle in front of me than a prefrontal lobotomy ...

khaos11
Level 1
Level 1
Posts: 2
Joined: Fri Apr 01, 2011 11:38 pm

Re: Can't disable nouveau

Post by khaos11 » Sat Apr 02, 2011 12:01 am

I followed all the steps by - vaxxipooh - but still get an error:

::::LOG::::

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Fri Apr 1 23:56:35 2011
installer version: 260.19.44

PATH:
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
precompiled interfaces : true
no ncurses color : false
query latest version : false
no questions : false
silent : false
no recursion : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
no kernel module : false
force SELinux : default
no X server check : false
no cc version check : false
run distro scripts : true
no nouveau check : false
run nvidia-xconfig : false
sigwinch work around : true
force tls : (not specified)
force compat32 tls : (not specified)
X install prefix : (not specified)
X library install path : (not specified)
X module install path : (not specified)
OpenGL install prefix : (not specified)
OpenGL install libdir : (not specified)
compat32 install chroot : (not specified)
compat32 install prefix : (not specified)
compat32 install libdir : (not specified)
utility install prefix : (not specified)
utility install libdir : (not specified)
installer prefix : (not specified)
doc install prefix : (not specified)
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
precompiled kernel interfaces path : (not specified)
precompiled kernel interfaces url : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)
selinux chcon type : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> Installing NVIDIA driver version 260.19.44.
ERROR: The Nouveau kernel driver is currently in use by your system. This
driver is incompatible with the NVIDIA driver, and must be disabled
before proceeding. Please consult the NVIDIA driver README and your
Linux distribution's documentation for details on how to correctly
disable the Nouveau kernel driver.
-> For some distributions, Nouveau can be disabled by adding a file in the modp
robe configuration directory. Would you like nvidia-installer to attempt to
create this modprobe file for you? (Answer: No)
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at http://www.nvidia.com.

::::::::::::

I added the nouveau to blacklist and did the apt-get purge, when I check the synaptic it shows that it isn't installed, so I'm not sure where I'm failing.
Any help appreciated, thanks.

User avatar
vaxxipooh
Level 2
Level 2
Posts: 57
Joined: Wed Mar 02, 2011 10:23 pm
Location: Stensele, Sweden
Contact:

Re: Can't disable nouveau

Post by vaxxipooh » Sat Apr 02, 2011 9:03 am

khaos11 wrote:I followed all the steps by - vaxxipooh - but still get an error:

::::LOG::::

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Fri Apr 1 23:56:35 2011
installer version: 260.19.44

PATH:
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
precompiled interfaces : true
no ncurses color : false
query latest version : false
no questions : false
silent : false
no recursion : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
no kernel module : false
force SELinux : default
no X server check : false
no cc version check : false
run distro scripts : true
no nouveau check : false
run nvidia-xconfig : false
sigwinch work around : true
force tls : (not specified)
force compat32 tls : (not specified)
X install prefix : (not specified)
X library install path : (not specified)
X module install path : (not specified)
OpenGL install prefix : (not specified)
OpenGL install libdir : (not specified)
compat32 install chroot : (not specified)
compat32 install prefix : (not specified)
compat32 install libdir : (not specified)
utility install prefix : (not specified)
utility install libdir : (not specified)
installer prefix : (not specified)
doc install prefix : (not specified)
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
precompiled kernel interfaces path : (not specified)
precompiled kernel interfaces url : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)
selinux chcon type : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> Installing NVIDIA driver version 260.19.44.
ERROR: The Nouveau kernel driver is currently in use by your system. This
driver is incompatible with the NVIDIA driver, and must be disabled
before proceeding. Please consult the NVIDIA driver README and your
Linux distribution's documentation for details on how to correctly
disable the Nouveau kernel driver.
-> For some distributions, Nouveau can be disabled by adding a file in the modp
robe configuration directory. Would you like nvidia-installer to attempt to
create this modprobe file for you? (Answer: No)
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at http://www.nvidia.com.

::::::::::::

I added the nouveau to blacklist and did the apt-get purge, when I check the synaptic it shows that it isn't installed, so I'm not sure where I'm failing.
Any help appreciated, thanks.
Have you put your machine to start WITHOUT X server running ?

Replace the in /etc/default/grub (sudo /kate /etc/default/grub)

the line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

with this:

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="text"
and if there are someting like this (the " vga" statement can vary): GRUB_CMDLINE_LINUX=" vga=795"

replace it with:

Code: Select all

GRUB_CMDLINE_LINUX=""
#1
and after that run: sudo update-grub

#2
and for to be sure run: sudo update-initramfs -u

#3
and after that run: sudo apt-get --purge remove xserver-xorg-video-nouveau

I really dont know if the last step (#3) is nessceary .. well i think it will do no harm ;-)

Reboot

Now you should boot into plain text terminal with no X server running

Now you should be able to install the Nvidia drivers
~.: Vaxxipooh :.~
Gunnarn, Sweden
http://kahli.dmz.se

I'd rather have a free bottle in front of me than a prefrontal lobotomy ...

AlbertP
Level 16
Level 16
Posts: 6719
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: Can't disable nouveau

Post by AlbertP » Sat Apr 02, 2011 1:11 pm

Answer 'Yes' at the modprobe file question, and you are done (on Mint, does not work on Fedora). And make sure gcc (from software/package manager) is installed.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

User avatar
vaxxipooh
Level 2
Level 2
Posts: 57
Joined: Wed Mar 02, 2011 10:23 pm
Location: Stensele, Sweden
Contact:

Re: Can't disable nouveau

Post by vaxxipooh » Sat Apr 02, 2011 5:47 pm

AlbertP wrote:Answer 'Yes' at the modprobe file question, and you are done (on Mint, does not work on Fedora). And make sure gcc (from software/package manager) is installed.
Yes and if that dont work you can do this drastic method:

Code: Select all

sudo mv /lib/modules/$(uname -r)/kernel/drivers/gpu/drm/nouveau/nouveau.ko /lib/modules/$(uname -r)/kernel/drivers/gpu/drm/nouveau/nouveau.ko.txt
and reboot
~.: Vaxxipooh :.~
Gunnarn, Sweden
http://kahli.dmz.se

I'd rather have a free bottle in front of me than a prefrontal lobotomy ...

khaos11
Level 1
Level 1
Posts: 2
Joined: Fri Apr 01, 2011 11:38 pm

Re: Can't disable nouveau

Post by khaos11 » Sat Apr 02, 2011 8:06 pm

My grub was already as you suggested - I had tried it both with and without the modprobe file, so I'll let it add it again - gcc was not installed so I will install it reboot and let you know, Thanks.

DrTeeth
Level 2
Level 2
Posts: 97
Joined: Sat Feb 13, 2010 7:47 pm

Re: Can't disable nouveau

Post by DrTeeth » Sun Jun 05, 2011 6:18 pm

I found the following about doing the same in SuSE and it may help here.

Load up the bootloader config applet and add the "nomodeset" parameter without the quotes...job done.

DrT

Fizzer
Level 1
Level 1
Posts: 3
Joined: Sat Jul 02, 2011 2:48 pm

Re: Can't disable nouveau

Post by Fizzer » Mon Jul 11, 2011 3:43 pm

Well.. Been fudging around with trying to get the Nvidia drivers installed...
vaxxipooh wrote: Replace the in /etc/default/grub (sudo /kate /etc/default/grub)

the line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

with this:

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="text"
and if there are someting like this (the " vga" statement can vary): GRUB_CMDLINE_LINUX=" vga=795"

replace it with:

Code: Select all

GRUB_CMDLINE_LINUX=""
#1
and after that run: sudo update-grub

#2
and for to be sure run: sudo update-initramfs -u

#3
and after that run: sudo apt-get --purge remove xserver-xorg-video-nouveau


I really dont know if the last step (#3) is nessceary .. well i think it will do no harm ;-)

Reboot
Did the usual Blacklist, kill gdm in console, trying the text only starting with Grub.

All failed until I did point #3

Look like you have to uninstall xserver-xorg-video-nouveau..

Which should be a mute point if it is blacklisted, obviously it isn't getting Blacklisted.

Many Many Thanks! vaxxipooh

P.S. I could tell it was finally killed because the text on screen went BIG and Ugly!! :mrgreen:

Greydog56
Level 1
Level 1
Posts: 11
Joined: Thu Apr 07, 2011 8:39 pm

Re: Can't disable nouveau

Post by Greydog56 » Sun Apr 15, 2012 6:33 pm

Many thanks to vaxxipooh for a well explained easy to follow post on how to disable nouveau. I confirm this method worked perfectly on my Mint 201204 XFCE 64 bit os.
A note on XFCE install:
Mint 201204 XFCE would not boot from live CD with my EVGA NVIDIA GTX550Ti video card. I had to remove the GTX550Ti and install older NVIDIA 9500 in order to complete the os install. Once nouveau disabled I installed NVIDIA proprietary driver, I put the GTX550Ti video card back in computer and system runs fine.

Greydog56
Level 1
Level 1
Posts: 11
Joined: Thu Apr 07, 2011 8:39 pm

Re: Can't disable nouveau

Post by Greydog56 » Mon Apr 16, 2012 9:21 pm

Regarding the live cd boot;

Before I was removing 550Ti and installing older 9500 for os install. Below is summary of what I found on another Mint post.

Workaround for me was this: booting live cd Mint 12 KDE, Gnome or XFCE-201204, when you see splash screen “automatic boot in 10 seconds”, depress escape key. I landed on a menu with several choices, I stuck with first “start linux mint” . Depress tab key to change options.

End of last line read … quiet splash --
I changed to read …........ quiet splash nomodset acpi=off --
Depress enter to continue, I landed on live cd desktop where I could test or install.

Post Reply

Return to “KDE”