Google Chrome/Chromium crashes on startup

Forum rules
Before you post please read how to get help
Mercador
Level 1
Level 1
Posts: 1
Joined: Mon May 02, 2011 8:33 pm

Google Chrome/Chromium crashes on startup

Post by Mercador »

Aloha everyone,

Hey, I am new to the forum but a long time Linux user. I am currently using Linux Mint 10 KDE 4.6.2. I did my system updates this morning and it upgraded my Google Chromium to version 11 from version 10. Now every time I start Chromium it crashes! I uninstalled it and installed the stable Google Chrome 11 from the web and once again it crashes on startup. Just as a reference Chrome 11 works fine on my Linux Mint 10 Gnome partition. Go figure.

Has anybody else experienced this?

User avatar
willie42
Level 7
Level 7
Posts: 1971
Joined: Tue Jun 22, 2010 7:52 pm
Location: Oak Ridge, TN USA

Re: Google Chrome/Chromium crashes on startup

Post by willie42 »

hi Welcome to the Linux Mint Forums.

open a terminal and launch it and see if you come up with any errors
Comptia A+ Certified Technician
Comptia Network + Certified Technician
You can not have Success without Failures.

lmintnewb

Re: Google Chrome/Chromium crashes on startup

Post by lmintnewb »

That's the fates way of telling ya you should be using a better class of browser ... firefox so forth. Or there's firefox. Also you could install and tweak I dunno ... firefox. :D

Messing round, though seriously my FF 4.01 is doing as good or better than anything else I've used. Endless customization at your fingertips. Google's 11.xxx chromium and chrome are trash from what I've seen of them. Just took them both off my Mint 10 and went back to FF. Never crashes on me. Never refuses to load what I tell it to.

A few choice tweaks and its as fast or faster than the others. Esp for you folks with mucho RAM. Could set it up to cache to RAM instead of disk. I don't have the extra RAM for that. But only takes a couple tweaks/mins for those of you who do. As noted my FF is doing just fine compared to anything else I've tried.

User avatar
willie42
Level 7
Level 7
Posts: 1971
Joined: Tue Jun 22, 2010 7:52 pm
Location: Oak Ridge, TN USA

Re: Google Chrome/Chromium crashes on startup

Post by willie42 »

IE is the only low quality of browser. Chrome is ok. :D
Comptia A+ Certified Technician
Comptia Network + Certified Technician
You can not have Success without Failures.

lmintnewb

Re: Google Chrome/Chromium crashes on startup

Post by lmintnewb »

There is no arguing with a bulldog in sunglasses. I would be wrong. ;)

Thought to amend summin about my FF tweak rant. Please tweak responsibly, lol. Much of the stuff ya find on the web isn't exactly the best of how to's. Might want to take some screen shots of your about:config so ya can change it back if ya junk up your FF folks. Caching to RAM for any dial up users ... errr probably not. Though might not hurt to try :D

And last but not least ... Been so long since I had a reason to think about it. But doesn't FF let ya use multiple user profiles ? So thinking a person could set up one to cache to RAM and nother to use normal and just switch between as the spirit moves ya eh. Dunno if FF profiles preserves disk cache too. Ya could also just fiddle the about:configs to get the same end.

Felt compelled to add this cause didn't want to encourage folks do summin that might junk up their FF's.

OT: Ya might be missing a package too OP. Thought I saw a package for integrating chrome/ium etc into kde. Or have older incompatible packages hanging around. When I updated and installed some other packages for chromium I noticed I'd left the 10.xxx package for element inspector. Don't know if that contributed to chromium slowing up or not.

Check synaptic>custom filters>missing recommends and/or upstream available thingy. Might not hurt to also type chrome or chromium in the search bar of synaptic and see which packages come up as installed. Might have to mark some of them for removal or Mark for complete removal.

Plus seems like google just really dropped the ball with that 11.xxx version. Chromium 10.xxx should definitely not be better than chromium 11.xxx. I'm done with having 2-3 ... 14 diff web browsers. Can't see how it makes life easier. :D

Just me ... but sticking with good ole FF.

asharma74
Level 1
Level 1
Posts: 1
Joined: Sat Apr 16, 2011 11:59 am

Re: Google Chrome/Chromium crashes on startup

Post by asharma74 »

Yeah, I have that problem too. It either takes a eternity trying to open a page (ultimately the page is not loaded) or the "killpage" dialogue box shows up. This has been happening since i upgraded my system (Linux mint KDE 10). Any solution??? I generally like to use apt-get and command line (you can call me a newbie to linux but I find command line fascinating) so please post solution for commandline newbie users too. Thanks.

karimbardee
Level 1
Level 1
Posts: 5
Joined: Tue Dec 08, 2009 7:59 pm

Re: Google Chrome/Chromium crashes on startup

Post by karimbardee »

And it's acting on my desktop just the same as it does with user ashama !!

kriak24
Level 1
Level 1
Posts: 3
Joined: Sat Jan 30, 2010 4:03 pm

Re: Google Chrome/Chromium crashes on startup

Post by kriak24 »

Problem with Chromium after upgrade to version 11 on LinuxMint KDE also here.
Chromium freezes (not always) after startup. No page can be laoded, always getting "kill page" dialogue.
Chromium can by closed by close button, but 3 processes remind alive:
kriak 4782 3004 1 14:39 ? 00:01:07 /usr/lib/chromium-browser/chromium-browser
kriak 4784 4782 0 14:39 ? 00:00:00 /usr/lib/chromium-browser/chromium-browser
kriak 4786 1 0 14:39 ? 00:00:00 /usr/lib/chromium-browser/chromium-browser --type=zygote

AlbertP
Level 16
Level 16
Posts: 6714
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: Google Chrome/Chromium crashes on startup

Post by AlbertP »

My Google Chrome on Linux does the same. Emptying the cache helped once, but only for a minute. I wanted to switch to Chromium because of this, but I have read here that Chromium does the same. The same version 11.0.696.65 works well in my Windows (Vista), but not on my father's Vista Business. The update of yesterday (or the day before yesterday?) did not solve the problem.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

irishfury
Level 1
Level 1
Posts: 11
Joined: Wed May 27, 2009 6:08 pm
Location: Blacksburg, VA, USA

Re: Google Chrome/Chromium crashes on startup

Post by irishfury »

Same problems. Chrome and Chromium are very unstable. Also, neither load a page when launched from another app e.g. debugging from Eclipse.

kanishka
Level 5
Level 5
Posts: 720
Joined: Sat Feb 10, 2007 5:59 am

Re: Google Chrome/Chromium crashes on startup

Post by kanishka »

Same here; I'm no longer able to use Chrome stable/unstable/beta nor Chromium. Tried them all; they stall at startup forever. :evil:
Mint KDE 10 amd64 here.

AlbertP
Level 16
Level 16
Posts: 6714
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: Google Chrome/Chromium crashes on startup

Post by AlbertP »

I don't have any problems loading a page from another app. It is a temporary issue in Chrome I think, there have been many of these issues recently. On Linux I've switched to Firefox 4, but on Windows, Chrome still works so I'm keeping it. (My provider has just introduced a webmail which does not need IE or FF but also runs fine in Chrome)
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

Old Ruler
Level 5
Level 5
Posts: 549
Joined: Sat Jul 18, 2009 12:43 pm
Location: Shropshire, UK.

Re: Google Chrome/Chromium crashes on startup

Post by Old Ruler »

Same problems with chromium here. I used to use the daily builds and found the same problem there, but I reverted to the distributed version somewhere near the end of the 11 series. V10 was OK and I still have the deb files for that in /var/cache/apt/archives/ namely:

chromium-browser_10.0.648.205~r81283-0ubuntu0.10.10.1_amd64.deb
chromium-browser-inspector_10.0.648.205~r81283-0ubuntu0.10.10.1_all.deb
chromium-browser-l10n_10.0.648.205~r81283-0ubuntu0.10.10.1_all.deb
chromium-codecs-ffmpeg_10.0.648.205~r81283-0ubuntu0.10.10.1_amd64.deb

What would be the best (retaining bookmarks and passwords) way to downgrade?

kanishka
Level 5
Level 5
Posts: 720
Joined: Sat Feb 10, 2007 5:59 am

Re: Google Chrome/Chromium crashes on startup

Post by kanishka »

AlbertP wrote:I don't have any problems loading a page from another app. It is a temporary issue in Chrome I think, there have been many of these issues recently. On Linux I've switched to Firefox 4, but on Windows, Chrome still works so I'm keeping it. (My provider has just introduced a webmail which does not need IE or FF but also runs fine in Chrome)
Yeah, in windows it works fine. I know it's temporary but I am at least at the third week without Chrome :(

sjonesy
Level 3
Level 3
Posts: 104
Joined: Mon Nov 29, 2010 4:29 pm

Re: Google Chrome/Chromium crashes on startup

Post by sjonesy »

well this is a useless search, try to get info on chromium crashes and people just tout firefox, ya know if I wanted firefox I'd have firefox. same issues here, mostly complains about flash being out of date or doesnt load at all.
Image

User avatar
buffalobillion
Level 1
Level 1
Posts: 14
Joined: Wed Apr 27, 2011 3:05 pm
Location: Utah, U.S.

Re: Google Chrome/Chromium crashes on startup

Post by buffalobillion »

Same problem here. I'd love to find a solution to this issue. No, changing to FF is not an option--I have to develop to a webkit browser for a work project; the gecko engine is not supported. So please refrain from telling me which browser's better. You may be right, but I still need Chrome to work. :wink:

Old Ruler
Level 5
Level 5
Posts: 549
Joined: Sat Jul 18, 2009 12:43 pm
Location: Shropshire, UK.

Re: Google Chrome/Chromium crashes on startup

Post by Old Ruler »

Too soon to suggest it's a definite workaround (I've only just tried it), but removing the gecko-mediaplayer package seems to have fixed it here. It was taking up to five tries to get it to start and show the page I've set as my home page (after a re-boot particularly), but now it starts properly, immediately. I'd be interested to hear if it works for anyone else.

Removing it is likely to cause problems for FireFox, I guess, but as I only use that one rarely, I'm not too bothered.

User avatar
buffalobillion
Level 1
Level 1
Posts: 14
Joined: Wed Apr 27, 2011 3:05 pm
Location: Utah, U.S.

Re: Google Chrome/Chromium crashes on startup

Post by buffalobillion »

@Old Ruler, keep me posted if this is indeed a solution for you--I'd be interested to hear!

cloggers
Level 1
Level 1
Posts: 8
Joined: Mon May 23, 2011 10:32 am

Re: Google Chrome/Chromium crashes on startup

Post by cloggers »

Well lets try. Remove gecko mediaplayer.
Done !
Start Chrome 13.0.767.1 dev .............
Works like a charm !
so, thank you veeeery much.

Old Ruler
Level 5
Level 5
Posts: 549
Joined: Sat Jul 18, 2009 12:43 pm
Location: Shropshire, UK.

Re: Google Chrome/Chromium crashes on startup

Post by Old Ruler »

buffalobillion wrote:@Old Ruler, keep me posted if this is indeed a solution for you--I'd be interested to hear!
Yes, it seems to be a complete cure. I've tended to re-boot more often than usual and I've started chromium 11 dozens of times without a single failure. Hoping you find the same.

@ cloggers: Glad it worked for you and welcome to the forum. :)

Post Reply

Return to “KDE”