Broadcom.......... again!

Forum rules
Before you post please read how to get help
Post Reply
User avatar
lwfitz
Level 1
Level 1
Posts: 17
Joined: Wed Nov 09, 2011 5:42 pm
Location: Monrovia, CA

Broadcom.......... again!

Post by lwfitz »

Im running Mint 12 KDE and every time I reboot I lose my wireless. Everything looks ok and my card is detected it just doesnt seem to see any networks. My wireless card is the bcm 4313 802.1 1. Ive tried uninstalling and reinstalling drivers, using the windows drivers and even downgrading drivers but nothing seems to work. I can usually find a fix but this one has been quite a pain. Anyone have any ideas?
The quieter you are the more you can hear............

Linux Mint 11 Katya KDE Vanilla x64

Dell N7010, 500gb Seagate hybrid drive, i5 @ 2.53ghz, 8gb ddr3, ATi Radeon HD 5470 1GB

User avatar
lwfitz
Level 1
Level 1
Posts: 17
Joined: Wed Nov 09, 2011 5:42 pm
Location: Monrovia, CA

Re: Broadcom.......... again!

Post by lwfitz »

So apparently Im the only one to have had this issue? Im losing my mind :shock: :lol: :roll: :oops: :mrgreen: Im willing to try anything at this point!
The quieter you are the more you can hear............

Linux Mint 11 Katya KDE Vanilla x64

Dell N7010, 500gb Seagate hybrid drive, i5 @ 2.53ghz, 8gb ddr3, ATi Radeon HD 5470 1GB

User avatar
mads
Level 6
Level 6
Posts: 1296
Joined: Wed Nov 03, 2010 3:44 pm
Contact:

Re: Broadcom.......... again!

Post by mads »

Check out this thread and this tutorial.

User avatar
Garvan
Level 4
Level 4
Posts: 298
Joined: Sun May 29, 2011 3:26 am
Location: Thailand
Contact:

Re: Broadcom.......... again!

Post by Garvan »

You said "every time I reboot I lose my wireless", so does this implies you know who to manually get it working again? If you know how to connect manually, it may give some clue to what is wrong.

Garvan
Notebook: DELL Latitude E5520, i5-2520M @ 2.50 GHz, 4GB RAM, Linux Mint 17.2 (2011)
Notebook: DELL Latitude 5280, i5-73000 @ 2.7 GHz., 16 GB RAM, Linux Mint 19.2 (2019)

User avatar
lwfitz
Level 1
Level 1
Posts: 17
Joined: Wed Nov 09, 2011 5:42 pm
Location: Monrovia, CA

Re: Broadcom.......... again!

Post by lwfitz »

Thanks for the response guys. Ive got the drivers installed and everything is blacklisted and my wifi works fine until I reboot......... if I reboot the computer I have no wireless even though everything says my card is fine. Its recognized and if I try to power on the card it doesnt seem to do anything.
Now......... if I shut down the computer completely then boot it back up my wifi works fine again!
when it isnt working no I do not know how to manually connect. Sorry if I didnt explain well....... I think Ive had way to much coffee today :D :D
The quieter you are the more you can hear............

Linux Mint 11 Katya KDE Vanilla x64

Dell N7010, 500gb Seagate hybrid drive, i5 @ 2.53ghz, 8gb ddr3, ATi Radeon HD 5470 1GB

User avatar
lwfitz
Level 1
Level 1
Posts: 17
Joined: Wed Nov 09, 2011 5:42 pm
Location: Monrovia, CA

Re: Broadcom.......... again!

Post by lwfitz »

Tried

Code: Select all

sudo apt-get install firmware-b43-installer
and got

Code: Select all

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  firmware-b43-installer
0 upgraded, 1 newly installed, 0 to remove and 2 not upgraded.
Need to get 3,272 B of archives.
After this operation, 53.2 kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu/ oneiric/multiverse firmware-b43-installer all 1:014-9 [3,272 B]
Fetched 3,272 B in 0s (8,734 B/s)                 
Selecting previously deselected package firmware-b43-installer.
(Reading database ... 158323 files and directories currently installed.)
Unpacking firmware-b43-installer (from .../firmware-b43-installer_1%3a014-9_all.deb) ...
Setting up firmware-b43-installer (1:014-9) ...
Unsupported device(s) found: PCI id 14e4:4727 
Aborting
The quieter you are the more you can hear............

Linux Mint 11 Katya KDE Vanilla x64

Dell N7010, 500gb Seagate hybrid drive, i5 @ 2.53ghz, 8gb ddr3, ATi Radeon HD 5470 1GB

ramartz
Level 1
Level 1
Posts: 14
Joined: Thu Nov 03, 2011 10:36 am

Re: Broadcom.......... again!

Post by ramartz »

Looking at your signature, I think we have same hardware m8 (Dell N7010) the only difference probably is I'm running LM (x64) Edition.
Nonetheless, I have the same problem and I gave up trying to find an answer, none seems to work seamlessly so no other option that to use a cable.

Anyway, did you find any stable solution on your end? Cheers!

TBABill
Level 6
Level 6
Posts: 1355
Joined: Wed Dec 30, 2009 1:02 pm
Location: Leonardtown, MD

Re: Broadcom.......... again!

Post by TBABill »

Ok, sounds like what is failing is the driver is not loading on restart. Since I do not know which driver you are using I will assume it's the STA driver. If it's not, substitute "b43" for wl in my instructions below, without quotes of course.

Code: Select all

gksudo gedit /etc/modules
Put "wl" without quotes at the end of the list of items in that file, save and restart. That should load the module for you on every restart. If you ever find your wireless disabled and just want it active without restarting, just

Code: Select all

sudo modprobe wl
Wait a few moments and enjoy.

"wl" is the module/driver so if you are using b43, just substitute it for wl in everything above...works the same regardless which module you use.

Edit: this all assumes you have it working properly. If it's still not working, please advise which driver you are trying to activate and what method you are following.

User avatar
lwfitz
Level 1
Level 1
Posts: 17
Joined: Wed Nov 09, 2011 5:42 pm
Location: Monrovia, CA

Re: Broadcom.......... again!

Post by lwfitz »

TBABill wrote:Ok, sounds like what is failing is the driver is not loading on restart. Since I do not know which driver you are using I will assume it's the STA driver. If it's not, substitute "b43" for wl in my instructions below, without quotes of course.

Code: Select all

gksudo gedit /etc/modules
Put "wl" without quotes at the end of the list of items in that file, save and restart. That should load the module for you on every restart. If you ever find your wireless disabled and just want it active without restarting, just

Code: Select all

sudo modprobe wl
Wait a few moments and enjoy.

"wl" is the module/driver so if you are using b43, just substitute it for wl in everything above...works the same regardless which module you use.

Edit: this all assumes you have it working properly. If it's still not working, please advise which driver you are trying to activate and what method you are following.

Thank you. I got tired of the headache and just replaced the wireless card with am Intel card and have had no problems since then. I will be using that card in another laptop so I will try what you said probably next week.
The quieter you are the more you can hear............

Linux Mint 11 Katya KDE Vanilla x64

Dell N7010, 500gb Seagate hybrid drive, i5 @ 2.53ghz, 8gb ddr3, ATi Radeon HD 5470 1GB

Post Reply

Return to “KDE”