Sleep mode when closing lid. LM12KDE.

Forum rules
Before you post please read how to get help
Post Reply
niuginibenz
Level 1
Level 1
Posts: 15
Joined: Sat Aug 21, 2010 7:58 pm

Sleep mode when closing lid. LM12KDE.

Post by niuginibenz »

I am totally impressed with the KDE version of Mint 12 in all respects except one. This small problem is far from a showstopper but a little annoying. I have a Samsung RF411 laptop and have set the system to go into sleep mode when I close the lid. It seems like it works - the "sleep chime" is played BUT it does not go the whole way. I need to lift the lid again for a second and close it again. Then it does it properly.
If I forget to lift the lid again before packing it away in my bag I will end up with a flat battery and/or possibly overheated computer. Anyone else had this problem?
Rayek
Level 1
Level 1
Posts: 12
Joined: Sat Mar 03, 2012 12:04 am

Re: Sleep mode when closing lid. LM12KDE.

Post by Rayek »

Just realized something similar happening to me, too. I know It was working, and it isn't now for some reason, but there is no way I shut it off myself, I had messed with the Power Management Profiles a little bit, it had stopped suspending, reset those back to the defaults, and it's still not working properly.

Edit: I just did a small experiment, changing the power settings to "Lock Screen" when the lid closes. Applied the settings, closed the lid, and nothing, no locked screen. The screen is turning off, just no "you've closed the lid" sound or anything else.
cespinal
Level 2
Level 2
Posts: 77
Joined: Mon Dec 08, 2008 2:31 pm

Re: Sleep mode when closing lid. LM12KDE.

Post by cespinal »

Question: did you upgrade to KDE 4.8?

There is a known, annoying bug in 4.8 that is causing this problem. What is happening is that for some reason, developers gave some applications priority to decide over power devil. This means power devil sends the signal to suspend to RAM (or disk) but some applications running in the background don't allow this to happen. Developers though this would be a good idea but it seemed to have backfired...

A solution to this bug has been pushed into 4.8.1 which will be released today. The solution will be an option in power devil which will allow you to decide which sort of behaviour you want from the system when managing these events.

I loved 4.8, but the power devil thingy kept bugging me... I will try to update to 4.8.1 if they release it D:
cespinal
Level 2
Level 2
Posts: 77
Joined: Mon Dec 08, 2008 2:31 pm

Re: Sleep mode when closing lid. LM12KDE.

Post by cespinal »

Question: did you upgrade to KDE 4.8?

There is a known, annoying bug in 4.8 that is causing this problem. What is happening is that for some reason, developers gave some applications priority to decide over power devil. This means power devil sends the signal to suspend to RAM (or disk) but some applications running in the background don't allow this to happen. Developers though this would be a good idea but it seemed to have backfired...

A solution to this bug has been pushed into 4.8.1 which will be released today. The solution will be an option in power devil which will allow you to decide which sort of behaviour you want from the system when managing these events.

I loved 4.8, but the power devil thingy kept bugging me... I will try to update to 4.8.1 if they release it D:
Post Reply

Return to “KDE”