XFCE - Laptop - When Lid is Closed > Do Nothing

Forum rules
Before you post please read how to get help
Post Reply
Billy-Mac
Level 1
Level 1
Posts: 1
Joined: Wed Oct 13, 2021 4:51 pm

XFCE - Laptop - When Lid is Closed > Do Nothing

Post by Billy-Mac »

I'm currently running Cinnamon on my laptop, and would like to switch back to XFCE as it's a pretty old laptop and I don't really need all the added features, and I really like the lightweight feel of XFCE. I keep this laptop closed and under a stand with output to an external monitor at all times, and input from external mouse/keyboard. I keep it on at all times and use the mouse/keyboard to wake the screen back up.

That's the reason I'm using Cinnamon though is the feature under Power Management > When the lid is closed > Do Nothing. This setting is not available on XFCE. I've tried searching for a fix but have not found one that works yet. Has anyone been able to disable the laptop lid closure from doing anything within XFCE? Is there some sort of workaround since it's not in the Power Management or Display Settings?
vimes666
Level 5
Level 5
Posts: 604
Joined: Tue Jan 19, 2016 6:08 pm

Re: XFCE - Laptop - When Lid is Closed > Do Nothing

Post by vimes666 »

I am not familiar with xfce but this may still work.
Edit /etc/systemd/logind.conf this way:

Code: Select all

xed admin:///etc/systemd/logind.conf
Locate this line:
#HandleLidSwitch=suspend
If it has a # mark up front, remove that and change suspend into ignore.
Save the file, reboot your laptop and try it.
If you think the issue is solved, edit your original post and add the word solved to the title.
User avatar
secureIT
Level 4
Level 4
Posts: 377
Joined: Wed Dec 05, 2018 1:26 pm

Re: XFCE - Laptop - When Lid is Closed > Do Nothing

Post by secureIT »

Hi Billy-Mac ,

open up graphical settings management for xfce

then choose >Power management<

click on tab >System<

There is a dropdown menu beyond >laptop screen<

choose >standby<

Then go to the next tab >screen< and move the registers .....

>black screen after<
>energy saving mode after<
>switch off after<

..... all to the right for 60 minutes (I hope that's enough time for your needs)

close settings management

Done.

edit:

As xfce4-power-manager depends on upower that also might work (independent of time) :

Open the folder: /etc/UPower/ with admin rights

edit UPower.conf

and put in the setting :

Code: Select all

IgnoreLid=true
close the Upower.conf and confirm the change

Note: for the change to take effect don't forget to restart your system .
.
Post Reply