Page 1 of 1

Xfce Power Manager problems

Posted: Sun Sep 09, 2012 12:16 pm
by eaglesgift

I recently installed Linux Mint 13 with Xfce on an Acer Aspire One (532h) and I've been really pleased with it apart from one issue...the battery status indicator. Basically, if I select the "always show icon" option, the icon appears in the panel but says the adaptor is online, even though it isn't. If I select any other option it doesn't normally appear at all. At one point it was appearing when I selected the "when battery is charging or discharging" option but now it doesn't do that either.

I searched this site and read through quite a few threads but couldn't see a solution to my problem. I tried the following commands in the terminal:

cat /proc/acpi/battery/BAT0/info &&
cat /proc/acpi/battery/BAT0/status

and I get the following output:

present: yes
design capacity: 4400 mAh
last full capacity: 2942 mAh
battery technology: rechargeable
design voltage: 10800 mV
design capacity warning: 220 mAh
design capacity low: 132 mAh
cycle count: 0
capacity granularity 1: 264 mAh
capacity granularity 2: 3780 mAh
model number: UM09H31
serial number:
battery type: Lion
cat: /proc/acpi/battery/BAT0/status: No such file or directory

I'm a bit confused about that last line because it comes up with all the info and then says "no such file or directory", but I'm new to Linux so maybe I just don't understand what's going on.

At first, when I used those commands the battery indicator would suddenly appear in the panel and show the correct state of the battery rather than telling me the adaptor was online but now it doesn't appear any more. I've tried a number of alternative battery monitor applications and most of them don't appear anywhere when I run them. One that I tried, xbattbar, appears and tells me my battery is -1% all the time and the last time I started it, the Xfce Power Manager icon appeared in the panel as well, showing the correct info.

Sorry for the lengthy post, I wanted to make sure I supplied all the relevant info. I'd really like to solve this problem because an OS with no battery indicator on a netbook is not very useful and I'd like to carry on using Linux Mint.

Thanks in advance for any help that anybody can give me.

Re: Xfce Power Manager problems

Posted: Sun Dec 09, 2012 12:33 pm
by daozen
Its a bit late but if you try this:

Code: Select all

cat /proc/acpi/battery/BAT0/info && cat /proc/acpi/battery/BAT0/state
If that doesn't work try the above with BAT1.

I have the same problem by the way, from what I can gather its a "segmentation fault" with

Code: Select all

cat /proc/acpi/battery/BAT0/info

Code: Select all

cat /proc/acpi/battery/BAT0/status
don't work for me until I have plugged in the power supply then they work.

xfce4-power-manager doesn't auto-start and when I do the above xfce4-power-manager crashes. Once I restart it it runs ok until I reboot that is.

Re: Xfce Power Manager problems

Posted: Fri Feb 01, 2013 6:53 am
by daozen
Just an update.

I have solved this problem for myself; as far as I can tell it was nothing to do with XFCE as this problem persisted on all distros and desktops I tried on my laptop. The only exception to this was Fedora 17 which detected the battery and everything was fine apart from having to use Fedora (personal preference).

I have no idea why Fedora works when others don't, I can only assume it handles power management in a different way maybe at a deeper level (if that makes sense) as "cat /proc/acpi/battery/BAT0/state (or status)" returns a "directory does not exist" error and "/proc/acpi/battery/" doesn't exist either.

However the ultimate fix was to pop into windows and update the BIOS to the latest version, now every distro detects the battery (however the manage it). This may or may not help.

Re: Xfce Power Manager problems

Posted: Sat Apr 13, 2013 2:35 pm
by eaglesgift
Hi, thanks for your replies. Sorry I did not notice them before, I had pretty much given up! I have had a similar experience to you - other distros I have installed sometimes show the battery indicator and sometimes don't. However, I wiped windows from my netbook a while ago as I was enraged that it could never keep a wireless connection open. It's a common problem with this model apparently but all Linux distros seem to be OK with it (excepting perhaps Bodhi if my memory serves me correctly)

I hope there is some way that I can update the BIOS without having to install Windows again.