Mouse cursor not visible sometimes

Forum rules
Before you post please read how to get help
User avatar
Level 13
Level 13
Posts: 4825
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Mouse cursor not visible sometimes

Postby Flemur » Thu Jan 10, 2013 4:04 pm

Mint 13 Xfce w/fluxbox

My mouse cursor becomes invisible at certain times, e.g., scrolling a window in FF makes the cursor disappear when you stop scrolling: moving the mouse makes it show up. That's not a big deal, but it also briefly disappears in other apps at inconvenient times.

When researching this issue, I saw some "hide the cursor" software mentioned - I DON'T have any installed.

I seem to remember setting **something** so that the cursor would hide itself when it wasn't moving, or some such, but can't remember what it was, and can't find it again.

TIA for any ideas!
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?

Level 1
Level 1
Posts: 1
Joined: Thu Mar 14, 2013 10:10 pm

Re: Mouse cursor not visible sometimes

Postby haumea » Thu Mar 14, 2013 10:22 pm

I have the exact same problem: the mouse cursor disappears once it stops moving. I'm really not sure why this is happening.

Level 1
Level 1
Posts: 3
Joined: Thu Mar 14, 2013 11:15 pm

Re: Mouse cursor not visible sometimes

Postby masterman467 » Thu Mar 14, 2013 11:50 pm

i am having a mouse related issue too.
Im on cinnimon, and, as i type, the curser is randomly loosing focus with this text box, and even other non-text things. this happends for about a second, then works fine for 3-10 seconds, and flips off again. this is anoying the ever living crap out of me and makes this OS nearly unusable. restarting foxes it for a bit, but it breaks again within 5 min. its not hideing itself like yours.

TL:DR mouse curser looses focus randomly.

Level 1
Level 1
Posts: 3
Joined: Sat Apr 13, 2013 10:14 pm

Re: Mouse cursor not visible sometimes

Postby ztact » Mon Apr 22, 2013 5:40 pm

I ran into the same problem (or a very similar) problem with the mouse cursor flickering and disappearing when dragging and hovering.

I found the problem with the VESA video driver, on the following distros:

LMDE 201303 MATE (all the time)
Xubuntu 12.04.02 (but only after running the Chromium web browser!)
Xubuntu 12.10 (all the time)

The following distros appear NOT to have the problem:

Debian Wheezy (which is interesting because it is so similar to LMDE 201303)
Xubuntu 13.04 (beta 2)


One of my laptops has Intel graphics (915GM).
915GM + Xubuntu 12.04.02 = no problem.
915GM + LMDE 201303 MATE = no problem.


I am happy the problem appears to be fixed in Xubuntu 13.04, and do not expect to investigate further.

Return to “XFCE”