[SOLVED] Desktop icons - snap to grid. How to switch off?

Forum rules
Before you post please read how to get help
Post Reply
leaston.h
Level 1
Level 1
Posts: 24
Joined: Fri Jan 11, 2008 2:16 pm

[SOLVED] Desktop icons - snap to grid. How to switch off?

Post by leaston.h »

Hi,

I've been trying for the past hour to get my desktop icons to:
a) stop snapping to a grid when I move them and
b) change the setting that seems to stop them from being placed within about an inch of the edge of the screen

As my hair has already disappeared, I can't pull it out. Could someone please put me out of my misery as I've looked in every config app I can think of and just cannot see any relevant settings for this. It's been a while since I used XFCE and can't remember if it even has a gui for these settings.

Thank you kindly,
Leaston
Last edited by leaston.h on Tue Sep 09, 2008 5:29 pm, edited 1 time in total.

iironjade
Level 4
Level 4
Posts: 298
Joined: Fri Jan 18, 2008 8:51 am
Location: London UK

Re: Desktop icons - snap to grid. How to switch off?

Post by iironjade »

Right click on the desktop and untick "Keep Aligned"?
"A good many dramatic situations begin with screaming."

leaston.h
Level 1
Level 1
Posts: 24
Joined: Fri Jan 11, 2008 2:16 pm

Re: Desktop icons - snap to grid. How to switch off?

Post by leaston.h »

iironjade wrote:Right click on the desktop and untick "Keep Aligned"?
Thanks for the suggestion, but it's not there. :?

My right click desktop menu is the same as the "start" menu. If I switch off the setting "Show desktop menu on right click" to get rid of that, I get another menu which has entries for the following choices: create launcher, create URL link, create folder, create from template and desktop settings. There's nothing anywhere about keep aligned. Even my margins are all set to zero, so I can't understand why my icons insist on staying well away from any screen edge. It's driving me crackers :D

Cheers,
Leaston

iironjade
Level 4
Level 4
Posts: 298
Joined: Fri Jan 18, 2008 8:51 am
Location: London UK

Re: Desktop icons - snap to grid. How to switch off?

Post by iironjade »

leaston.h wrote:
iironjade wrote:Right click on the desktop and untick "Keep Aligned"?
Thanks for the suggestion, but it's not there. :?

My right click desktop menu is the same as the "start" menu. If I switch off the setting "Show desktop menu on right click" to get rid of that, I get another menu which has entries for the following choices: create launcher, create URL link, create folder, create from template and desktop settings. There's nothing anywhere about keep aligned. Even my margins are all set to zero, so I can't understand why my icons insist on staying well away from any screen edge. It's driving me crackers :D

Cheers,
Leaston
There must be a difference (obviously) between Gnome and xfce. I get "create folder" etc., plus "arrange by name" and "keep aligned" by right clicking.
Maybe there's something in preferences or admin that'll let you change it.
"A good many dramatic situations begin with screaming."

leaston.h
Level 1
Level 1
Posts: 24
Joined: Fri Jan 11, 2008 2:16 pm

Re: Desktop icons - snap to grid. How to switch off?

Post by leaston.h »

iironjade wrote:There must be a difference (obviously) between Gnome and xfce. I get "create folder" etc., plus "arrange by name" and "keep aligned" by right clicking. Maybe there's something in preferences or admin that'll let you change it.
Ahh, that explains it. Yes, there's a world of difference between them.

I must admit to having been through every menu in each admin app I can find (several times), without success. It could be that I've just missed the setting, but I'd love someone to tell me the answer.

LinuxForever
Level 3
Level 3
Posts: 138
Joined: Tue May 13, 2008 2:05 pm

Re: Desktop icons - snap to grid. How to switch off?

Post by LinuxForever »

I've never seen that option in XFCE. merlwiz79 probably knows the answer. Have you checked with the forum at XFCE http://www.xfce.org/

Link to XFCE forum http://forum.xfce.org/

leaston.h
Level 1
Level 1
Posts: 24
Joined: Fri Jan 11, 2008 2:16 pm

[SOLVED] Desktop icons - snap to grid. How to switch off?

Post by leaston.h »

Thanks LinuxForver. I didn't even know XFCE had a forum.

Ok, I'm definitely learning a few things here and I'm not the first (by a long way) who's asked about this issue. The desktop management system for XFCE was only updated in recent versions to enable icons on the desktop at all. I remember wishing for them in older versions, and now they're here. But, I'm still not satisfied with that hehe! :twisted:

The icons and desktop features of XFCE are managed by Thunar file manager libraries, which have limited functionality, presumably to keep in line with the lightweight nature and speed of XFCE as a desktop environment. Fair enough. You can go into the desktop settings of XFCE and untick the box "Allow XFCE to manage the desktop". This will cause all icons to disappear and the desktop to become black (because you've gone back in time effectively by disabling any desktop management). If you want to replace Thunar with something else, to enable things like no more snapping to grid of desktop icons, you need to replace the desktop manager with a new one. The one that seems to be popular is called PCMan File Manager (search the Mint repos for pcmanfm). It does allow icons on the desktop and they can be placed anywhere. You can switch between these by simply ticking the box again in desktop settings.

Anyway, that's my questions answered. Cheers for everyone who posted. :D

Cheers,
Leaston

User avatar
edwardr
Level 4
Level 4
Posts: 248
Joined: Thu Jun 03, 2010 1:09 pm
Location: USA - Texas

Re: [SOLVED] Desktop icons - snap to grid. How to switch off

Post by edwardr »

It's leaving a space because there's not enough room between the task bar and the lowest desktop icon to fit another row of the desktop grid. A workaround is to change the size of the desktop icons, which changes the height of the rows of the desktop grid. Incrementally change the size of the icons one or two points at a time and try to place an icon at the bottom of the screen until you get a size that allows the desktop grid to better fit the screen. Right click on the desktop and and hunt through the settings to find where to change the desktop icon size (I'm not at my Xfce computer so can't tell you exactly what to click on)
The optimist proclaims that we live in the best of all possible worlds; and the pessimist fears this is true

Post Reply

Return to “Xfce”