Compton compositor and (minor) issue with Whisker

Forum rules
Before you post please read how to get help
Post Reply
Neurons_at_Work
Level 1
Level 1
Posts: 13
Joined: Fri Aug 20, 2010 11:01 pm

Compton compositor and (minor) issue with Whisker

Post by Neurons_at_Work » Sun Dec 27, 2015 2:59 am

Hi all,
I'm running XFCE 17.2 on a Thinkpad T410 (i915 Intel graphics) and was experiencing a lot of video tearing, so went with the compton compositor as that is an oft-quoted solution. It worked very well using the generic compton.conf file contents as provided on many sites. The tearing issue seems corrected (had tried xorgedgers first, nada, reverted) and the side benefits are windows and menus that fade in/out smoothly and a great drop shadow effect. I'm having just one issue with Whisker menu, and I thought that perhaps someone out there might have figured out a solution. All windows fade in, along with their drop shadow, and both fade out together when the window or menu is closed. With Whisker, however, the menu fades in with shadow, but when closed the menu closes instantaneously, leaving just the shadow effect to fade out at the normal speed. I'm just looking for some reason why every other window/menu/tooltip fades in/out, but Whisker alone briefly leaves its shadow behind. I'm guessing that a tweak in compton.conf would help. I'm not sure whether this is a factor, but I have also added code to gtkrc-2.0 to dark theme Whisker. And yes, I can wait for Rosa and see if that fixes it, but I just thought I'd put this out there on the off chance this has been seen before. Thanks!

isacdan
Level 1
Level 1
Posts: 16
Joined: Sun May 17, 2009 12:37 pm

Re: Compton compositor and (minor) issue with Whisker

Post by isacdan » Sun Mar 18, 2018 5:41 am

Setting the background opacity at 100 in the Whisker Menu settings solved the problem for me.

Post Reply

Return to “Xfce”