Enable Mint 17.3 XFCE system sounds

Forum rules
Before you post please read how to get help
Post Reply
tarala
Level 1
Level 1
Posts: 28
Joined: Sun May 25, 2014 7:35 pm

Enable Mint 17.3 XFCE system sounds

Post by tarala » Fri Jan 15, 2016 10:02 pm

Hi all,

I've been trying to get sound effects enabled after a clean install of Mint 17.3 XFCE.

I found and tried this: http://ubuntuforums.org/showthread.php? ... st12702910 although I am aware it relates to an older version of ubuntu. In settings editor xsettings/net, I do not have the SoundThemeName option present.

I don't need a whole suite of system sounds, I just really miss the volume setting "pop". Did anyone have luck?

User avatar
mingle
Level 3
Level 3
Posts: 128
Joined: Thu May 24, 2012 9:58 pm

Re: Enable Mint 17.3 XFCE system sounds

Post by mingle » Sat Jan 16, 2016 9:08 pm

You're in the same boat as a lot of people - getting basic system sounds to work in LM is a mystery to most (including me).

Why it can't be a simple matter of ticking the "Enable system sounds" option, I don't know.

There are very few tutorials on how to get it to work and none of the ones that I've tried
have solved the issue.

Sorry I can't be of help, but I feel your pain...

Mike.

Resistor
Level 3
Level 3
Posts: 163
Joined: Wed Nov 03, 2010 12:04 am
Location: Western Ozarks

Re: Enable Mint 17.3 XFCE system sounds

Post by Resistor » Sat Jan 16, 2016 9:53 pm

Using 17.3 Cinnamon, I removed the 3.19.x.x kernel, in favor of the 3.16.0.38 kernel. The 3.16.0.37 kernel also allows the sound to work on this Dell.

I have not tried any of the higher kernels.

In Update Manager, look under View > Linux Kernels.
LM 17.3 Qiana v2, Cinnamon. Windows 8 is gone.
Dell Inspiron Ultrabook, 15z 5523, 6 GB RAM, Intel i3-3217U,
Intel 7 Series/C210 Audio. snd_hda_intel bus-ID: 00:1b.0...

User avatar
MtnDewManiac
Level 6
Level 6
Posts: 1411
Joined: Fri Feb 22, 2013 5:18 pm
Location: United States

Re: Enable Mint 17.3 XFCE system sounds

Post by MtnDewManiac » Mon Jan 18, 2016 12:33 am

mingle wrote:Why it can't be a simple matter of ticking the "Enable system sounds" option, I don't know.
That option does not seem to be present in any distros (that I have used) that used the Xfce DE. Because of this, I occasionally see a thread asking for help with enabling system sounds on the Xfce community web-forum. I tried following the instructions in one, once (back in Mint 14, IIRC) and it worked. I suggest that you post your question there. You'll want to include some basic information in your post, such as the distro (Mint), distro version, and which version of Xfce (4.12) you're using. People are as helpful there as they are here, but they specialize in Xfce (staff member ToZ is especially helpful - I have seen threads in which he downloaded/installed the same distro/version that the questioner was using, just to be able to better help troubleshoot an issue). If you do decide to ask your question there, please come back to this thread and post the solution in order to help others here. I believe a link to it would be acceptable if you do not wish to copy/paste.

Code: Select all

https://forum.xfce.org/
Regards,
MDM
Mint 18 Xfce 4.12.

If guns kill people, then pencils misspell words, cars make people drive drunk, and spoons made Rosie O'Donnell fat.

tarala
Level 1
Level 1
Posts: 28
Joined: Sun May 25, 2014 7:35 pm

Re: Enable Mint 17.3 XFCE system sounds

Post by tarala » Tue Jan 19, 2016 3:06 am

Thanks for the replies!

Surprisingly, when I used my computer today, I suddenly had a sound come when a prompt popped up. So some sounds seem to be working. However, it is still a bit confusing how the sound theme setting is missing from the settings editor.

Unfortunately, there is still no sound on volume change which was the only sound effect I wanted. I have been trying to find the configurations (i.e. which sound effects to be played at which event), but so far I have not been able to do so. Does anyone know which configuration file I should edit? Thanks!

tarala
Level 1
Level 1
Posts: 28
Joined: Sun May 25, 2014 7:35 pm

Re: Enable Mint 17.3 XFCE system sounds

Post by tarala » Thu Jan 28, 2016 5:51 am

ByeByeXP wrote:Greetings! Since you mentioned that you heard "some sound", i assume that your basic setup for your pc's audio chip/subsytem is working poperly. Just to make sure, can you play an audio CD/.mp3 file and listen to it? Probably, yes. So let's move on.

Afaik, the on/off switch for having "System Sounds" to work AT ALL is located in your panel's "Sound" indicator icon (depending on your system's icon theme, that w/b a "speaker"-type icon to the far-right of your panel's space). Once you click on THAT icon, you'll have a few choices. "Mute/Unmute" is the 1st choice. If "Unmute" shows at the top, your sound chip is "muted" and you'd have to "unmute" 1st. Ok, to move on; then at the bottom of that popup, you should see the "Sound Settings ..." option. Can you spot that one?
Thanks for the reply.
Sound playback is working just fine, this thread is about enabling system sounds, more specifically the volume change sound effect. Nothing is muted and, as I mentioned, some system sounds are playing. However, as the sound theme option appears to be missing it is hard for me to configure which sound files to use for which events

User avatar
richyrich
Level 19
Level 19
Posts: 9027
Joined: Mon May 04, 2009 8:31 pm

Re: Enable Mint 17.3 XFCE system sounds

Post by richyrich » Thu Jan 28, 2016 8:46 am

Menu > Settings > Appearance program - Settings tab . . have you put a check in the "Enable event sounds" checkbox ?

tarala
Level 1
Level 1
Posts: 28
Joined: Sun May 25, 2014 7:35 pm

Re: Enable Mint 17.3 XFCE system sounds

Post by tarala » Fri Feb 05, 2016 6:05 pm

Thanks for the replies, guys.
Yes, event sounds under Menu > Settings > Appearance - Settings tab is indeed ticked. Event sounds do appear to be activated on my system, however I have struggling to be changing the settings to play the desired sound effects upon the intended events.

In Settings Editor, I had completely missed noticing the 'Add' button allowing me to manually add the missing subkey. Now, I added it as a 'string' type and wrote 'ubuntu' under value.
Now, this should mean that the sound files placed in /usr/share/sounds/ubuntu/stereo/ are used, as far as I know?

It is still not playing the audio-volume-change.oga upon volume change via fn keys. I also made a renamed copy calle audio-volume-change.ogg just in case the .oga made it miss the file, but still no luck. No sound is played upon volume change. The other sounds I was experiencing are still playing (e.g. sound effect upon prompt when closing multiple tabs at once in Firefox)

User avatar
mingle
Level 3
Level 3
Posts: 128
Joined: Thu May 24, 2012 9:58 pm

Re: Enable Mint 17.3 XFCE system sounds

Post by mingle » Mon Feb 08, 2016 9:45 pm

@ByeByeXP,

I seem to be missing something... When I go into the Graphical Setting Editor, I see a rather sparse display...
settings.png
What do I need to do to get sound themes installed?

Cheers,

Mike.

User avatar
xfrank
Level 5
Level 5
Posts: 598
Joined: Sat Nov 24, 2012 6:09 pm
Location: Mexico City
Contact:

Re: Enable Mint 17.3 XFCE system sounds

Post by xfrank » Mon Feb 08, 2016 11:03 pm

mingle wrote:You're in the same boat as a lot of people - getting basic system sounds to work in LM is a mystery to most (including me).

Why it can't be a simple matter of ticking the "Enable system sounds" option, I don't know.

There are very few tutorials on how to get it to work and none of the ones that I've tried
have solved the issue.

Sorry I can't be of help, but I feel your pain...

Mike.
I'ts a mistery why the Xfce team don't pay enough attention to the system sounds. I'm a heavy Xfce user (other than Cinnamon), and I ever struggle to enable system sounds. Why they are not enabled by default (with the option to disable them)? Xfce is a wonderful DE, but would be even more widespread and popular if simple things like system sounds would work properly out-of-the-box.
Linux everywhere. Active Distros in my many computers: LM17.3 (Cinnamon, Xfce); LM18.1 (Cinnamon,Xfce); LMDE 2 (Mate), MXLinux (Xfce), Debian 9 (Xfce).

User avatar
Quexos
Level 2
Level 2
Posts: 72
Joined: Wed Jul 29, 2015 9:49 pm

Re: Enable Mint 17.3 XFCE system sounds

Post by Quexos » Tue Feb 09, 2016 9:07 pm

ByeByeXP, I did all the above in Mint 17.3 Xfce, except I set "/Net/SoundThemeName string value = freedesktop" because that is the sound theme in "/usr/share/sounds/freedesktop/stereo/". I also tried "default", and "LinuxMint" which also did not work. I still get absolutely not a single peep from any system sounds. All other sound works fine, and the sound files themselves that are in the freedesktop folder play fine in Audacity.

No startup, shutdown, login, logout, trash, volume slide, connect/disconnect usb devices...nothing.

cottfcfan
Level 4
Level 4
Posts: 255
Joined: Tue Jun 16, 2009 7:32 am
Location: Hull, England.

Re: Enable Mint 17.3 XFCE system sounds

Post by cottfcfan » Thu Feb 11, 2016 3:09 pm

For anyone having a problem with this age old issue, i'll put all the steps required in one place to get system sounds working.
1. Download and unzip the following sound folder from post #8:
http://ubuntuforums.org/showthread.php?t=2263834
Copy the folder to /usr/share/sounds.

2. Then in a terminal:

Code: Select all

sudo apt-get install pavucontrol dconf-editor sox gnome-session-canberra
3. In settings/appearance/settings make sure that "enable event sounds" & "enable event sounds feedback" are both ticked.

4. In settings/settings editor/xsettings/ Change SoundThemeName to Borealis (Don't forget the capital B)

5. In dconf-editor, Go to org/gnome/desktop/sound. Make sure both sound boxes are ticked, & change theme name to Borealis.

6. In a terminal:

Code: Select all

sudo gedit /etc/X11/Xsession.d/52libcanberra-gtk-module_add-to-gtk-modules
paste the following into the empty file & save:

Code: Select all

# This file is sourced by Xsession(5), not executed.

if [ -z "$GTK_MODULES" ] ; then
	GTK_MODULES="canberra-gtk-module"
else
	GTK_MODULES="$GTK_MODULES:canberra-gtk-module"
fi

export GTK_MODULES

Code: Select all

sudo gedit /etc/X11/Xsession.d/52libcanberra-gtk3-module_add-to-gtk-modules
paste the following & save:

Code: Select all

# This file is sourced by Xsession(5), not executed.

if [ -z "$GTK_MODULES" ] ; then
	GTK_MODULES="canberra-gtk-module"
else
	GTK_MODULES="$GTK_MODULES:canberra-gtk-module"
fi

export GTK_MODULES
7. Open up pulse audio volume control & make sure under playback that system sounds is 100%

Now finally logout & back in. Hopefully you'll have system sounds.
This works on Xubuntu 14.04 on which Mint 17 is based, so should work.
Thanks to Toz for most of these instructions.

User avatar
Quexos
Level 2
Level 2
Posts: 72
Joined: Wed Jul 29, 2015 9:49 pm

Re: Enable Mint 17.3 XFCE system sounds

Post by Quexos » Thu Feb 11, 2016 9:55 pm

cottfcfan wrote:For anyone having a problem with this age old issue, i'll put all the steps required in one place to get system sounds working.
That worked somewhat. Doing all that got the annoying click and "buthump" sounds on almost every click of the mouse on anything (sometimes more than one sound at a time), but still no useful event sounds. Unticking the "enable input feedback sounds" button stops it, but of course, I'm back to total silence.

I think I'll just keep the silent Xfce and forget about this.

tarala
Level 1
Level 1
Posts: 28
Joined: Sun May 25, 2014 7:35 pm

Re: Enable Mint 17.3 XFCE system sounds

Post by tarala » Sun Feb 14, 2016 2:35 am

ByeByeXP wrote:Hi ... It looks like you're making some progress -- at least some of the event-sounds are playing.

Now, re. your 'ubuntu"-sounds: afaik, if you installed that theme correctlym there s/b an "index.theme" file in your /usr/share/sounds/ubuntu folder that looks like this:
[Sound Theme]
Name=ubuntu
Directories=stereo

[stereo]
OutputProfile=stereo
Do you have THAT file? Is the spelling of "ubuntu" correct (case-sensitive!) ? If all that lines up, the matching of events-to-sounda s/b (theoretically!) just fine.

Re. your "Fn"+{somekey} keyboard control to up/down/mute/unmute is a whole new story. I've located two forum posts here and here that discuss how to get this done. Imho, way to complicated for any distro-maintainer to get that pre-configured -- there are way too many variables and/or users' preferences to consider ... In addition, most laptops implement those controls in their firmware which may/may not properly signal those Fn-events to the OS.

Example: when muting, should there be an event-sound before the mute happens? On the other hand, should there be an event-sound after the unmute? How about event-sounds only for keyboarding, but not for mouse-control? Or perhaps the other way? Who decides?
Thanks for the reply.
Nothing has changed, it is the same sounds as before I edited the index.theme file to correct from 'Ubuntu' to 'ubuntu', but it has not changed anything,

Just to clarify: The functionality of the fn keys is fine in terms adjusting volume/brightness. It's just having the sound event for volume change triggered that appears to be the barrier. Does this sound event activate a sound effect on your system?

Also: I tried to change the sound theme to test it, and I downloaded that modified Borealis theme. However, changing the SoundThemeName setting had no effect, it's still the same sound effects

cottfcfan
Level 4
Level 4
Posts: 255
Joined: Tue Jun 16, 2009 7:32 am
Location: Hull, England.

Re: Enable Mint 17.3 XFCE system sounds

Post by cottfcfan » Sun Feb 14, 2016 5:07 am

The above tutorial only brings back limited system sounds. Window opening/closing/minimizing, button pushed etc...
Unless anyone knows different, this is the best there is at the moment.
I suppose that is why XFCE is known as a "lightweight distro".
If you want all the bells & whistles then Gnome/KDE is the way to go.
I do agree though it would be useful to have a "full system sounds" option available.
That's probably one for the XFCE devs though.
There is an xfce wish list here:
https://wiki.xfce.org/wish_list
Maybe the more that request this, the more chance it has of being implemented.

Lord Vltor
Level 1
Level 1
Posts: 4
Joined: Sat Jan 06, 2018 5:14 pm

Re: Enable Mint 17.3 XFCE system sounds

Post by Lord Vltor » Sun Nov 04, 2018 10:06 pm

Just to say, the v12 LXDE *has* system sounds enabled.
Browsing through the oldest LinuxOS distros, I noticed the oldest have the System Sounds enabled - all of them: there's even an option to work and tweak the sounds in the control panel, if I remember correctly.
What I do not understand is why it has been removed with the time: slamming it back wouldn't be that bad, after all: WinXP (or was it Win95?) had a nice, simple interface to re-assign system sounds for a good personalization.

Post Reply

Return to “Xfce”