How to set Opera as the default browser? [solved]

Forum rules
Before you post please read how to get help
Post Reply
bt101
Level 1
Level 1
Posts: 33
Joined: Thu Feb 14, 2013 12:30 am

How to set Opera as the default browser? [solved]

Post by bt101 » Sat Feb 06, 2016 12:25 pm

Hi

Running Mint 17.

I want to set the default browser to Opera, but things still open in FF (from both Thunar and Thunderbird).

I tried this:
http://forums.linuxmint.com/viewtopic.php?f=57&t=208800

However things still open in FF.
Perhaps I'm having a bit of difficulty understanding the instructions:

Code: Select all

I believe you need to:
1. Change browser in XFCE (Settings -> Settings Manager -> Preferred applications -> Opera)
and do not do:
3. Change opera to default browser

Doing #1 is enough. If, after this, a browser asks if you want it to be the default browser, then answer NO. At least that's how it works here.
Is there a step #2 missing, because those two steps seem to contradict themselves?

Any solutions?
Thanks
Last edited by bt101 on Sun Feb 07, 2016 1:11 pm, edited 1 time in total.

User avatar
Moem
Level 19
Level 19
Posts: 9562
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: How to set Opera as the default browser?

Post by Moem » Sat Feb 06, 2016 1:16 pm

those two steps seem to contradict themselves
Not if the second one means setting Opera as default browser from inside Opera, in the settings/preferences. (That's what I would try first, anyway.)
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

bt101
Level 1
Level 1
Posts: 33
Joined: Thu Feb 14, 2013 12:30 am

Re: How to set Opera as the default browser?

Post by bt101 » Sat Feb 06, 2016 6:40 pm

M0em wrote:
those two steps seem to contradict themselves
Not if the second one means setting Opera as default browser from inside Opera, in the settings/preferences. (That's what I would try first, anyway.)
How do you do that?
I followed these instructions for setting the default browser from inside opera:
http://www.wikihow.com/Set-Opera-As-You ... et-Browser
However there is no such setting.

User avatar
Moem
Level 19
Level 19
Posts: 9562
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: How to set Opera as the default browser?

Post by Moem » Sat Feb 06, 2016 6:52 pm

bt101 wrote:
M0em wrote:
those two steps seem to contradict themselves
Not if the second one means setting Opera as default browser from inside Opera, in the settings/preferences. (That's what I would try first, anyway.)
How do you do that?
I followed these instructions for setting the default browser from inside opera:
http://www.wikihow.com/Set-Opera-As-You ... et-Browser
However there is no such setting.
There isn't? Then my try would have failed. I'm pretty surprised though... I've never seen a browser which did not have that setting somewhere!
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

bt101
Level 1
Level 1
Posts: 33
Joined: Thu Feb 14, 2013 12:30 am

Re: How to set Opera as the default browser?

Post by bt101 » Sat Feb 06, 2016 7:11 pm

M0em wrote:There isn't? Then my try would have failed. I'm pretty surprised though... I've never seen a browser which did not have that setting somewhere!
I'm not sure how to embed an image, so I attached below.

I looked all over inside opera for the setting and cannot find it.

Whether the setting is inside or outside opera, I'll take any solution.
Attachments
opera.png

GeneBenson
Level 4
Level 4
Posts: 342
Joined: Fri Sep 17, 2010 9:55 pm

Re: How to set Opera as the default browser?

Post by GeneBenson » Sat Feb 06, 2016 8:44 pm

Hi bt101,
those two steps seem to contradict themselves
The idea is not to set any browser as default from within the browser itself. I know it is confusing and sounds counter intuitive but that's how it works here.

So just change browser in XFCE (Settings -> Settings Manager -> Preferred applications -> Opera) and make sure no browser is set to default in the browser itself (in it's preferences). If a browser asks if you want to make it the default then answer NO.

Hope this clears it up for you. :D

bt101
Level 1
Level 1
Posts: 33
Joined: Thu Feb 14, 2013 12:30 am

Re: How to set Opera as the default browser?

Post by bt101 » Sat Feb 06, 2016 9:40 pm

GeneBenson wrote:Hi bt101,
those two steps seem to contradict themselves
The idea is not to set any browser as default from within the browser itself. I know it is confusing and sounds counter intuitive but that's how it works here.

So just change browser in XFCE (Settings -> Settings Manager -> Preferred applications -> Opera) and make sure no browser is set to default in the browser itself (in it's preferences). If a browser asks if you want to make it the default then answer NO.

Hope this clears it up for you. :D
Ok that makes sense, and we are tantalizingly close.
I did the XFCE settings thing a long time ago and it didn't make a difference.
Neither browser asks me anything at startup.
After your post, I looked inside FF to see if there was some way to "unset" it as the default.
From what I can see (pic 1 below) FF only has the option to set as default (not unset).
ff1.png
So (for the heck of it) I checked the box that says "always check if ff is your default browser".
I didn't think that it would prompt me at startup because FF seems to be stuck as the default browser already.
However when I restarted FF it did indeed ask me if I want FF as the default browser (pic 2 below).
ff2.png
So I selected "not now".

However nothing has changed, everything still opens in FF.
Did a reboot as well, no diff.
ummm, please don't say "uninstall FF". :(

Habitual
Level 13
Level 13
Posts: 4870
Joined: Sun Nov 21, 2010 8:31 pm
Location: 0.0.0.0

Re: How to set Opera as the default browser?

Post by Habitual » Sat Feb 06, 2016 11:59 pm

I set mine in

Code: Select all

exo-preferred-applications

bt101
Level 1
Level 1
Posts: 33
Joined: Thu Feb 14, 2013 12:30 am

Re: How to set Opera as the default browser?

Post by bt101 » Sun Feb 07, 2016 12:19 am

Habitual wrote:I set mine in

Code: Select all

exo-preferred-applications
Yes, that launches the same app as this:
ff3.png
Which unfortunately has no effect.

GeneBenson
Level 4
Level 4
Posts: 342
Joined: Fri Sep 17, 2010 9:55 pm

Re: How to set Opera as the default browser?

Post by GeneBenson » Sun Feb 07, 2016 3:44 am

Hi bt101,

In Thunar:
Right click on an object you want to open with Opera and choose "Properties". In "Open with" you should be able to set this to opera. If this doesn't stick then there is the brute force method. In your Home folder open the file ~/.local/share/applications/mimeapps.list and change every instance of firefox to opera. .local is a hidden folder so make sure you can see hidden folders/files in Thunar.

In Thunderbird:
Start Thunderbird and then Menu -> Edit -> Preferences -> Attachments tab you should have an entry for http and/or https. Under "Action" you should be able to select opera.

bt101
Level 1
Level 1
Posts: 33
Joined: Thu Feb 14, 2013 12:30 am

Re: How to set Opera as the default browser?

Post by bt101 » Sun Feb 07, 2016 1:10 pm

GeneBenson wrote:Hi bt101,

In Thunar:
Right click on an object you want to open with Opera and choose "Properties". In "Open with" you should be able to set this to opera. If this doesn't stick then there is the brute force method. In your Home folder open the file ~/.local/share/applications/mimeapps.list and change every instance of firefox to opera. .local is a hidden folder so make sure you can see hidden folders/files in Thunar.

In Thunderbird:
Start Thunderbird and then Menu -> Edit -> Preferences -> Attachments tab you should have an entry for http and/or https. Under "Action" you should be able to select opera.
Ah, yes the Thunar solution you specified has worked. I totally forgot about that method (I think I got fixated on the "preferred applications" xfce thing and thought it would change the browser for all apps).

Although I had forgot about Thunar's settings (duh) I had looked everywhere in Thunderbird for a setting and could not find it. I had come across some posts that mentioned Preferences/Attachments/Incoming but found there were no settings for http:
tbird.png
After your post above, I thought that angle needed more digging, so I came across this article:
https://kevinlocke.name/bits/2012/07/18 ... ser-linux/
I followed the instructions in the first section entitled 'mimeTypes.rdf'.
It forces thunderbird to ask you what application you want to use when clicking on a link.
You can select the desired browser -or- you can select /usr/bin/xdg-open so tbird will use the preferred browser from xfce.

OK,I think I've got it now thanks everyone.
It appears the the xfce preferred applications is a bit of a red herring, in that you need to go into the apps and specify your desired browser, or at least tell the app to use the xfce setting.

Post Reply

Return to “Xfce”