Disappearing Clock

Forum rules
Before you post please read how to get help
VirgoMale8
Level 1
Level 1
Posts: 19
Joined: Wed Mar 25, 2015 2:22 pm

Disappearing Clock

Post by VirgoMale8 »

I am usnig Linux Mint 18 with XFCE. When I change the clock format to 12 hour the entire clock disappears from the panel. Under Preferences/Options it reads Format: "Custom Format". I changed the clock display to LCD and it reappeared in 12 hour format, though... :P

User avatar
MtnDewManiac
Level 6
Level 6
Posts: 1459
Joined: Fri Feb 22, 2013 5:18 pm
Location: United States

Re: Disappearing Clock

Post by MtnDewManiac »

Seems like a bug - did you post about it in the comments area of Clem's Mint 18 Xfce beta blog page?

Regards,
MDM
Mint 18 Xfce 4.12.

If guns kill people, then pencils misspell words, cars make people drive drunk, and spoons made Rosie O'Donnell fat.

VirgoMale8
Level 1
Level 1
Posts: 19
Joined: Wed Mar 25, 2015 2:22 pm

Re: Disappearing Clock

Post by VirgoMale8 »

Thanks. No I posted it at http://blog.linuxmint.com/?p=3068#comment-131961. It is comment #169. :?
Last edited by VirgoMale8 on Fri Jul 22, 2016 11:18 am, edited 1 time in total.

User avatar
richyrich
Level 19
Level 19
Posts: 9063
Joined: Mon May 04, 2009 8:31 pm

Re: Disappearing Clock

Post by richyrich »

The link was found on Mint's main page . .

http://blog.linuxmint.com/?p=3073

VirgoMale8
Level 1
Level 1
Posts: 19
Joined: Wed Mar 25, 2015 2:22 pm

Re: Disappearing Clock

Post by VirgoMale8 »

richyrich wrote:The link was found on Mint's main page . .

http://blog.linuxmint.com/?p=3073
I found it by searching Google... :wink:

thom_A
Level 4
Level 4
Posts: 314
Joined: Tue Jun 09, 2015 1:26 pm

Re: Disappearing Clock

Post by thom_A »

It's probably a bug. I just picked the LCD option for now.

User avatar
Pepi
Level 5
Level 5
Posts: 934
Joined: Wed Nov 18, 2009 7:47 pm

Re: Disappearing Clock

Post by Pepi »

This happened to me during my testing also

User avatar
Voltron
Level 2
Level 2
Posts: 65
Joined: Tue Oct 21, 2014 12:48 am
Location: Indiana University--Bloomington

Re: Disappearing Clock

Post by Voltron »

I brought up a new installation of Linux Mint 18.1 Xfce (64-bit) and this appears to still exist. As mentioned in the comments section of the release announcement of Linux Mint 18 Xfce, I am seeing this, as well:

RE: Clock Applet Disappearing

I can confirm that the clock applet disappears on me, as well, whenever I modify any of the “Clock” preferences, when I leave the display format on “Digital.” However, when I change the display format to something other than “Digital,” I am able to see the new formatted clock; it does not disappear. I have the 32-bit version installed on a Toshiba notebook computer.

As stated, I am also seeing this on a new, up-to-date installation of Linux Mint 18.1 Xfce (64-bit). I haven't tested to see if this is an Xfce-based bug or a Linux Mint-based bug, yet. I have a feeling it is Xfce-based. Can anyone confirm this? Are the Linux Mint developers aware of this issue? There does not appear to be much communication on this (potential) bug.

Thanks.

Dan14
Level 1
Level 1
Posts: 1
Joined: Mon Sep 18, 2017 11:55 am

Re: Disappearing Clock

Post by Dan14 »

Voltron wrote:I have a feeling it is Xfce-based. Can anyone confirm this?
For me, it only happens in Xfce, not in MATE or Cinnamon. Cinnamon has its own panel clock bug, where "Display seconds" just shows a static seconds placeholder, and only the minutes change.

User avatar
DanJ
Level 1
Level 1
Posts: 38
Joined: Mon Dec 14, 2009 8:35 am

Re: Disappearing Clock

Post by DanJ »

.
Last edited by DanJ on Thu Jan 09, 2020 4:52 pm, edited 1 time in total.

TroyFoxxin
Level 1
Level 1
Posts: 3
Joined: Thu Nov 24, 2011 1:49 pm

Re: Disappearing Clock

Post by TroyFoxxin »

My way around this was to set it to what i want. and without closing the clock properties.

I open terminal and type

Code: Select all

~$ killall xfce4-panel
followed by

Code: Select all

~$ xfce4-panel & 
Then you can close terminal (which may make the panel refresh again).
but my settings i picked for my clocked remained. The properties thing is just all kinds of borked up.
They have some very lazy ass testers for these basic functions. It was broken like this while it was still a beta.
Figured it be fixed by the time it it was released. but nope clearly not.

happyamos
Level 1
Level 1
Posts: 8
Joined: Sun Jun 10, 2018 8:58 pm
Location: Michigan

Re: Disappearing Clock

Post by happyamos »

I'm using Mint 19 64 bit, bug still here, but I can confirm the above tip did the trick. Not sure if it survives reboots or not yet.

*edit*

It survives reboots. :D

User avatar
thatsafact
Level 1
Level 1
Posts: 20
Joined: Sat Feb 02, 2019 12:44 am

Re: Disappearing Clock

Post by thatsafact »

This still appears to be an issue with digital clock. I changed time format and all time disappeared. I had to switch to LCD to get the time to come back on Linux mint 19.1

mediclaser
Level 4
Level 4
Posts: 384
Joined: Tue Mar 20, 2018 2:28 pm

Re: Disappearing Clock

Post by mediclaser »

If I remember correctly, the workaround is to log out after making the changes on the clock settings, instead of closing the settings window. The clock with the new settings will be visible after logging back in.
If you're looking for a greener Linux pasture, you won't find any that is greener than Linux Mint. ;)

User avatar
thatsafact
Level 1
Level 1
Posts: 20
Joined: Sat Feb 02, 2019 12:44 am

Re: Disappearing Clock

Post by thatsafact »

I changed format to digital and then logged out as you suggested and the clock time format did not disappear. Thanks very much. Seems like long standing bug that could be fixed, but workaround appreciated.

69Rixter
Level 4
Level 4
Posts: 210
Joined: Sun Aug 31, 2014 3:20 pm
Location: Central Ohio

Re: Disappearing Clock

Post by 69Rixter »

I, too had to go to LCD to have time stay in task bar. Next logical question, is there a site I could go to or that would notify me when the "bug" is fixed?

:twisted: Rick

michael-hi
Level 1
Level 1
Posts: 38
Joined: Sun Mar 19, 2017 2:31 pm

Re: Disappearing Clock

Post by michael-hi »

It is surprising that this problem affecting something as basic as the XFCE panel clock has not been fixed. But wait...the panel actually comes with two clocks!

My solution therefore was to right-click on the "Clock" and select Remove. Then you can use Add New Items to add the other clock which is called "DateTime". At first sight it may not seem to be what you are looking for because, by default, it shows the date above the time in small writing. However, in the Properties there are four layout options - Date then Time, Time then Date, Date Only and Time Only. If you choose Time Only, the date will still show in the tooltip which appears when you hover with the mouse, just as with the original "Clock". You will need to change the font and font size eg to Noto Sans 13. Also, the date and time are fully customizable with the usual codes so you can have the date as well as the time in the Time field if that is what you wish.

In other words, it is very easy to make DateTime look just like the original clock.

Frankus333
Level 3
Level 3
Posts: 108
Joined: Mon Jan 06, 2014 10:33 pm
Location: Brisbane Australia

Re: Disappearing Clock

Post by Frankus333 »

Great stuff; thanks michael-hi

This seems like the better applet anyway. Maybe rather than fixing the bug, devs should just change to this default.

Cheers
Frankus333: LM19.3XFCE 64bit; Intel NUC8i3BEH, 4GB RAM, CPU Dual Core i3-8109U Kaby Lake 3.6GHz, 1TB HDD, dual boot Win 10 Home. LM18.3 KDE 64 bit; HP 15 laptop, 4GB RAM, CPU Celeron dual core N2840 2.5GHz, 500GB HDD (triple boot LM19.3 XFCE, Win 8.1)

Crippled

Re: Disappearing Clock

Post by Crippled »

This also happens on other releases of Linux mint Xfce. Delete the clock and then re-add it fixes it.

XP Refugee
Level 2
Level 2
Posts: 51
Joined: Sun May 25, 2014 11:42 pm

Re: Disappearing Clock

Post by XP Refugee »

mediclaser wrote:
Thu Mar 14, 2019 6:43 pm
If I remember correctly, the workaround is to log out after making the changes on the clock settings, instead of closing the settings window. The clock with the new settings will be visible after logging back in.
I did that but when I logged back in it was in MATE :)
hahahahaha
never a dull moment in LinuxLand.
as an aside, has anyone ever found any OS where ticking the box to disable touchpad while typing actually works?? :D
Last edited by XP Refugee on Thu Jan 16, 2020 4:21 am, edited 1 time in total.

Post Reply

Return to “Xfce”