Page 1 of 1

dropbox is removing in autostart list

Posted: Mon Nov 21, 2016 5:33 am
by erkasoft
Hello,

I'm using Linux Mint 18 XFCE. I have a dropbox indicator problem.
Indicator plugin is not displayed correctly in panel after dropbox install.
I removed " start dropbox on system startup" option and add custom startup command like this:
name: my custom dropbox
command: dbus-launch dropbox start

Dropbox stared and display indicator correctly.
But after reboot, my custom item is removing in autostart list.

Can anyone help me about that ?

Thanks,

Re: dropbox is removing in autostart list

Posted: Mon Nov 21, 2016 6:17 am
by kc1di
Hello erkasoft and Welcome to Mint,

Here's what you need to do:

Create the Special instructions in Startup - Do not just edit existing file. but remove it and create a new line for Dropbox. with

Code: Select all

dbus-launch dropbox start
now start dropbox manually and right click on the icon. in the panel go to preferences and uncheck the box that say start dropbox on system startup.
other wise on every startup it will generate a new startup line in the list. and you'll end up with two lines and it won't work.

Good luck
dboxsc1.png
dboxsc2.png

Re: dropbox is removing in autostart list

Posted: Mon Nov 21, 2016 7:07 am
by erkasoft
Hi kc1di,

Thank you for quick and detailed instructions.
Actually, I did same steps but it didn't work. But I changed the name of autostart list that "blabla dp" and now working :D
Maybe Dropbox check "dropbox" name and removing it. I don't know.
But now ok.

Have a nice day,
Thanks,

Re: dropbox is removing in autostart list

Posted: Mon Nov 21, 2016 7:15 am
by kc1di
Glad you found a solution, enjoy :)

Re: dropbox is removing in autostart list

Posted: Thu Mar 02, 2017 11:51 am
by jsb
I was not sure if I was following the instructions above correctly, but based on this discussion, I tried the following and it seems to have worked (Mint 18.1 XFCE 64 bit):

First I had tried this:

Code: Select all

dropbox stop && dbus-launch dropbox start
as suggested here: viewtopic.php?f=47&t=216403#p1131994

That got the dropbox icon to appear correctly in the panel, but it did not survive a restart.

So then repeated that to get the icon back for a session and I did these steps:
Unchecked "Dropbox" in startup and "Start Dropbox on system startup" from the dropbox preferences.

Then I restarted and added the command suggested by kc1di to startup:

Code: Select all

dbus-launch dropbox start
I restarted and the Dropbox icon appeared correctly in the tray.

Re: dropbox is removing in autostart list

Posted: Thu Mar 02, 2017 11:58 am
by jsb
Oops, I spoke too soon. My fix did not survive a second restart. The item I had added to the application autostart list for drop box is gone after restarting again.

Re: dropbox is removing in autostart list

Posted: Thu Mar 02, 2017 12:13 pm
by jsb
Hmm, well tried again and added the step of unchecking and rechecking the command to start dropbox in the application autostart list of "Session and Startup" and now it does seem to have worked...at least for a couple restarts. :?

Thought maybe unchecking and rechecking is what somehow had worked, based on:
erkasoft wrote:Hi kc1di,

Thank you for quick and detailed instructions.
Actually, I did same steps but it didn't work. But I changed the name of autostart list that "blabla dp" and now working :D
Maybe Dropbox check "dropbox" name and removing it. I don't know.
But now ok.

Have a nice day,
Thanks,

Re: dropbox is removing in autostart list

Posted: Mon Dec 11, 2017 4:07 am
by demonlibra
Maybe it will be usefull.
Every time after I run dropbox, file "/home/username/.config/autostart/dropbox.desktop" changing by file "/usr/share/applications/dropbox.desktop"

So, I did some changes in file "/usr/share/applications/dropbox.desktop"

replace

Code: Select all

Exec=dropbox start -i
to

Code: Select all

Exec=dbus-launch dropbox start -i
if you want to disable autostartup add to end

Code: Select all

X-GNOME-Autostart-enabled=false

Re: dropbox is removing in autostart list

Posted: Fri Jun 15, 2018 12:30 pm
by tehol
demonlibra wrote:
Mon Dec 11, 2017 4:07 am
Maybe it will be usefull.
Every time after I run dropbox, file "/home/username/.config/autostart/dropbox.desktop" changing by file "/usr/share/applications/dropbox.desktop"

So, I did some changes in file "/usr/share/applications/dropbox.desktop"

replace

Code: Select all

Exec=dropbox start -i
to

Code: Select all

Exec=dbus-launch dropbox start -i
if you want to disable autostartup add to end

Code: Select all

X-GNOME-Autostart-enabled=false
This was the solution I used, but I found the above description unclear.

In order to prevent dropbox from forcing the startup applications to include dropbox, you must edit the file "/usr/share/applications/dropbox.desktop". Dropbox will cease to launch upon startup if that file reads as follows:

Code: Select all

 [Desktop Entry]
Name=Dropbox
GenericName=File Synchronizer
Comment=Sync your files across computers and to the web
Exec=dropbox start -i
Terminal=false
Type=Application
Icon=dropbox
Categories=Network;FileTransfer;
StartupNotify=false
X-GNOME-Autostart-enabled=f

Re: dropbox is removing in autostart list

Posted: Thu Sep 13, 2018 6:23 am
by Anastasia Stefanuk
You can write
~/config/autostart/dropbox.desktop



____________________________________________________________________________________________________________________________
dropbox integration