User login list on lightdm managed desktop

Forum rules
Before you post please read how to get help
Post Reply
bobinmurphy
Level 1
Level 1
Posts: 5
Joined: Mon Dec 18, 2017 11:18 pm

User login list on lightdm managed desktop

Post by bobinmurphy » Tue Dec 19, 2017 9:17 am

I have 18.3 on my system and installed libvirt-manager. It created a couple of entires in the passwd file for accounts libvirt-qemu and libvirt-dnsmasq. Both entires have UID and GID values outside the range used for login as defined in the /etc/login.defs file. However there's always and entry on the lightdm login screen for the libvirt-qemu entry. Neither account is a user account that can be logged into. How do I get the libvirt-qemu entry removed from the list of users on the login page?

pcspecialistpdx
Level 1
Level 1
Posts: 26
Joined: Fri Jun 10, 2016 6:19 pm

Re: User login list on lightdm managed desktop

Post by pcspecialistpdx » Tue Dec 19, 2017 9:09 pm

You could try replacing lightdm with mdm:

sudo apt install mdm xscreensaver

sudo apt remove slick-greeter lightdm lightdm-settings apparmor

User avatar
greerd
Level 5
Level 5
Posts: 940
Joined: Sat Jul 31, 2010 10:58 am
Location: Nova Scotia, Canada

Re: User login list on lightdm managed desktop

Post by greerd » Tue Dec 19, 2017 9:43 pm

/etc/lightdm/users.conf has a [UserList] option 'minmum-uid=500' which looks to conflict with /etc/login.defs 'UID_MIN 1000'.
You could try setting minimum-uid=1000 and see if that helps. Your user id should = 1000. typing 'id' at the command prompt will tell.
Image

bobinmurphy
Level 1
Level 1
Posts: 5
Joined: Mon Dec 18, 2017 11:18 pm

Re: User login list on lightdm managed desktop

Post by bobinmurphy » Sun Jan 14, 2018 9:22 pm

Regardless of the conflicts between /etc/lightdm/users.conf and /etc/login.defs for the min and max UID and GID, the values for libvirt-qemu are GID=64055 and UID=131. If either of the config files were actually controlling which "users" are presented for login, libvirt-qemu shouldn't show up.

Post Reply

Return to “Xfce”