How to stop mouse click raising a window

Forum rules
Before you post please read how to get help
Post Reply
dangerman
Level 1
Level 1
Posts: 3
Joined: Fri Dec 22, 2017 7:55 am

How to stop mouse click raising a window

Post by dangerman » Fri Dec 22, 2017 8:05 am

Hello. I've just moved to Mint 18.3 XFCE (was previously on 17.3).

One of the things I like about Linux desktops is that I can click on a window without automatically bringing it to the front and obscuring other windows that I might want to see (like the good old days of the Commodore Amiga). But I can't work out how to do this in the latest Mint XFCE.

On my previous install, I think I went to the menu and selected ->Settings ->Window Manager
Then from the Focus tab, I turned off Raise on Click

But this doesn't seem to work on the latest version. What do I need to do? Thanks.

User avatar
all41
Level 12
Level 12
Posts: 4099
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: How to stop mouse click raising a window

Post by all41 » Sun Dec 24, 2017 12:47 am

I can click on a window without automatically bringing it to the front and obscuring other windows that I might want to see
OK but why would you click on a window without expecting focus?
Proud to be a supporter and monthly contributor to Mint.

dangerman
Level 1
Level 1
Posts: 3
Joined: Fri Dec 22, 2017 7:55 am

Re: How to stop mouse click raising a window

Post by dangerman » Mon Dec 25, 2017 2:23 pm

Oh, I do want the window to get focus. But a window can get focus without becoming raised to the top so that it covers absolutely everything else. And for me, that's really useful.

This used to be possible in previous version of XFCE Mint, but since upgrading I can't get it to work any more. I turned off Raise on Click but it doesn't seem to make a difference.

User avatar
all41
Level 12
Level 12
Posts: 4099
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: How to stop mouse click raising a window

Post by all41 » Mon Dec 25, 2017 8:45 pm

In Settings Editor/xfwm4 have you tried disabling focus_new?
Proud to be a supporter and monthly contributor to Mint.

dangerman
Level 1
Level 1
Posts: 3
Joined: Fri Dec 22, 2017 7:55 am

Re: How to stop mouse click raising a window

Post by dangerman » Sun Dec 31, 2017 10:48 am

Hi all41. Thanks for the suggestion. I've tried it but I'm afraid it didn't help. Clicking in a window still raises it in front of other windows as well as giving it focus :(

Post Reply

Return to “Xfce”