[SOLVED]XFCE always starts with my last session

Forum rules
Before you post please read how to get help
Post Reply
User avatar
BigEasy
Level 6
Level 6
Posts: 1181
Joined: Mon Nov 24, 2014 9:17 am
Location: Chrząszczyżewoszyce, powiat Łękołody

[SOLVED]XFCE always starts with my last session

Post by BigEasy » Thu Dec 28, 2017 3:46 pm

After upgraiding to Mint 18.* my XFCE always starts with my last session. I really have no idea how to disable such behaviour. Anybody knows? :)
Last edited by BigEasy on Sat Dec 30, 2017 4:31 am, edited 1 time in total.
Windows assumes I'm stupid but Linux demands proof of it

User avatar
sammiev
Level 4
Level 4
Posts: 369
Joined: Sat May 19, 2012 12:16 pm

Re: XFCE always starts with my last session

Post by sammiev » Thu Dec 28, 2017 5:05 pm

When you goto shut down you will see just below the box Log Out - Restart - Shut Down, save session for future logins.

Remove the check mark from that box.

User avatar
BigEasy
Level 6
Level 6
Posts: 1181
Joined: Mon Nov 24, 2014 9:17 am
Location: Chrząszczyżewoszyce, powiat Łękołody

Re: XFCE always starts with my last session

Post by BigEasy » Fri Dec 29, 2017 5:24 am

5 years since this check mark was removed :) And all saved session cleared.
After upgrading to MInt 18.* I choose display manager LightDM and choose Mint-X login window. May be there is some bug in both of them...
Windows assumes I'm stupid but Linux demands proof of it

User avatar
Pjotr
Level 20
Level 20
Posts: 11053
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: XFCE always starts with my last session

Post by Pjotr » Fri Dec 29, 2017 6:21 am

Wipe all old sessions with a terminal command:

Code: Select all

rm -r -v ~/.cache/sessions/*
Tip: 10 things to do after installing Linux Mint 19 Tara
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

User avatar
BigEasy
Level 6
Level 6
Posts: 1181
Joined: Mon Nov 24, 2014 9:17 am
Location: Chrząszczyżewoszyce, powiat Łękołody

Re: XFCE always starts with my last session

Post by BigEasy » Fri Dec 29, 2017 4:24 pm

Already done! But every time every session saved again and XFCE starting with saved session. Where and when I asked XFCE to do that?
Well, to shutdown my computer I press the keyboard key X86PowerOFF (executing command:xfce4-session-logout --halt). Everything working OK before some last times :)
Windows assumes I'm stupid but Linux demands proof of it

mr_raider
Level 6
Level 6
Posts: 1317
Joined: Sun Jun 20, 2010 9:50 am
Location: Montreal, QC

Re: XFCE always starts with my last session

Post by mr_raider » Fri Dec 29, 2017 4:42 pm

The option was moved into the settings app.
Image

mr_raider
Level 6
Level 6
Posts: 1317
Joined: Sun Jun 20, 2010 9:50 am
Location: Montreal, QC

Re: XFCE always starts with my last session

Post by mr_raider » Fri Dec 29, 2017 9:29 pm

mr_raider wrote:The option was moved into the settings app under session and startup.
Image

User avatar
BigEasy
Level 6
Level 6
Posts: 1181
Joined: Mon Nov 24, 2014 9:17 am
Location: Chrząszczyżewoszyce, powiat Łękołody

Re: XFCE always starts with my last session

Post by BigEasy » Sat Dec 30, 2017 4:31 am

Yes I know, but their checkbox "automatically save session on logout" doesn't work for me. Session always saving regardless of checkbox condition.
Little worlaround I done: I replaced command for X86PowerOFF "xfce4-session-logout --halt" with "shutdown -h now". Now it works as planned :)
Thank you all!
Windows assumes I'm stupid but Linux demands proof of it

Post Reply

Return to “Xfce”