Diagonal screen tearing

Forum rules
Before you post please read how to get help
Post Reply
Torraf
Level 1
Level 1
Posts: 5
Joined: Wed Dec 06, 2017 8:35 am

Diagonal screen tearing

Post by Torraf » Mon Jan 15, 2018 2:09 pm

So I recently switched from Cinnamon to XFCE. XFCE runs alot better imo except that I got som terrible diagonal screen tearing on 18.3. My laptop is rocking a N3450, so just the included Intel gpu. Not a power house, but good enough for Windows and other Linux dists.
Now, I've been googling alot and tried different tips and tricks and the only thing that actually worked was installing Compiz and changing the Window manager to just that, Compiz. Now everything is butter smooth but now I got some other problems. First off, it messes up my theme. I got this extra color on windows title bar, can't style the title bar text, artifacts in the browser when it displays history in the url drop down list, title bar buttons disappears sometimes, whiskers meny acting weird etc. Needless to say, it's not an optimal solution and it almost annoys me more than screen tearing.

I've noticed that a lot of people seem to have problem with tearing on Mint 18. Is there any solution to this problem? Actually almost thinking of changing dist, barly unusable.

Dave B
Level 4
Level 4
Posts: 392
Joined: Thu Jan 08, 2015 10:49 pm
Location: UK

Re: Diagonal screen tearing

Post by Dave B » Tue Jan 16, 2018 12:59 am

Hi Torraf,

Compiz is already included in Mint's Xfce edition (at least it is in 18.3). Maybe try 'xfwm4 + Compton'?

Different display managers are located under
Settings -> Desktop Settings.

Which part/s of Cinnamon caused tearing for you?

Torraf
Level 1
Level 1
Posts: 5
Joined: Wed Dec 06, 2017 8:35 am

Re: Diagonal screen tearing

Post by Torraf » Tue Jan 16, 2018 6:23 am

Dave B wrote:Hi Torraf,

Compiz is already included in Mint's Xfce edition (at least it is in 18.3). Maybe try 'xfwm4 + Compton'?

Different display managers are located under
Settings -> Desktop Settings.

Which part/s of Cinnamon caused tearing for you?
I didn't have tearing on Cinnamon, just on XFCE and Mate. Though Cinnamon was very..."sluggish" like it ran at a lower frames per second.

The display managers that I got is:
"xfwm4 + Compositing" - Sluggish/low fps and bad tearing. Theme OK
"xfwm4" - Smooth but bad tearing. Theme OK
"Metacity + Compositing" - Sluggish/low fps and bad tearing. Theme bad.
"Metacity" - Smooth and tearing. Theme bad.
"Marco + Compositing" - Sluggish/low fps and really bad tearing. Theme OK.
"Marco" - Smooth and tearing. Theme OK
"Compiz" - Smooth, no tearing, buggy. Theme bad.

I have tearing on eveything, most noticable on long webpages though, like a long thread here on the forum.

As I said, Compiz is very smooth but it isn't really compatible with the window's settings, so it looks kinda meh and is really buggy.

Dave B
Level 4
Level 4
Posts: 392
Joined: Thu Jan 08, 2015 10:49 pm
Location: UK

Re: Diagonal screen tearing

Post by Dave B » Tue Jan 16, 2018 9:18 am

Shame Cinnamon edition was a bit slow on your system, guessing possibly older or lower powered hardware?

- There's good news in connection with Firefox

1) In Firefox's address bar enter

Code: Select all

about:config
2) After accepting the warning, copy & paste the following into the search bar

Code: Select all

layers.acceleration.force-enabled
3) Double click the highlighted option so its status changes to 'true'

4) Close and relaunch Firefox, all done!

This change should prevent diagonal tearing.

Torraf
Level 1
Level 1
Posts: 5
Joined: Wed Dec 06, 2017 8:35 am

Re: Diagonal screen tearing

Post by Torraf » Tue Jan 16, 2018 10:06 am

Dave B wrote:Shame Cinnamon edition was a bit slow on your system, guessing possibly older or lower powered hardware?

- There's good news in connection with Firefox

1) In Firefox's address bar enter

Code: Select all

about:config
2) After accepting the warning, copy & paste the following into the search bar

Code: Select all

layers.acceleration.force-enabled
3) Double click the highlighted option so its status changes to 'true'

4) Close and relaunch Firefox, all done!

This change should prevent diagonal tearing.
Yeah the CPU isn't the most powerful, but it can run Windows fine, and Manjaro with Cinnamon or Mate. So I don't think it's Cinnamons fault...

The FF tweak doesn't work and this problem occurs in all browsers I'm afraid.

I think I'm gonna try Mate, see if it might work better there, but I like XFCE the most.

Dave B
Level 4
Level 4
Posts: 392
Joined: Thu Jan 08, 2015 10:49 pm
Location: UK

Re: Diagonal screen tearing

Post by Dave B » Tue Jan 16, 2018 11:39 am

Interesting, haven't seen a system yet which hasn't been fixed by using that Firefox command.

Alternatively...
Set 'layers.acceleration.force-enabled' back to 'false', and test the following command by setting it to true (this command may cause some graphical glitches if using an Intel GPU).

Code: Select all

gfx.xrender.enabled
As before, close all open Firefox instances, then relaunch to test for improvements.

User avatar
Termy
Level 5
Level 5
Posts: 762
Joined: Mon Sep 04, 2017 8:49 pm
Location: UK
Contact:

Re: Diagonal screen tearing

Post by Termy » Sat Feb 17, 2018 11:23 am

Another user on this board found my compton.conf file very useful. I've customized it quite a lot and have a lovely, tear-free experience across the board:

https://github.com/terminalforlife/misc ... mpton.conf

You could try that. Either create a file in ~/.config called compton.conf and copy & paste the contents into it, or, use this one-liner:

Code: Select all

[ -f ~/.config/compton.conf ] || wget -q "https://github.com/terminalforlife/miscellaneous/raw/master/compton.conf" -O ~/.config/compton.conf
Nothing will happen if the file is already there, in-case you don't want to overwrite any existing configurations. By default, the file doesn't exist, which is normal.
Here to help.

I'm LearnLinux (LL) on YouTube: https://www.youtube.com/channel/UCfp-lN ... naEE6NtDSg
I'm also terminalforlife (TFL) on GitHub: https://github.com/terminalforlife

cottfcfan
Level 4
Level 4
Posts: 255
Joined: Tue Jun 16, 2009 7:32 am
Location: Hull, England.

Re: Diagonal screen tearing

Post by cottfcfan » Mon Feb 19, 2018 6:02 am

With integrated Intel Graphics the solution for system wide screen tearing is the following. In a terminal type:

Code: Select all

gksudo xed /usr/share/X11/xorg.conf.d/20-intel.conf
in the empty file that opens, copy & paste the following:

Code: Select all

Section    "Device"
Identifier "Intel Graphics"
Driver     "intel"
Option     "TearFree" "true"
Option     "AccelMethod" "sna" 
EndSection
Save the file & Reboot.

Post Reply

Return to “Xfce”