Can not revert back from XFCE login screen to Cinnamon

Forum rules
Before you post please read how to get help
Post Reply
vizhnu
Level 1
Level 1
Posts: 3
Joined: Thu Jan 18, 2018 7:46 am

Can not revert back from XFCE login screen to Cinnamon

Post by vizhnu » Thu Jan 18, 2018 8:07 am

I installed XFCE desktop environment on my Linux Mint 18.2 Sonya(from Software Manager) . When I tried it , the login page automatically changed to XFCE login. I tried to change the login screen back to cinnamon but I couldn't . So I uninstalled XFCE , but the login screen remains the same. I have tried everything on this forum and other sites to change the login greeter back to the default cinnamon one , but nothing seems to work. It is really frustrating....Someone please help.( I have seen other threads on the same topic , but the solutions didn't work for me.)
NB: I can change the desktop environment to Cinnamon,
it's the login greeter I am having trouble with.
Last edited by vizhnu on Mon Jan 22, 2018 1:23 am, edited 1 time in total.

User avatar
Flemur
Level 16
Level 16
Posts: 6271
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Can not revert back from XFCE login screen to Cinnamon

Post by Flemur » Thu Jan 18, 2018 11:16 am

The login managers are pretty poorly designed and implemented, but :

- you should have a "desktop selector" on the login GUI, although on mine it's made very not-obvious. Try clicking all over the place.

- "lightdm-settings" doesn't set (default/login) desktops, like it should.

- This conveniently located file
/etc/lightdm/lightdm.conf.d/70-linuxmint.conf

Contains:

Code: Select all

[SeatDefaults]
user-session=fluxbox
You could edit that (as sudo) and try changing the user-session to 'Cinnamon' or 'cinnamon'.

Edit: you might also try something like:

Code: Select all

sudo dpkg-reconfigure cinnamon
or

Code: Select all

sudo dpkg-reconfigure lightdm
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

vizhnu
Level 1
Level 1
Posts: 3
Joined: Thu Jan 18, 2018 7:46 am

Re: Can not revert back from XFCE login screen to Cinnamon

Post by vizhnu » Tue Jan 23, 2018 1:13 pm

Thank you flemur , but I can change the desktop environment easily, it is the login greeter that l'm having trouble with . I wasn't quite clear about that in my question and my topic name is also misleading. I have edited my question to be more precise now, but I don't know how to edit the topic name. It's my first time asking a question and I apologize for my mistake. Thanks again for your time.

User avatar
karlchen
Level 19
Level 19
Posts: 9497
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Can not revert back from XFCE login screen to Cinnamon

Post by karlchen » Tue Jan 23, 2018 1:21 pm

Hm. The login screens are not dependent of the desktop environment.
The login screen is displayed before your desktop environment xfce or Cinnamon gets loaded.
Therefore to the best of my knowledge, which ends with Linux Mint 18.1 at the time being, there is no xfce login screen and no Cinnamon login screen. There is just a Linux Mint login screen. At least this was true till Linux Mint 18.1, when mdm ruled the login screen.
Image
Linux Mint 18.1 64-bit Cinnamon Desktop, Total Commander 9.21a 64-bit
Ubuntu 18.04.1 32-bit Mate Desktop, Total Commander 9.21a 32-bit
Windows? - 1 window in every room

User avatar
karlchen
Level 19
Level 19
Posts: 9497
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Can not revert back from XFCE login screen to Cinnamon

Post by karlchen » Tue Jan 23, 2018 1:28 pm

About editing /etc/lightdm/lightdm.conf.d/70-linuxmint.conf:
You could edit that (as sudo) and try changing the user-session to 'Cinnamon' or 'cinnamon'.
translates to either of 2 commandlines:

Code: Select all

sudo vi /etc/lightdm/lightdm.conf.d/70-linuxmint.conf
or

Code: Select all

gksudo xed /etc/lightdm/lightdm.conf.d/70-linuxmint.conf
Note:
sudo is not a user, but a command which will run the rest of the commandline with root privileges.
sudo should never be use to invoke graphical applications. Use gksudo in these cases instead.
Image
Linux Mint 18.1 64-bit Cinnamon Desktop, Total Commander 9.21a 64-bit
Ubuntu 18.04.1 32-bit Mate Desktop, Total Commander 9.21a 32-bit
Windows? - 1 window in every room

vizhnu
Level 1
Level 1
Posts: 3
Joined: Thu Jan 18, 2018 7:46 am

Re: Can not revert back from XFCE login screen to Cinnamon

Post by vizhnu » Wed Jan 24, 2018 12:46 pm

Thanks Karlchen, I think it isn't the xfce login screen.I couldn't attach a screenshot, so I did a bit of googling and came up with an image which resembles my current login screen while searching for "default login manager for linux mint". I am assuming that somehow my login screen got reverted back to an older version.
Attachments
AntergOSloginC-600x450.png

User avatar
karlchen
Level 19
Level 19
Posts: 9497
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Can not revert back from XFCE login screen to Cinnamon

Post by karlchen » Wed Jan 24, 2018 7:40 pm

Hi, vizhnu.

Should it not be possible to select a different login screen theme by going to System Settings => Login Screen?
This at least how I can select a different login screen theme on Linux Mint 18.1, which admittedly uses mdm, not lightdm.

The New features in Linux Mint 18.2 Cinnamon page, section about "LightDM", praises the "Slick Greeter" used by LightDM as highly configurable via "LightDM Settings".

Best regards,
Karl
Image
Linux Mint 18.1 64-bit Cinnamon Desktop, Total Commander 9.21a 64-bit
Ubuntu 18.04.1 32-bit Mate Desktop, Total Commander 9.21a 32-bit
Windows? - 1 window in every room

Post Reply

Return to “Xfce”