Haunted Rebecca Xfce: Renaming Triggers Swapping

Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 21
Joined: Tue Jan 27, 2015 3:10 am

Haunted Rebecca Xfce: Renaming Triggers Swapping

Post by Alaksandu » Wed Mar 07, 2018 3:47 pm

Hello Forum,

I have an otherwise well-working system (Mint 17.1 Rebecca / Xfce 4.11.8 / Gtk 2.24.23) which is plagued by episodes of swapping.

The problem is:
Very excessive swapping, which slows the system down, making any disc operation slower. It goes on for 5-10 minutes per episode. It is quickly and completely eliminated by logging off and back on.

The problem is (frequently) triggered by:
Renaming files in GUI
Copying large files in GUI
Renaming folders in GUI
Creating folders in GUI

The problem is at least largely immune to:
Extensive file management using rsync.

Please help me eliminate this problem, it's very annoying!

inxi -Fxz output:

Code: Select all

System:    Host: [Name] Kernel: 3.13.0-37-generic x86_64 (64 bit, gcc: 4.8.2) 
           Desktop: Xfce 4.11.8 (Gtk 2.24.23) Distro: Linux Mint 17.1 Rebecca
Machine:   Mobo: ASUSTeK model: M4A88TD-V EVO/USB3 version: Rev X.0x Bios: American Megatrends version: 1015 date: 03/31/2010
CPU:       Dual core AMD Athlon II X2 250 (-MCP-) cache: 2048 KB flags: (lm nx sse sse2 sse3 sse4a svm) bmips: 12054.9 
           Clock Speeds: 1: 800.00 MHz 2: 800.00 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RS880 [Radeon HD 4250] bus-ID: 01:05.0 
           X.Org: 1.15.1 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1440x900@59.9hz 
           GLX Renderer: Gallium 0.4 on AMD RS880 GLX Version: 3.0 Mesa 10.1.3 Direct Rendering: Yes
Audio:     Card-1: Advanced Micro Devices [AMD/ATI] RS880 HDMI Audio [Radeon HD 4200 Series] driver: snd_hda_intel bus-ID: 01:05.1
           Card-2: Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA) driver: snd_hda_intel bus-ID: 00:14.2
           Sound: Advanced Linux Sound Architecture ver: k3.13.0-37-generic
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller 
           driver: r8169 ver: 2.3LK-NAPI port: e800 bus-ID: 06:00.0
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 570.1GB (39.8% used) 1: id: /dev/sda model: Hitachi_HDT72503 size: 320.1GB 
           2: id: /dev/sdb model: ST3250318AS size: 250.1GB 
Partition: ID: / size: 288G used: 212G (78%) fs: ext4 ID: swap-1 size: 6.17GB used: 0.00GB (0%) fs: swap 
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 40.0C mobo: 36.0C 
           Fan Speeds (in rpm): cpu: 3040 psu: 1457 sys-1: 1527 
Info:      Processes: 181 Uptime: 40 min Memory: 962.3/5716.9MB Runlevel: 2 Gcc sys: 4.8.4 Client: Shell inxi: 1.8.4 

User avatar
Fred Barclay
Level 12
Level 12
Posts: 4190
Joined: Sat Sep 13, 2014 11:12 am
Location: Bumping around in the bush

Re: Haunted Rebecca Xfce: Renaming Triggers Swapping

Post by Fred Barclay » Wed Mar 07, 2018 4:07 pm

"Once you can accept the universe as matter expanding into nothing that is something, wearing stripes with plaid comes easy."
- Albert Einstein

Level 1
Level 1
Posts: 21
Joined: Tue Jan 27, 2015 3:10 am

Re: Haunted Rebecca Xfce: Renaming Triggers Swapping

Post by Alaksandu » Wed Mar 07, 2018 4:29 pm

Fred Barclay wrote:
Wed Mar 07, 2018 4:07 pm
Try reducing the swappiness:
https://sites.google.com/site/easylinux ... e-swap-use
Unfortunately, that has zero effect. I remembered trying that, but to make sure I tried it again. I tried deleting a .pdf with the new setting (10), and the multi-minute swapping is ongoing as I type.

I forgot to mention deleting files and folders triggers it too: deleting triggers it most of the time.

It's not because of the default install: my system started doing this at some point. Something has broken, I do not know what. Only that command-line and rsync operations often work without triggering the dreaded swapping.

Post Reply

Return to “Xfce”