Gdebi Package Installer

Forum rules
Before you post please read how to get help
Post Reply
User avatar
Night Wing
Level 4
Level 4
Posts: 244
Joined: Wed Dec 25, 2013 10:21 pm
Location: Texas, USA

Gdebi Package Installer

Post by Night Wing » Wed May 16, 2018 7:10 am

At one time, the Gdebi Package Installer was installed by default "and" listed in the old Applications Menu as well as with the Whisker Menu. I install third party .deb packages and I use Gdebi. In Mint 18.3, the Gdebi Package Installer is installed by default in Mint 18.3, but it is "not" listed in the old Applications Menu or the Whisker Menu in Xfce.

Usually, when I download a .deb package to where I want it in Mint 18.3, I just right click and a window opens with Gdebi in it so I left click on Gdebi and Gdebi does the work automatically for me. Just yesterday I was just looking at both the Applications Menu and the Whisker Menu and noticed Gdebi is not listed.

I went into my Synaptic Package Manager and found gdebi and gdebi-core are installed. But what I really want to know is why is the Gdebi Package Installer not listed anywhere in the Applications Menu or the Whisker Menu? And I did check for Gdebi under Accessories too.
Mint 18.3 (Sylvia) Xfce

User avatar
karlchen
Level 18
Level 18
Posts: 8777
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Gdebi Package Installer

Post by karlchen » Wed May 16, 2018 7:50 am

Hi, Night Wing.

I suspect that the launcher file for gdebi will exist in the directory /usr/share/applications. But it might hold the parameter "NoDisplay=true", which would have the effect of hiding it inside the Whisker application menu and inside the xfce application menu.
You might right-click on the [Mint] button and select "Edit menu". You might be able to locate the gdebi item and disable the "hidden" property. I assume gdebi will be located in the System sub-menu or inside the Accessories sub-menu. Yet, I will have to check on my Mint 18.1 xfce system. (Currently logged in on Ubuntu 16.04.4 Unity)

You should be able to invoke gdebi as well by navigating to a .deb file inside the Thunar filemanager, right-click on the .deb filename and select "Open with ..." and select gdebi from the list. There should be a tick box (setting) as well which permits you to make this the default operation for .deb files.

HTH,
Karl
Image
Old bugs good, new bugs bad! Updates are evil: might fix old bugs and introduce no new ones.

User avatar
Night Wing
Level 4
Level 4
Posts: 244
Joined: Wed Dec 25, 2013 10:21 pm
Location: Texas, USA

Re: Gdebi Package Installer

Post by Night Wing » Wed May 16, 2018 10:53 am

Karl

Thanks for your explanation. Per your advice, I'll check it out.

I hope when Mint 19 (Tara) in Xfce is released, Gdebi will be listed in the Applications Menu and the Whisker Menu like it was in previous versions of Mint. If Gdebi isn't listed, then I'll have to go into my Synaptic Package Manager to see if gdebi and gdebi-core are installed. If they are, then I won't assume Gdebi is not installed and it will keep me from installing something which is already installed so it won't cause me a headache to fix.

This same type of thing happened with Domain Blocker which was installed and listed by default in both menus in Mint (18.2). But in Mint 18.3, DB was not listed in both menus because it wasn't installed. I had to go into my Synaptic Package Manager to find "mintnanny" to install Domain Blocker.

BTW, one of my pet peeves about linux. Why can't the Domain Blocker be named, "domainblocker" or "domain-blocker" instead of "mintnanny"? In other words, who comes up with these nerdy, geeky techno type names which can and will cause confusion because people like me are looking for the common name and not something "else"? For me, "mintnanny" does not compute for Domain Blocker.

Sometimes when I see things like this happening, I think some developers "go off the deep end" if you get my drift.
Mint 18.3 (Sylvia) Xfce

User avatar
smurphos
Level 5
Level 5
Posts: 697
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: Gdebi Package Installer

Post by smurphos » Wed May 16, 2018 11:00 am

Gdebi is normally the default application for .deb files. I just double click on the .deb file in the file manager and it opens automatically. This is under Cinnamon.

Hoser Rob
Level 11
Level 11
Posts: 3860
Joined: Sat Dec 15, 2012 8:57 am

Re: Gdebi Package Installer

Post by Hoser Rob » Wed May 16, 2018 11:19 am

As mentioned above, you can just right click a .deb in File Manager and open it with gdebi. It's been some time since I've used gdebi any other way.

User avatar
karlchen
Level 18
Level 18
Posts: 8777
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Gdebi Package Installer

Post by karlchen » Wed May 16, 2018 2:07 pm

Hi, Night Wing.

Just checked here on my Mint 18.1 xfce. The gDebi launcher file is /usr/share/applications/gdebi.desktop. And it holds the parameter NoDisplay=true. This parameter prevents it from being listed in the submenu System.
I.e. changing the parameter to NoDisplay=false (or deleting the line) would make the item gDebi appear in the System submenu.
(Can be done using the "Edit menu" item in Mint Application menu - submenu "Preferences". Or by editing the launcher file with root privileges in xed.)

Also checked in Thunar that Hoser Rob is right. Yes, he is. "Open in gDebi" is the default operation for .deb files.

Best regards,
Karl
Image
Old bugs good, new bugs bad! Updates are evil: might fix old bugs and introduce no new ones.

Post Reply

Return to “Xfce”