Super-T as Terminal Hotkey (Solved)

Forum rules
Before you post please read how to get help
Post Reply
raywood
Level 1
Level 1
Posts: 25
Joined: Sat Apr 09, 2016 1:45 pm

Super-T as Terminal Hotkey (Solved)

Post by raywood » Mon Jun 18, 2018 5:52 am

I have changed the hotkey combination to open Terminal in Xfce (LM 18.3). Instead of Ctrl-Alt-T, it is now Super-T. All I did was change the hotkey in the Keyboard Settings dialog. Problem: while Super-T does open a Terminal session, it also brings up the main menu (i.e., what Super does by itself), where Ctrl-Alt-T didn't. Is there a way to defeat that behavior -- to get Super to function as part of the key combination without simultaneously functioning as though I were pressing Super by itself?
Last edited by raywood on Wed Jun 27, 2018 1:57 pm, edited 1 time in total.

Marziano
Level 7
Level 7
Posts: 1671
Joined: Thu Jan 04, 2018 1:00 pm

Re: Super-T for Terminal

Post by Marziano » Mon Jun 18, 2018 5:58 am

Look for the entry xfce4-popup-whiskermenu in the Application Shortcuts and change the hotkey combination for it by marking it and clicking on the Edit. In the pop-up box, click OK and in the next box choose a new key combo.
"Those are my principles, and if you don't like them...well, I have others." -Marx...
Groucho { Marx

raywood
Level 1
Level 1
Posts: 25
Joined: Sat Apr 09, 2016 1:45 pm

Re: Super-T for Terminal

Post by raywood » Mon Jun 25, 2018 7:03 pm

That's a puzzling one. They have Super-L defined to open the "Start" menu, but in the default setting Super does it by itself. I tried replacing it with Ctrl-Function (i.e., my laptop's Ctrl-Fn key combination). That worked, weirdly: now the dialog shows Ctrl-L as the Start menu key combination, as if Fn = L -- and, sure enough, Ctrl also brings up the menu without hitting Fn. The good news is, Ctrl toggles the menu on and off. So that's a net improvement. Thank you!

Marziano
Level 7
Level 7
Posts: 1671
Joined: Thu Jan 04, 2018 1:00 pm

Re: Super-T for Terminal

Post by Marziano » Mon Jun 25, 2018 7:19 pm

You are welcome! Glad to hear that it worked out somehow.
Cheers
"Those are my principles, and if you don't like them...well, I have others." -Marx...
Groucho { Marx

raywood
Level 1
Level 1
Posts: 25
Joined: Sat Apr 09, 2016 1:45 pm

Re: Super-T for Terminal

Post by raywood » Mon Jun 25, 2018 7:45 pm

Spoke too soon. Sorry for the premature champagne. (Somehow, in real life, I've never actually had to apologize to anyone for champagne.) It seems the Ctrl function has been hijacked. So I've assigned Ctrl-WinKey to open the Start menu.

Also, I misread the dialog. I think that, when it says Super L, it doesn't mean Super-L. It means the left-hand Super key.

But now I think it all works.

Post Reply

Return to “Xfce”