[UPDATED][SOLVED] kde application appearance in Xfce in LM 19

Forum rules
Before you post please read how to get help
Post Reply
jgsutton
Level 1
Level 1
Posts: 16
Joined: Wed Jul 15, 2015 5:38 pm
Location: New Mexico, US

[UPDATED][SOLVED] kde application appearance in Xfce in LM 19

Post by jgsutton » Tue Jul 17, 2018 1:48 pm

I just upgraded from LMDE2 Mate but running xfce desktop, to LM 19 xfce. I use a couple of kde applications (k3b, digicam, etc) which I loaded post install. In LM 19 xfce the appearance of these kde applications has problems. There are no icons in the application menus or toolbars and fonts are different from what I've seen in the past. I tried loading k3b-extrathemes but that doesn't seem to effect the icons or fonts in these kde apps.

I'm guessing that I'm missing some necessary package to get the correct appearance but I don't have a clue as to what may be needed. Any help or pointers would be appreciated.

--John
Last edited by jgsutton on Thu Jul 19, 2018 10:09 am, edited 2 times in total.

User avatar
phd21
Level 17
Level 17
Posts: 7016
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: kde application appearance in Xfce in LM 19

Post by phd21 » Tue Jul 17, 2018 2:27 pm

HI jgsutton,

Install the "kde-runtime" from the Software Manager or Synaptic Package Manager (SPM) and restart ...

Hope this helps ...
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

User avatar
richyrich
Level 19
Level 19
Posts: 9007
Joined: Mon May 04, 2009 8:31 pm

Re: kde application appearance in Xfce in LM 19

Post by richyrich » Tue Jul 17, 2018 2:35 pm

And also, you just might need the oxygen-icon-theme.

jgsutton
Level 1
Level 1
Posts: 16
Joined: Wed Jul 15, 2015 5:38 pm
Location: New Mexico, US

Re: kde application appearance in Xfce in LM 19

Post by jgsutton » Tue Jul 17, 2018 3:03 pm

Installed both kde-runtime and oxygen-icon-theme, restarted but the kde apps still look the same.

Something else must be missing.

User avatar
phd21
Level 17
Level 17
Posts: 7016
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: kde application appearance in Xfce in LM 19

Post by phd21 » Tue Jul 17, 2018 3:50 pm

Hi jgsutton,

That is odd. Installing the "kde-runtime" should install the oxygen theme as well. Did you restart after installing this (you should)?

You can try going into the "Synaptic Package Manager (SPM)" search for "K3b" right-click it and install all recommended and suggested packages, do not install all the recommended and suggested packages with "digiKam" other than its digikam-doc package. You might also consider installing the "ffmpeg", x264, x265, h264enc, & "kipi-plugins". DigiKam also has an AppImage you might try...

I am currently in Linux Mint 19 Xfce with the full KDE desktop installed and it is working well.

You can also reinstall K3b and DigiKam which sometimes helps.


Hope this helps ...
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

jgsutton
Level 1
Level 1
Posts: 16
Joined: Wed Jul 15, 2015 5:38 pm
Location: New Mexico, US

Re: kde application appearance in Xfce in LM 19

Post by jgsutton » Tue Jul 17, 2018 5:28 pm

phd21,

Thanks for your patience. I added from k3b suggested k3b-extrathemes, k3b-il8n, and kde-config-cddb, everything else there was already installed as was ffmpeg. No difference. I added x265, x265 and h264cenc, kipi-plugins which also made no difference. Completely removed k3b and digikam and reinstalled with no joy again. Most of the stuff I installed in the initial build was installed using apt instead of SMP but I don't think that should have made a difference.

BTW, oxygen-icon-theme does get loaded with kde-runtime.

If you have any other thoughts please let me know.

Thanks.

User avatar
phd21
Level 17
Level 17
Posts: 7016
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: kde application appearance in Xfce in LM 19

Post by phd21 » Tue Jul 17, 2018 6:01 pm

Hi jgsutton,

You are welcome...

Assuming you restarted afterward that should have worked.

It would help to know more about your system setup. If you run "inxi -Fxzd" from the console terminal prompt, highlight the results, copy and paste them back here, that should provide enough information.
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

jgsutton
Level 1
Level 1
Posts: 16
Joined: Wed Jul 15, 2015 5:38 pm
Location: New Mexico, US

Re: kde application appearance in Xfce in LM 19

Post by jgsutton » Tue Jul 17, 2018 6:29 pm

Yes, I've restarted multiple times. Wasn't sure you meant logout/in or reboot so I rebooted.

The information from inxi as requested:
> inxi -Fxzd
System: Host: naboo Kernel: 4.15.0-24-generic x86_64 bits: 64 gcc: 7.3.0
Desktop: Xfce 4.12.3 (Gtk 2.24.31) Distro: Linux Mint 19 Tara
Machine: Device: desktop System: LENOVO product: 10A9CTO1WW v: ThinkCentre M93p serial: N/A
Mobo: LENOVO model: SHARKBAY v: SDK0K11826 WIN serial: N/A
BIOS: LENOVO v: FBKTB9AUS date: 11/13/2015
CPU: Quad core Intel Core i7-4790 (-MT-MCP-)
arch: Haswell rev.3 cache: 8192 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 28736
clock speeds: max: 4000 MHz 1: 1097 MHz 2: 1097 MHz 3: 1097 MHz
4: 1097 MHz 5: 1097 MHz 6: 1097 MHz 7: 1098 MHz 8: 1097 MHz
Graphics: Card: NVIDIA GF119 [GeForce GT 620 OEM] bus-ID: 01:00.0
Display Server: x11 (X.Org 1.19.6 )
drivers: nouveau (unloaded: modesetting,fbdev,vesa)
Resolution: 1920x1200@59.95hz
OpenGL: renderer: NVD9 version: 4.3 Mesa 18.0.5 Direct Render: Yes
Audio: Card-1 Intel 8 Series/C220 Series High Def. Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Card-2 NVIDIA GF119 HDMI Audio Controller
driver: snd_hda_intel bus-ID: 01:00.1
Sound: Advanced Linux Sound Architecture v: k4.15.0-24-generic
Network: Card: Intel Ethernet Connection I217-LM
driver: e1000e v: 3.2.6-k port: f040 bus-ID: 00:19.0
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives: HDD Total Size: 6371.2GB (22.4% used)
ID-1: /dev/sda model: SAMSUNG_MZ7LF120 size: 120.0GB temp: 30C
ID-2: /dev/sdb model: Samsung_SSD_850 size: 250.1GB temp: 0C
ID-3: USB /dev/sdc model: 10EAVS_External size: 1000.2GB temp: 0C
ID-4: USB /dev/sdd model: Elements_107C size: 5000.9GB temp: 0C
Optical-1: /dev/sr0 model: PLDS DVD-RW DH16AFSH
rev: DL31 dev-links: cdrom,cdrw,dvd,dvdrw
Features: speed: 40x multisession: yes
audio: yes dvd: yes rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
Partition: ID-1: / size: 29G used: 8.9G (33%) fs: ext4 dev: /dev/sda3
ID-2: /home size: 80G used: 19G (25%) fs: ext4 dev: /dev/sda4
ID-3: swap-1 size: 1.26GB used: 0.00GB (0%)
fs: swap dev: /dev/sda1
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 41.0
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 234 Uptime: 1:07 Memory: 2171.9/7900.5MB
Init: systemd runlevel: 5 Gcc sys: 7.3.0
Client: Shell (tcsh 6.20.00) inxi: 2.3.56

I used the "Linux Mint 19 "Tara" - Xfce (64-bit)" ISO for the fresh install. Since this was a rebuild from LMDE2 Mate, my home directory with all the old configs was carried over to the new system. Used the Update Manager to get current and then I added my usual extra tools using an apt install script I wrote. I'm guessing that the old Mate system had some packages that came with it that made the kde apps appear properly even after I added xfce to LMDE2 Mate. Don't know if that info is useful but I offer it just in case it might be.

User avatar
MtnDewManiac
Level 6
Level 6
Posts: 1376
Joined: Fri Feb 22, 2013 5:18 pm
Location: United States

Re: kde application appearance in Xfce in LM 19

Post by MtnDewManiac » Tue Jul 17, 2018 7:36 pm

I wouldn't have tried using the same user directory (and, therefore, all of the previous configuration/etc. files) from a Debian-based distro on an Ubuntu-based one. Perhaps that is the root cause of your issue(s)?

But, just in case you were gifted with more good luck than such an activity should bring with it, lol, I do remember reading the release notes on Clem's blog some time ago for one of the Mint Xfce releases. I believe it was Mint 18 (it might have been 17, but I'm pretty sure it was 18). There was some mention of what to do if one's KDE (Qt) applications had issues of the sort that you describe (or, at least, similar). The solution was really simple. Take a look at those release notes.

Actually, I just found it, so I'll paste it here. Again, this was for a previous version of Mint, but it might solve your issue. As someone already stated, remember to log out (I like to reboot) when making changes in hopes of fixing problems.
Issues with KDE apps

If you're experiencing issues with KDE apps (Okular, Gwenview, KStars..etc) run the following command:

apt install kdelibs-bin kdelibs5-data kdelibs5-plugins
Wait a minute... I just had a hunch and checked the release notes for the version of Mint that you installed and are having trouble with. The exact same text is in there! You DID read the release notes for the distro you were about to install, didn't you?

Regards,
MDM
Mint 18 Xfce 4.12.

If guns kill people, then pencils misspell words, cars make people drive drunk, and spoons made Rosie O'Donnell fat.

User avatar
phd21
Level 17
Level 17
Posts: 7016
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: kde application appearance in Xfce in LM 19

Post by phd21 » Tue Jul 17, 2018 8:26 pm

Hi jgsutton,

1.)
jgsutton wrote:Yes, I've restarted multiple times. Wasn't sure you meant logout/in or reboot so I rebooted.
I meant restart, so you did right by that.

2.) You do not have the nVidia drivers installed for your "GeForce GT 620" video card, you are using the default "nouveau" driver. This may be a problem.

NVIDIA: how to install the latest video card drivers - Easy Linux tips project
https://sites.google.com/site/easylinux ... nvidia-PPA
jgsutton wrote: Graphics: Card: NVIDIA GF119 [GeForce GT 620 OEM] bus-ID: 01:00.0
Display Server: x11 (X.Org 1.19.6 )
drivers: nouveau (unloaded: modesetting,fbdev,vesa)
Resolution: 1920x1200@59.95hz
OpenGL: renderer: NVD9 version: 4.3 Mesa 18.0.5 Direct Render: Yes

3.)
jgsutton wrote:I used the "Linux Mint 19 "Tara" - Xfce (64-bit)" ISO for the fresh install. Since this was a rebuild from LMDE2 Mate, my home directory with all the old configs was carried over to the new system. Used the Update Manager to get current and then I added my usual extra tools using an apt install script I wrote. I'm guessing that the old Mate system had some packages that came with it that made the kde apps appear properly even after I added xfce to LMDE2 Mate. Don't know if that info is useful but I offer it just in case it might be.
I personally do not think that copying Home folders from a completely different Linux system into another Linux system is a good idea especially if that included any of the hidden system and application configuration folders. This could be a big problem with all kinds of stuff. There is nothing wrong with copying and restoring your previous Home folder's data folders like Documents, Pictures, Music, Videos, etc...


Hope this helps ...
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

jgsutton
Level 1
Level 1
Posts: 16
Joined: Wed Jul 15, 2015 5:38 pm
Location: New Mexico, US

Re: kde application appearance in Xfce in LM 19

Post by jgsutton » Tue Jul 17, 2018 8:59 pm

@mdm

You got me, I did NOT read the release notes. However the packages you mentioned are already installed, not the problem.

@ phd21

To test the idea that it is my copied home directory that is causing the problem I created and new user and logged on as that user. K3b, digikam and other kde apps look as expected. That was the problem!!!!

Thanks to all who offered their advice in helping me solve this problem.

--John

User avatar
phd21
Level 17
Level 17
Posts: 7016
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: kde application appearance in Xfce in LM 19

Post by phd21 » Tue Jul 17, 2018 9:14 pm

Hi John (jgsutton),

You are welcome from all of us that replied...

The "kde-runtime" covers the KDE requirements from the Linux Mint release notes, the oxygen theme, and more...

Creating a new "admin" user is always a good idea for testing this kind of thing, and because if something goes wrong with the current user you can login as another one.
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

jgsutton
Level 1
Level 1
Posts: 16
Joined: Wed Jul 15, 2015 5:38 pm
Location: New Mexico, US

Re: [SOLVED] kde application appearance in Xfce in LM 19

Post by jgsutton » Thu Jul 19, 2018 10:08 am

And the answer is ...

a missing .config/qt5ct/...

Background:
It was suggested that it is not a good idea to copy you configuration files from from one distro to another. This may be true but there is a lot of work in setting up your configuration and I didn't want to lose it all, especially my desktop/window manager/panel settings. So I set about looking for the problem in my old configuration. What I found was that there was a missing configuration in my .config directory - gt5ct/ (which can be created and altered by the qt5ct tool).

When adding a new user .config is populated with qt5ct with other defaults configs. However, qt5ct is not created if missing in an existing .config unless you run qt5ct (not sure if this is a bug or not). When I copied .config/qt5ct from a freshly created user configuration to my existing configuration my kde apps appearance took on their proper look.

I hope this is useful to someone else.

--John

Post Reply

Return to “Xfce”